openmediavault

The open network attached storage solution

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

News

  • New

    Hello board,

    I have the follwing setup:
    - a mergerfs pool
    - a sharedfolder Videos in this pool
    - this sharedfolder is used as a NFS share

    Then my emby server (in another VM) is relying on this NFS share. And my android Emby app is supposed to access in direct to the movie through the NFS share.

    My problem is: the nfs share doesn't work unless I reset the permissions (using the resetperm plugin) to pure POSIX rights.

    But somehow, every now or then (no idea of the frenquency yet - couple of hours maybe?), the ACL reappear and break the NFS share again. I have to reset the permissions and it instantly works again.

    Is there a way to debug this?

    Is there a permanent swith to disable the ACL and prevent them from reappearing once and for good?

    Thanks a lot!
  • New

    Hi I'm attempting a fresh OMV 4 install from scratch from a previous OMV 3.x updated install. I have an SSD for the OS and 5 HD's formatted with ext4 in the previous OMV version. Note no RAID. After the successful OMV 4 install I've noticed all drives are visible in the Physical Disks table but two drives are missing in the File Systems folder. No matter what I try, I can't get these drives in the file system and then mounted.
    I've tried:
    1. Multiple re-installs
    2. Manually created an entry in fstab and mounted successfully, but this vanishes with reboot
    3. "Create" file system: tried to recreate the file system wiping out all my old files. Formatting looks like it's working with Status=Initializing, but when done the entry vanishes again

    I'm out of ideas. Any guidance would be greatly appreciated.
    Thanks
    Kris
  • New

    Hello, I'm using for some months ARRAKIS beta (now 4.1.0-1) and it works good.
    I have installed also OMV-extras.org stable repo, plexmediaserver repo and some plugins.
    Now OMV 4 become stable (4.1.3 in this moment) so I'd like switch to stable version.
    I must change repositories? How is the correct way of doing the switch from beta to stable without loosing my data and my OMV configuration?
    Thanks a lot for the help

    Ciro
  • New

    hello there, so i was tinkering with setting up a Web File Manager/explorer in docker (with something called FilleRun) and i made a softlink of / in / (root?) and now when i try to login to OMV Web UI it gives me: Failed to connect to socket: Permission denied

    when i login to CLi through SSH and try to run a command with SUDO (say: sudo nano) it gives me

    Source Code

    1. sudo: /etc/sudoers is owned by uid 33, should be 0
    2. sudo: no valid sudoers sources found, quitting
    3. sudo: unable to initialize policy plugin




    what did i f*ck up? and is there a fix to this?

    sorry for wasting your time :)
    regards


    edit: i can still login through SSH with ROOT and my USER

    edit 2, after reebooted the system i got a white page with this when trying to access webUI
  • New

    Hi again,

    I also have an issue with newly installed clamav plugin. Once I try to access it's config page I get:

    Failed to execute XPath query '//services/clamav'.


    Source Code

    1. Error #0:
    2. OMV\Config\DatabaseException: Failed to execute XPath query '//services/clamav'. in /usr/share/php/openmediavault/config/database.inc:78
    3. Stack trace:
    4. #0 /usr/share/openmediavault/engined/rpc/clamav.inc(60): OMV\Config\Database->get('conf.service.cl...')
    5. #1 [internal function]: OMVRpcServiceClamAV->getSettings(NULL, Array)
    6. #2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
    7. #3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getSettings', NULL, Array)
    8. #4 /usr/sbin/omv-engined(536):

Unread Threads

Topic Replies Last Reply

How long is a user banned for multiple posting?

146

votdev

Upgrade Omv 2->3->4 - Hilfe

7

ryecoaaron

Error "/dev/sda not large enough to join array" when trying to "Grow" Raid Mirror

3

ryecoaaron

OMV 4 on Debian 9 problem install

59

pinajj

Subsonic Plugin

2

ryecoaaron

Recent Activities

  • votdev -

    Replied to the thread How long is a user banned for multiple posting?.

    Post
    The plugin is updated and activated
  • ryecoaaron -

    Replied to the thread OMV 4.x Upgrade 2.x -> 4.x Upgrade Omv 2->3->4 - Hilfe.

    Post
    Quote from bladecgn: “The property 'show_tab' does not exist in the model 'conf.service.virtualbox'. Any suggestion on how to fix it? ” This is a browser cache issue. Quote from bladecgn: “remot desktop is still having issues. ” I don't know…
  • ryecoaaron -

    Replied to the thread OMV 3.x Error "/dev/sda not large enough to join array" when trying to "Grow" Raid Mirror.

    Post
    Quote from Phil: “Does the way you suggest mean that I would have to rely on a delayed scheduled job to run before the data is synced? ” Yes. Do you really need real time sync? realtime sync can bad sometimes especially when you accidentally delete…
  • pinajj -

    Replied to the thread OMV 4.x OMV 4 on Debian 9 problem install.

    Post
    Hello donh. I did not expect so much complication in this process. For now I'm going back to the solution I was using (OMV4 standalone). In a while, I will try again, with a new installation of Debian9. Anyway. Many, many thanks for your patience and…
  • ryecoaaron -

    Replied to the thread OMV 4.x Network-manager.

    Post
    Quote from dbbdark: “But .... apt not allow that ” Installing network-manager is a bad idea since OMV manages the network settings. Installing packages from sid is generally a bad idea as well.
  • Mr Smile -

    Replied to the thread OMV 4.x Resolved VirtualBox does not work anymore.

    Post
    Thanks for this explanation! :) I also remember that virtualbox from virtualbox.org has a lot of freaky dependencies and installs a lot of unwanted stuff. Didn't know that the debian version is so much better in this regard. This actually IS a huge…
  • ryecoaaron -

    Replied to the thread problems installing OMV within Hyper-V 2016.

    Post
    Quote from jhayward: “Hyper-V is a bit different from VMware ESXi as it supports pass thru disks. ” ESXi supports this too (rdm). I have passthrough disks on my server running ESXi. Quote from jhayward: “Is using OMV under Virtualisation not…
  • ryecoaaron -

    Replied to the thread OMV 4.x Resolved /sharedfolders is empty.

    Post
    I bind mount is created in that folder for each shared folder. Creating one new shared folder is the easiest way to create these. And yes, it will create the mountpoint for every shared folder on your system.
  • nativeworld -

    Wrote a comment on Mark’s wall.

    Wall Comment
    Hallo, Du hattest mich angeschrieben?