openmediavault

The open network attached storage solution

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

News

  • New

    Hi, I'm really struggling here. I can't seem to find anyone with the same error that I'm getting, I think I've corrupted something. I get the following:

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; docker images 2>&1' with exit code '1': Cannot connect to the Docker daemon at unix:///var/run/docker.sock. Is the docker daemon running?

    I read something that said that the Shared Folder location can't be on the Union FS, so I tried to put it on the Data drive, but got the wrong one, and then when I went to fix it all up again, it's now not working. I think I must have done something wrong and corrupted something???

    I tried reinstalling the Docker Plugin, and opening up the permissions, but I just can't figure out why I cannot set a new Base Path for this Docker plugin...I don't know whether the problem is with the plugin or the folder I'm trying to set?
  • New

    I moved one of my OMV machines (DESTINATION) to mom's house to rsync from my Gen8 (SOURCE) at home. I can SSH shell at her machine back to the Gen8, so port forwarding rule and public key settings are all good. However, when it remote rsync (pull) with this:

    Source Code

    1. rsync -av --delete --numeric-ids --rsh=/usr/bin/ssh -p 8822 -i /var/lib/openmediavault/ssh/keys/BACKUP_KEY root@source.duckdns.org:/srv/dev-disk-by-label-SOURCE/SOURCE_FOLDER/ /srv/dev-disk-by-label-DESTINATION/.

    it doesn't work and prompts this:

    Source Code

    1. Unexpected remote arg: root@source.duckdns.org:/srv/dev-disk-by-label-SOURCE/SOURCE_FOLDER/
    2. rsync error: syntax or usage error (code 1) at main.c(1348) [sender=3.1.1]
    What's wrong with the syntax? Thanks.
  • New

    Hi all,

    Just simple question.

    I've noticed that Plex hasn't been updated for more than 2 months now.
    There has been many updates released to Plex Media Server, some of them major updates.
    These include Plex Web update, Improved collections and a ton of fixes.

    Has the plugin been abandoned?

    Regardless if it is or not, thank you for the work so far.

    Thank you,
    Ralms.
  • New

    I already have 2 hard drives available to use. One inside an old NAS (which I'm replacing) and one inside a Vantec USB 2.0 enclosure with it's own power source (not being used at the moment)

    Option 1: Odroid HC-2. One drive connected via SATA and one drive connected via USB. The HC-2, and power supply would cost $131 (Canadian) in total

    Option 2: Rock64. Both drives would have to be connected via USB. The board + power + shipping would be $83 (Canadian) in total.

    All I need is a NAS for file serving, and I'm not planning on a Plex server. I also don't need/want anything fancy like RAID. It's over kill for my purposes.

Unread Threads

Topic Replies Last Reply

Which energy efficient ARM platform to choose?

57

Valsi

Docker Plugin Error Setting New Base Path

4

gabs247

Import existing RAID1 to filesystems

3

votdev

Upgrade Debian 9 and 4.x

45

votdev

default Login - first login?

11

cabrio_leo

Recent Activities

  • Valsi -

    Replied to the thread Which energy efficient ARM platform to choose?.

    Post
    Hi, have ordered last week following parts: ODROID-HC1 : Home Cloud One plus 6A powersupply and other parts from Hardkernel for having a complete home Server. Additionally 1TB Seagate BarraCuda 2,5'' So I'm looking forward to see the improvement to my…
  • gabs247 -

    Replied to the thread OMV 3.x (stable) Docker Plugin Error Setting New Base Path.

    Post
    Quote from subzero79: “I believe your issue might be that the drive has noexec flag. Is it ext4? If you need to change the noexec flag permanently go to the wiki in my signature you can information on how to change this correctly” PRobably, I'll…
  • subzero79 -

    Replied to the thread OMV 3.x (stable) Docker Plugin Error Setting New Base Path.

    Post
    I believe your issue might be that the drive has noexec flag. Is it ext4? If you need to change the noexec flag permanently go to the wiki in my signature you can information on how to change this correctly
  • gabs247 -

    Replied to the thread OMV 3.x (stable) Docker Plugin Error Setting New Base Path.

    Post
    Ok, first stupid mistake fixed...I should have known that you just need to use the --reinstall flag to get it to reinstall the missing lib files: Source Code (1 line)Just need to figure out the docker problem somehow...
  • gabs247 -

    Replied to the thread OMV 3.x (stable) Docker Plugin Error Setting New Base Path.

    Post
    Good news (NOT) in trying to remove the /var/lib/docker folder so that I could symlink it to another location as specified here: Move Docker Base location issues I've now accidentally (IDIOT) deleted my /var/lib/openmediavault folder! Please tell me…
  • votdev -

    Replied to the thread OMV 4.x (testing) Import existing RAID1 to filesystems.

    Post
    Quote from JoZerByte: “Exactly the same problem. Trying a fresh install of OMV 4 with an existing RAID1 not showing on the GUI-File Systems menu. I can manually mount the array from the command line with no issues Here's my blkid…
  • votdev -

    Replied to the thread Upgrade Debian 9 and 4.x.

    Post
    Quote from bowe: “Quote from thexma: “thank you @Wolf2000, replace new lines fixed it: line 109: def remove(wr, selfref=ref(self)): replace with: def remove(wr, selfref=ref(self), _atomic_removal=_remove_dead_weakref): line 117:…
  • gabs247 -

    Posted the thread OMV 3.x (stable) Docker Plugin Error Setting New Base Path.

    Thread
    Hi, I'm really struggling here. I can't seem to find anyone with the same error that I'm getting, I think I've corrupted something. I get the following: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin;…
  • cabrio_leo -

    Replied to the thread default Login - first login?.

    Post
    From the picture in the first post I would assume it shows a local console login, no SSH. I you want to use 'root' for login, you have to use the approprate password. This is normally set during the installation process, if the default omv installer is…
  • Dropkick Murphy -

    Replied to the thread OMV 4.x (testing) OMV on Buffalo LS-WVL.

    Post
    Please show Source Code (1 line) and Source Code (1 line)Also Source Code (1 line)would be helpful.