openmediavault

The open network attached storage solution

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

News

  • New

    Hi to the community,
    I have a problem when I try to connect to https.
    When i use a certificate created from omv the connection works correctly except the security message. But when I use a Letsencrypt's certificate created from the omv plugin and still available, i get the following message when saving changes:

    Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-e1645972-5803-4343-95d0-f31849e9f23b.key") failed (SSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch) nginx: configuration file /etc/nginx/nginx.conf test failed

    I understand that the problem is related to NGINX but I do not know what solution is used to solve this problem.
    Would you have any ideas to help me?
    Thanks
  • New

    my Current version says under Overview it is 0.4.31 ( Fedaykin ).
    I tried auto update ..no luck.
    Then I tried
    apt-get update && apt-get dist-upgrade && omv-update
    and then
    omv-release-upgrade
    with no luck .


    How can I Upgrade ?
    If I down the latest iso will it perform and upgrade ?
    Thanks ,
    John
  • New

    Hi,
    This is my first NAS build and I'm new to linux. I tried FreeNas and Amahi. DId not like those 2 and moved to OMV. I like it. I'm facing this issue.
    The OMV (4.0.16) is running in a pen drive which is 32 gb.
    I have a 3TB and 1 TB hardisks connected through SATA. I'm trying to create a file system with the 3tb and 1tb hard disks. After all the steps are completed and the "Create File Systems" popup windows says done. But the file systems windows is not showing the hard disks.
    I tried with both EXT3 and EXT4.
    I also tried using the command line. There also the same.
    THanks for the help in advance.
  • New

    I ran OMV on a Banana Pi between 2016-2018. It worked well enough for a single-user Samba share but I always saw potential to use OMV for more. I’d never built a desktop computer before so it seemed a good time to try something new. The hardware is somewhat random but it works well enough



    Specs:

    • Motherboard: Gigabyte GA-J1900N-D3V - €86.03
    • Power Supply: 450W Corsair CX450 80+Bronze - €49.60
    • Case: Cooler Master | Elite 110 Mini-ITX - €41.68
    • RAM: 8GB (2 x 4GB) Samsung DDR3L SO-DIMM 1600Mhz 1,35V - free
    • Storage: 2 x 2TB Seagate Barracuda 2,5, 1 x 1TB Seagate Momentus 2,5 (5TB total) - €160
    • OS drive: Samsung Ultra Fit USB - €14.99
    • Additions: Mini-PCIE SATA card - €11.99 (Amazon)
    Total: €361.29 (Prices current, based upon the cost of buying new as of 15.1.18)



    Motherboard

    The motherboard was a gamble because I had read lots of very poor reviews, mostly in regards to issues with the older BIOS revisions (F1, F2 & F3). On the other hand, the board uses little power, is fan-less, the specs…

Unread Threads

Topic Replies Last Reply

Destroyed file system?

11

henfri

ZFS mountpoint full of folders

12

subzero79

Https connexion with Letsencrypt's certificate doesn't work

0

Upgrade ?

1

subzero79

OMV 3: Formatting and mounting 4TB usb drive

20

tkaiser

Recent Activities

  • henfri -

    Replied to the thread Destroyed file system?.

    Post
    md0 IS your whole raid.
  • subzero79 -

    Replied to the thread OMV 4.x (testing) ZFS mountpoint full of folders.

    Post
    The log shows that zfs-mount fails because the /mnt/zfs folder is full of folders. Try one more time with the pool unmounted, remove /mnt/zfs make sure no data is in there before you do that. Now with no folders in /mnt reboot now run again the…
  • pat6634 -

    Posted the thread OMV 3.x (stable) Https connexion with Letsencrypt's certificate doesn't work.

    Thread
    Hi to the community, I have a problem when I try to connect to https. When i use a certificate created from omv the connection works correctly except the security message. But when I use a Letsencrypt's certificate created from the omv plugin and still…
  • subzero79 -

    Replied to the thread OMV 0.4 Update Upgrade ?.

    Post
    No way you're system is gonna survive that upgrade. Clean install...... As usual disconnect data drives before a clean install
  • tkaiser -

    Replied to the thread OMV 3.x (stable) OMV 3: Formatting and mounting 4TB usb drive.

    Post
    Quote from ExRaspberry: “Maybe only etcher has problems velidating checksum? ” Seriously? If Etcher is reporting a problem it's not an Etcher problem but Etcher reporting writing failed (a hardware problem!). Only solution: throw the card away. Or…
  • johnism -

    Posted the thread OMV 0.4 Update Upgrade ?.

    Thread
    my Current version says under Overview it is 0.4.31 ( Fedaykin ). I tried auto update ..no luck. Then I tried apt-get update && apt-get dist-upgrade && omv-update and then omv-release-upgrade with no luck . How can I Upgrade ? If I down the latest iso…
  • hoppel118 -

    Replied to the thread OMV 4.x (testing) ZFS mountpoint full of folders.

    Post
    Quote from Weitenbummler: “Sorry, for the posts. I‘ve got everytime an error when I send my answer.” It‘s offtopic, but I also have this problem, if I use the WebInterface at my desktop/notebook to post something here in this forum...
  • Weitenbummler -

    Replied to the thread OMV 4.x (testing) ZFS mountpoint full of folders.

    Post
    Sorry, for the posts. I‘ve got everytime an error when I send my answer.
  • Weitenbummler -

    Replied to the thread OMV 4.x (testing) ZFS mountpoint full of folders.

    Post
    boot.txt is attached. ZFS-Pool: RAID-Z1 size 8.12T
  • Weitenbummler -

    Replied to the thread OMV 4.x (testing) ZFS mountpoint full of folders.

    Post
    boot.txt is attached. ZFS-Pool: Source Code (135 lines)