Search Results

Search results 1-20 of 46.

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from tinh_x7: “After I changed the WebRoot path from /var/www/openmediavault/ to /media/54bf67db-da31-4c50-bb3c-27140944b223/www/owncloud, this is the new log: It said>>Error: the configuration object is in use... ” It looks like your dns entries are not setup correctly, based on: "To fix these errors, please make sure that your domain name was entered correctly and the DNS A record(s) for that domain contain(s) the right IP address" Have you recently made a change to your DNS records? It …

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from gsola96: “I posted some time ago answering tinh_x7 and because of that, I found that I cannot renew or create new certificates. I have port 80 forwarded to my OMV box but I get an error that let's encrypt can't "access" /var/www/openmediavault/acme-challenge/(some random string of numbers/letters). ” what does your lets encrypt log say? /var/log/letsencrypt/letsencrypt.log

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from mcgyver83: “ WARNING: The following packages cannot be authenticated! augeas-lenses libaugeas0 [/code] what's wrong?” try: Source Code (3 lines)

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from gsola96: “ I installed the let's encrypt client and when I try to run "letsencrypt (..............)" with the arguments, it keeps telling me that letsencrypt command does not exist. ” Are you running the command from the directory you cloned the github repository? The plugin clones it to /opt/letsencrypt

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from gsola96: “I clicked in the LetsEncrypt.js and it opened another tab with adress: view-source:http://192.168.1.230/js/omv/module/admin/diagnostic/log/plugin/LetsEncrypt.js So I think is the first case. Thanks for your time.” I'm having trouble reproducing the issue; I've tried on multiple virtual machines. Have you tried uninstalling the plugin and reinstalling? How about restarting your computer?

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from gsola96: “ This is my web console. 3 errors. The last one is related to Let's encrypt: ” Does it say which LetsEncrypt.js file it is? There are two: module/admin/diagnostic/log/plugin/LetsEncrypt.js module/admin/service/letsencrypt/LetsEncrypt.js

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from gsola96: “I don't know what happens but I can't access the plugin configuration now. I tried installing and uninstalling several times and no luck. When I click the let's encrypt plugin in the web, I don't get any response. Any ideas?” If you open your web browsers web console do you see any errors? (Firefox: Options > Developer > Web Console)

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from raulfg3: “only as sugest to improbe pluging, if possible try to add letsencrypt.log to OMV webGUI Log so I can see what happens if something goes wrong. Other plugin like failbam or bittorrent add his log if you want to revise code.” The log is now in OMV with the new 2.4 release Quote from papka__: “Finally problem found! Actually, if you want to get correct certificate - you should't try "Test certificate". Once you tried - you always will get connected to wrong staging server. So s…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from papka__: “But there were no errors during generation. And actually I have no idea what should I change. It's 3 fields domain/e-mail/webroot. All of them contain correct values (e-mail used for account only, for webroot used default value). Any ideas?” I've seen the happy hacker ca root cert before. I'm still struggling to figure out why this happens. I know it happens when a cert is acquired from the Let's Encrypt Test server; however, the plugin never changes what server the cert is …

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from tinh_x7: “I got multiple crons also. Whenever LE failed to generate the certs or if you re-install the plug-ins, then you'll get duplicate cron jobs. I also noticed that if I uninstall the plug-in, re-install it, then regenerate the certs, the expiration date stay the same. I thought it suppose to extend the expiration date.” Currently crons are not being uninstalled. I will fix that in the next release. Regenerating certs does not give you a new expiration date because I have the fla…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from tinh_x7: “My IP is dynamic, that's why I'm using DDNS. No, my domain, and my subdomain are on different hosts with different IPs.” That is why you cannot authenticate both of your certs. You will have to use Lets Encrypt on each machine individually. Quote from raulfg3: “please revise creation of cron jobs, I finish with 3 jobs. Can I delete 2 of then?forum.openmediavault.org/index…66a8bdd09daf7cd8feef40ca9” I was worried about this. I will have to investigate a way of making it more …

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from tinh_x7: “I got this error. By the way, where do I see LE's log at ? Edit: If I don't include my main domain in the cert, then it generated fine. I don't understand why it wouldn't allow me to include my main domain in it.” Logs: /var/log/letsencrypt What is the IP of your domain, what is the IP of the subdomain? Are they the same? Do they take you to the same part of your website? Probably not. Look at where your authorization files are being placed. They are going in the same direct…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from tinh_x7: “It isn't populated. I"m using LE for owncloud, not OMV. So my webroot should be /media/54bf67db-da31-4c50-bb3c-27140944b223/www/owncloud ? What if my I want to use LE for both OMV and OC?” Correct your webroot is /media/54bf67db-da31-4c50-bb3c-27140944b223/www/owncloud Check out my second post in this thread, I elaborated on how to use SNI Proxy which will allow you to authenticate all of your lets encrypt certificates from a single location on your file system.

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from mcloum: “Can you explain more about SNI proxy and how it works? Is this a plugin in OMV or something you installed manually? From what i understand LE is expecting a response for my subdomains on port 80, but as they are running on ports 9091, 8081 etc then its not getting a response? SNI proxy solves this?” I updated my second post in this thread with more details and a specific use case. There is not a plugin for OMV, I compiled the source, but the binaries are listed as well. To yo…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from mcloum: “Yes but not the OMV gui, it points to the transmission install that is running on OMV on port 9091. If i point my browser at transmission.domain.co.uk i get access to my transmission so i know DNS is resolving correctly. The only thing i though was because transmission is protected by a password that letsencrypt wasnt getting the response it needed? I tested by turning off the authentication on transmission but still didn't work.” What are you serving on port 80? more specifi…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from raulfg3: “Hello, do not work for me: Error creating new cert :: Too many certificates already issued for: zapto.org, ddns.net ... Perhaps I need to try other day to avoid diary limit?” There is no way around this except to wait until Lets Encrypt allows you to request a cert again. Quote from raulfg3: “only as sugest to improbe pluging, if possible try to add letsencrypt.log to OMV webGUI Log so I can see what happens if something goes wrong. Other plugin like failbam or bittorrent ad…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from Foo Bar: “Got blank screen after install of your plug-in” When you refresh your browser does the web-gui load? How about after reboot? Maybe this will provide some insight: Constant WebGUI timeout errors

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from gsola96: “Is one self-signed for the same "BitTorrent" and I can't find a way to change it and tell BTSync to use the reliable Let'sEncrypt one.” I've never used BTSync but it looks like it may create a domain in nginx (/etc/nginx/sites-available/btsync) in that configuration you can add entries to the lets encrypt certs ssl_certificate /etc/letsencrypt/live/domain/fullchain.pem; ssl_certificate_key /etc/letsencrypt/live/domain/privkey.pem; Quote from tinh_x7: “@fubz, My OMV doesn't u…

  • openmediavault-letsencrypt

    fubz - - Plugins

    Post

    Quote from tekkb: “ @fubz you need to add git as a dependency in your control file. @ryecoaaron ” Oops, Added. Thank you Quote from gsola96: “ Thanks also to fubz, I think it's a great contribution since I've been using let's encrypt for a while now.” You're welcome!

  • Free SSL Certificates

    fubz - - General

    Post

    Quote from tinh_x7: “Does the plug-in has the feature for auto-renewal?” Yes it does. The plugin is now available in the OMV-Extras.org Testing repository. See my post here