Search Results

Search results 1-20 of 229.

  • LUKS disk encryption plugin

    riff-raff - - Plugins

    Post

    Is it possible so halt on boot and wait für the encrypted disks to be unlocked through ssh? I want to setup 2 encrypted drives and ZFS on top, so to prevent the pool to fail I need the drives unlocked quite early. Since there is almost no reboot, manual unlocking is fine for me, but it has to be possible through SSH, since I am physically not near the server. Edit: I managed to unlock my drives during boot by sticking to this howto Keyfile is stored in root directory.

  • I set up a VM on another machine to do some testing. I followed the same procedere as I did on my nas build. Istalled fresh OMV4, patched everything incl. 4.16, installed OMV-Extras, reboot, installed dpkg-dev Source Code (63 lines)So pretty much the same as on my main machine. Edit: After uninstalling und reinstalling the ZFS-Plugin, it works on the VM-machine .... don't know why .... Now I'll try on nas-machine.

  • i'lll get this error even with dpkg-dev installed ...

  • Well a Xeon E3 V3 4C/8T should not take half an hour to compile a kernel module .... I would not mess with a Pi for a NAS .... Installing ZFS-Plugin: Source Code (2 lines)why is there an architecture-failure?

  • well, its a quad core CPU, utilization during compile is almost zero.

  • so the solution should be installing dpkg-dev? I'll try that. My steps: fresh install of OMV4, patch all updates incl. kernel 4.16. Install dpkg-dev, install omv-extras, enabling stable+testing-repo. reboot. now apt-get update and install ZFS Source Code (4 lines) hangs there .... 15 min already Edit: Source Code (15 lines)hangs at that point for quite a while Edit: After finishing and reboot accessing ZFS-Plugin: Source Code (14 lines)running Source Code (1 line) drops the error, till next rebo…

  • I have a fresh and patched OMV 4.1.6 and try to install ZFS-Plugin. Installer hangs at Source Code (1 line) After waiting for an hour error-messages occur .... whats wrong with it? Source Code (1 line)Edit: I finally managed to install ZFS, but Source Code (1 line) running Source Code (1 line)enables ZFS, but why is the kernel module not initially loaded? Edit: A new approach with fresh OMV4, without patched Kernel 4.16 hangs at installing kernel-headers: Source Code (113 lines)Source Code (12 l…

  • User Backup / Fresh install

    riff-raff - - General

    Post

    I have a OMV3 runnig for quite a while. Now I want to upgrade to stable OMV4. I thought of a fresh setup to get rid of all old crap. I have to migrate a Nextcloud installation and my OMV users, since I do not know their passwords. For Nextcloud I found a suitable solution, but how do I backup and restore my OMV users? I do not need to backup their permissions, only user and their passwords, I can set permissions afterwards. How can I accomplish that? I have a Raid 1 with 2x8TB running for availa…

  • I have to pick up this oder topic because I expirience the same issue, but not after an upgrade from OMV. My OMV3 is running for quite long, I changed permissions for a shared folder and saw under all ACL user 1003 with read-permissions to all of my shared folders. The user 1003 does not show up under unsers tab. Source Code (1 line)does not list the 1003 user security issue?

  • NextCloud Installation Q & A

    riff-raff - - General

    Post

    Maybe delayed deploy? Did you try to switch release channel to 'beta' and back to stable? Worked for me a couple times with earlier upgrades.

  • openmediavault-letsencrypt

    riff-raff - - Plugins

    Post

    LE needs port 80 to be open and point to your webroot. So use OMV-GUI on a diffrent port (e.g. 8080) and point port 443 (ssl) and 80 to your NC with LE.

  • NextCloud Installation Q & A

    riff-raff - - General

    Post

    Activate the nginx server before creating the php pool. Check the path and privileges of the directory used as webroot. ACL/privileges should be www-data:www-data with 755 or less

  • MySQL no root access

    riff-raff - - Plugins

    Post

    The mySQL bug prevents me right now from upgrading to a fresh OMV4. I prefer a fresh setup. I tried a upgrade from a running OMV3 to OMV4 with MySQL etc. running and it worked as well. Edit: MySQL-management-site login works with omvadmin as account und resettet password.

  • MySQL no root access

    riff-raff - - Plugins

    Post

    Source Code (2 lines)

  • MySQL no root access

    riff-raff - - Plugins

    Post

    That is exactly what I did. Without management site, login attempts would not be possilble through GUI anyway. (exception would be a separate phpmyadmin-install, which I do not use) Since I wanted to setup Nextcloud as native install on a fresh OMV4, I had to prepare DB and DB user in advance.

  • MySQL no root access

    riff-raff - - Plugins

    Post

    I tried to login with 'root' and no password, with 'admin' and no password, with 'root' and 'openmediavault' and with 'admin and 'openmediavault'. None worked. I have to mention that I tried to reset the password through Plugin-GUI on another OMV installation in advance and since there it was not working I checked those combinations. After my login attempts failed, I used the reset password on my current setup as well and tried 'root' with 'my password' and 'admin' with 'my password' Have not ch…

  • MySQL no root access

    riff-raff - - Plugins

    Post

    Okay, I messed up, I ment this one where moreje answered before creating a new thread regarding the same topic

  • MySQL no root access

    riff-raff - - Plugins

    Post

    This function does not work.

  • MySQL no root access

    riff-raff - - Plugins

    Post

    One post and/or topic is enough

  • NextCloud Installation Q & A

    riff-raff - - General

    Post

    I till run my OMV3 with NC 12.XXX and I want to upgrade to NC 13, but in the updater I get - Check for expected files - The following extra files have been found: - .well-known from letsencrypt I guess. Up to now, I moved .well-known to another folder each time I updated NC, but this shoould be avoidable. I added Source Code (4 lines)For NC+LE to work, but still got this error.