Search Results

Search results 1-20 of 28.

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • [HowTo] SnapRAID in OMV

    Jonatron - - Plugins

    Post

    Do you use a script that you'd be willing to share?

  • [HowTo] SnapRAID in OMV

    Jonatron - - Plugins

    Post

    I see, thank you. In your opinion is a weekly whole array scrub best practice or should I schedule a lower percentage to run every few days? How stressfuly for a drive is a scrub?

  • [HowTo] SnapRAID in OMV

    Jonatron - - Plugins

    Post

    What is the snapraid-diff.conf for? I want to set up my scrubs to run on specific days and not 100% every 7 days. Does this run automatically or can I just set up my scrubs via cron?

  • Initramfs on clean installation

    Jonatron - - General

    Post

    I was able to resolve this issue by installing OMV4 onto a different SSD with my HBA disconnected, loading the WebUI, running apt-get update/upgrade and installing the Snapraid and Unionfilesystem plugins. I then rebooted, connected my HBA/drives and was able to successfully boot into OMV and mount all drives. I suspect it was missing drivers that was causing the issue.

  • Initramfs on clean installation

    Jonatron - - General

    Post

    Are you running OMV4?

  • Initramfs on clean installation

    Jonatron - - General

    Post

    Those errors are very similar to the issue I am having, but moving all my data around like that isn't really viable. I don't have a RAID set up, it's just ext4 drives with data on that I had been using mergerfs to pool. Your solution for me would be a very very very last resort. Did it shed any light for you on what might be causing this to happen, because I really see no reason why normal drives with only data on should cause this kind of issue.

  • Initramfs on clean installation

    Jonatron - - General

    Post

    Hi I decided to move my OMV to a smaller SSD as it was silly wasting a larger one for the OS drive and as I was doing this I decided to go for OMV4 rather than OMV3. I installed via USB as normal no problem and was able to get the OS to boot and access the WebGUI. However when I reconnect my drives via my HBA (LSI2008 in IT mode) the OS will not boot and it instead loads something called initramfs. What is causing this and how on earth do I fix it?

  • Quote from RPMan: “if you connect from outside (assuming you have mappedPort redirection from your router to mappedPort in OMV): ssh user@OmvHostIp -p mappedPort mappedPort is not the internal container port (!= 58846) ” I am only trying to connect on my local network, nothing remotely, so I have not set up any port forwarding at router level, is this correct or shoujld I do as you have suggested?

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    Running the command in my OMV host shows my static IP as assigned by my ISP and running it in my containers shows a different IP which I believe to be assigned by my VPN provider. Should I be satisfied with these tests?

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    Running ifconfig in the Deluge container returns the following: eth0 Link encap:Ethernet HWaddr 02:42:XX:XX:XX:XX inet addr:172.17.0.2 Bcast:172.17.255.255 Mask:255.255.0.0 inet6 addr: fe80::42:acff:fe11:2/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:28817 errors:0 dropped:0 overruns:0 frame:0 TX packets:31832 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:10213682 (9.7 MiB) TX bytes:5280841 (5.0 MiB) lo Link encap:Local Loopback inet addr…

  • Quote from gderf: “In the WebUI, have you made this setting? ” Yes, I can confirm that the box is ticked in the WebUI settings. Quote from raulfg3: “provide some screen capture of how do you configure deluge. ” Here are my settings, I have ports 8112 and 58846 passed through from the OpenVPN container to enable connection.

  • I am using the linuxserver/deluge docker and have it set up seemingly fine, I can connect to the WebUI no problem however I am unable to connect to the daemon via thinclient from a remote machine. I have tried setting port forwards both in OMV and in the Docker setup, I have also been running this container through an OpenVPN container and have the same problem. I can't seem to find any resources online to help with this issue, other than one comment that it could be caused by OMV itself. Does a…

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    I managed to get it working with a bit of trial and error, but I ended up speaking to the maintaner of the OpenVPN package and he said if you only want to access WebUis on your local network then you can avoid nginx completely by using the ROUTE variable and 192.168.1.0/24 or whatever your local network is. One issue I am having now however is that whilst I can access the Deluge WebUI I cannot access the deluge daemon, this was possible to fix I believe using a special nginx configuration.

  • Have you managed to find a solution to this?

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    I've managed to set OpenVPN up, but am now having trouble with nginx, it defaults to port 80 which is in use by OMV and I cant seem to find any way of changing this setting from Docker. Is it possible to change this default port, or should I bite the bullet and change OMVs port which is easier (but not my preference to avoid future complications)

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    Quote from gaelic: “Hi. It is possible, but it is a bit of a problem if you stop / start your openmediavault box frequently. My setup looks like this: - openvpn-client container (dperson/openvpn-client) - transmission container - jackett container - sonarr container - nginx container to provide access to transmission/jackett/sonarr 1. setup of the openvpn-client (name vpn, networkmode: bridge) 2. setup transmission with extra option: -net=container:vpn this means that transmission connects throu…

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    Quote from gaelic: “Quote from Jonatron: “Is it better to run nginx in a container or via the official plug-in? ” You have to run nginx as a container to access the other containers using the vpn container ... ” That does make sense when you put it like that!

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    Thanks for this, I'm gonna give it a go and see how it works. How can I ensure that all traffic from the containers only goes via the VPN when it is up and running, is it possible to include a killswitch on the OpenVPN container? Is it better to run nginx in a container or via the official plug-in?

  • Docker containers with VPN

    Jonatron - - Plugins

    Post

    I'm starting to set up various services with docker: SABnzbd, Radarr, Sonarr, rTorrent etc and would like at the very least to run SABnzbd and rTorrent through my VPN service. Am I better off figuring out how to do my own Dockers with the chosen services and an OpenVPN client, or can I use the OpenVPN plugin directly to OMV and run certain containers through that? I am very unaware of how Docker works, and so far am only using the images from the built in repo.

  • Best filesystem for MergerFS/SnapRAID

    Jonatron - - General

    Post

    Well, the new breakout cables arrived and the drives still weren't playing nicely, so I reinstalled OMV as the main boot OS and everything now seems to be working fine, I can only assume in this case that the issue was between Proxmox, the HBA and the PCI passthrough settings. All my drives are now happily formatted to ext4 and I've combined them using MergerFS. My issue now is that I wanted to run a torrent client/nzb downloader etc in VMs/containers through VPN, will this be possible with OMV,…