Search Results

Search results 1-20 of 545.

  • Configure OMV 4.1.3 with AD 10000+ users

    donh - - CIFS/SMB

    Post

    Quote from ryecoaaron: “Quote from donh: “sssd has been trying to improve speed for some time. I don't know what the limit is. ” At work, we use sssd connected to LDAP (sync'd from AD) with more than 10k users on Linux systems. Works well but we never try to enumerate all of them into a paginated web interface. I do have a couple of sssd Linux systems connecting to AD and while it seems to be just as fast as LDAP, it is very problematic. sssd has to be restarted at least five times a week. This …

  • Configure OMV 4.1.3 with AD 10000+ users

    donh - - CIFS/SMB

    Post

    Again I have not used this with more than 100 users and 5 groups. "OMV is not designed to manage 10000+ users." Managing users and groups is not my goal. That is better left to the various ldap / ad servers. sssd enumerates the users and groups for access rights to the shares. That is all debian and not depentant on OMV code. It works great for me. The speed is the question with 10,000 users. sssd has been trying to improve speed for some time. I don't know what the limit is. The only way to kno…

  • Configure OMV 4.1.3 with AD 10000+ users

    donh - - CIFS/SMB

    Post

    I don't have 10000 users so take this with a grain of salt. I use sssd instead of winbind. It is a much newer way of doing things. I have a script in this thread that works for most windows ad. forum.openmediavault.org/index…Directory-LDAP-Revisited/ You might have to tune it for 10000 users. Also see this forum.openmediavault.org/index…highlight=ldap#post180760 Please let me know if you find anything that should be in the script.

  • How to resize sytem partition

    donh - - General

    Post

    You can use a live cd and boot your vm. Then resize the partition. Practice on a clone first.

  • smb.conf missing share definitions

    donh - - CIFS/SMB

    Post

    You are right the shares should show in /etc/samba/smb.conf. Not sure what happened. Try adding them with the web interface again. If that fails maybe post it as a bug. github.com/openmediavault/openmediavault/issues

  • Wierd active directory issue. ldap

    donh - - CIFS/SMB

    Post

    Not sure what caused this but running this fixed it. systemctl stop sssd.service && rm /var/lib/sss/db/* && systemctl start sssd.service Must have corrupted the db somehow.

  • smb.conf missing share definitions

    donh - - CIFS/SMB

    Post

    Did you try the ip address?

  • Wierd active directory issue. ldap

    donh - - CIFS/SMB

    Post

    A kernel upgrade for a 4.18 kernel came up when checking for updates. Before the update all users were showing in omv. After the update and reboot only one user shows up? Booting a 4.17 kernel and all users show up. Any ideas? I used this to get ad working. forum.openmediavault.org/index…Directory-LDAP-Revisited/ Why is omv wanting a 4.18 kernel? Backports? Have others seen this on other methods of getting ad or ldap working? Thanks PS: omv4 updated to today running as a proxmox vm.

  • The plugin is for connecting to an ldap / active directory server. It does not provide a server. There are many types of servers out there. Short list windows, openldap, freeipa or samba. You could install one on your openmediavault server but it could get complicated. Would be better to install in a vm or other box.

  • OMV LDAP Integration

    donh - - Plugins

    Post

    See the post above yours. Without a clue what server you are connecting to it isn't possible to help beyond that. To many detaials are better than none.

  • Installation Problems

    donh - - General

    Post

    Use blkid to see the uid of your drives. Look at your /etc/fstab and be sure it points / to the correct drive. If it points to /dev/sdx change it to the uid.

  • Quote from garyi: “Device "bond0" does not exist ” What does cat /etc/network/interfaces look like. # Include additional interface stanzas. source-directory interfaces.d # The loopback network interface auto lo iface lo inet loopback # ens18 network interface auto ens18 allow-hotplug ens18 iface ens18 inet dhcp dns-search example.com iface ens18 inet6 manual pre-down ip -6 addr flush dev $IFACE # bond0 network interface auto bond0 iface bond0 inet static address 10.0.83.220 gateway 10.0.83.1 net…

  • I tried adding a pair of nics in a vm and making a bond. When hitting apply I get errors. Did you get errors then? Even with the error I can ping and get to the webui. Can you ping the ip of the bond from the omv? Or another machine? Will look at the error later. root@OMV4:~# systemctl status networking.service ● networking.service - Raise network interfaces Loaded: loaded (/lib/systemd/system/networking.service; enabled; vendor preset: enabled) Active: failed (Result: exit-code) since Sun 2018-…

  • Post the output of ifconfig or ip address. How did you add the other nics?

  • Samba Active Directory Domain

    donh - - CIFS/SMB

    Post

    Well your method of using winbind must be top secret because you wont tell anything about it. I haven't used it for some time. It worked from the first betas threw to version 3. If you posted your steps it might have jogged my memory. Might even have tried it in a vm. When you ask for help the better questions you ask the better answers you might get.

  • What are the ip's of the lacp and built in? Did you add the lacp from the webui or cli? Too many details are better than none.

  • Samba Active Directory Domain

    donh - - CIFS/SMB

    Post

    You are asking for help without providing any details of what you have done. How is anyone going to guess what may be going on? What version of omv? Steps you took to get were you are now. What version of samba server you are trying to connect to. Look threw this thread for things related to winbind. forum.openmediavault.org/index…ghlight=winbind#post79673 FYI: I think you are running into problems that sssd and realmd were developed to avoid.

  • Samba Active Directory Domain

    donh - - CIFS/SMB

    Post

    Well it works for many of us so please let us know what you find. I guess wbinfo -u works too.

  • Samba Active Directory Domain

    donh - - CIFS/SMB

    Post

    Since you have provided almost no details it is hard to help just guess. The code in omv is working for others. Read threw some of the examples. If your uid's are higher than 60000 look at /etc/login.defs. Since users show in getent it is almost certainly something in smb.conf. Found an old note and here is what I had in extras. #[Custom] security=ads realm=YOURDOMAIN.COM idmap config * : range = 10000-20000 idmap config * : backend = tdb idmap config YOURDOMAIN : default = yes idmap config YOUR…