Search Results

Search results 1-20 of 111.

  • openmediavault-letsencrypt

    Agricola - - Plugins

    Post

    Quote from Nefertiti: “About renewing the certificate,for sure you do not need to do a fresh install of the container just pass docker logs -f letsencrypt ” Not to steal away the thread (after 31 pages!) but I got that impression after I did so. I deleted the Letsencrypt folder completely as well as the container before restarting, but when I got to the end where you modify the config.php file it was already customized - ready to go; which makes me wonder why even bother with the Letsencrypt plu…

  • openmediavault-letsencrypt

    Agricola - - Plugins

    Post

    I have read through this thread - all thirty-one pages and I still have a few questions. The look and functionality of this Letsencrypt plugin has changed since it first was introduced on page one. I have Nextcloud/Letsencrypt running per @TechnoDadLife video on an Odroid HC2. It's all great except when it comes time to renew my cert. Last night, after my certificate expired a couple days ago, I did a fresh install on the Letsencrypt container and received a new certification. In the Letsencrypt…

  • Oooo-kay. I got pihole running on the diet-pie/Odroid XU4 and just set one device to that ip and it worked. I then added unbound and set it up in the pihole web admin, and it worked with that one device. I then set the router's DNS to that pihole and the internet quit retrieving pages. I tried it with several other machines with the same situation. Then I went to my router and decided to try some single-switch setting changes. The first modification fixed everything. See the screen shot below. I…

  • I noticed this morning that pi-hole.net removed their test page from there site. I wonder what is with that. When I get close on the diet-pi install I will remove the other reference from my router.

  • Quote from flmaxey: “Test pi-hole with at least one client, first, before adding unbound. ” Thanks. Will do. Should I shut down my pihole/omv server, or just switch the dns settings in my router when pihole/dietpie is ready?

  • Docker Issue on Install

    Agricola - - Docker

    Post

    This may be the one: Docker not installing on new install

  • Docker Issue on Install

    Agricola - - Docker

    Post

    Sometimes it’s necessary to uninstall the docker-GUI plugin, run apt clean from the install menu of omv extras, turn docker ce off, run the apt clean again, turn docker ce back on and install docker- GUI again. If it doesn’t work, repeat until it does. Persistence, patience, and holding your mouth just right is essential. You might try a clean install on a brand new name-brand high class SD card. There is a thread on this topic. I will see if I can locate it.

  • I flashed a SD card with diet pi and played with it last evening but ran into a snag. Setting a static ip and switching dns server to 1.1.1.1 was easy enough. I also set time zone, region, keyboard and then ran an upgrade. When I went to the dietpi-software section it showed pihole starred as if it were already installed but I could not figure how to access it to configure it. I finally uninstalled it and then reinstalled it. I was then allowed to go in and configure but then proceeded to lock m…

  • I have experimented with Diet-Pi a while back. I’ll give it a try. Thanks.

  • No but I do have an Odroid XU4, and it just happens to have pihole already on it, but not unbound. I set both machines up with a fresh omv a few days ago and ran the pihole docker on both of them but didn’t get to unbound on the XU4 because the R-Pi was doing so well. I can’t try it out till later today, probably this evening. Thanks for the clarification. I’m pretty sure IPv6 is already disabled at the router. I just looked at your section on adding that file to pihole and it looks clear enough…

  • I'm beginning to think there is something with my router settings preventing unbound. There is a check box in basic network settings to enable DNSSEC. Under Advanced Settings there is an area for Custom Configuration of Dnsmasq. Notes at the bottom of that page read "Custom configuration - Extra options to be added to the Dnsmasq configuration file." and "The contents of file /etc/dnsmasq.custom are also added to the end of Dnsmasq's configuration file (if it exists)." Associated with anything D…

  • @flmaxey Yes I did run an AirPort Extreme until I bought a Netgear R7000 (Tomato firmware). It had about four settings and couldn't handle port forwarding (or I couldn't figure out how). The Tomato router has about four hundred settings and I have figured out about fifteen of them. I still use the AirPort (two of them, actually) in bridge mode to extend the network/wifi to the outer reaches around the house. What an education! I have wondered why if we are running out of addresses there doesn't …

  • I did run the tests as shown above and did get those results. I was just uncertain because of the problem with the iPhones/iPad/laptop (yes, it was I). I guess I misinterpreted when you wrote in your how-to: Quote from @flmaxey: “At the end of the installation: To configure Pi-hole (which is running in a Docker with a separate IP address) to look at OMV/unbound as it's up-stream DNS server; 127.0.0.1#5353 cannot be used. ” I don't understand what you mean when you said above "127.0.0.1 "is" the …

  • @flmaxey with the two dig tests, you change the port numbers. Do you not also change the address? Shouldn't it be the address of the omv server?: dig sigfail.verteiltesysteme.net @127.0.0.1 -p 53 dig sigok.verteiltesysteme.net @127.0.0.1 -p 53 When I run the tests as above, they each return as described in the how-to. I have tried it substituting my server's address and the tests time out. With regard to the configuration section, I am assuming the /etc/unbound/unbound.conf.d/pi-hole.conf in the…

  • Docker not installing on new install

    Agricola - - Docker

    Post

    Quote from bubba: “Before I updated or upgraded anything or before changing any other variables from default, I enabled Docker then installed the Docker GUI plugin. After this was done, I made all the changes (i.e. updates, date/time, password, etc.). ” After starting up a fresh install on a RPI 3 I don't touch it for 20 minutes, because it does an auto reboot the first time it runs. At that point I access it via the web and turn on ssh and then access it through command line to perform the foll…

  • Nextcloud Broken

    Agricola - - General

    Post

    Quote from Virgil.A: “I update my images and rebuild my containers manually because I kinda understand why it deleted my container. 1. you pull the image from docker hub 2. your container still runs on your older version image name turns into a hash 3. you stop this container 4. you select this container press copy and give it a new name because you can't use the old name 5. you delete the old container 6. you delete the old image 7 you update containers that use this container as a mounted volu…

  • Nextcloud Broken

    Agricola - - General

    Post

    I shutdown and inserted my backup sd card and rebooted. Then I repointed my shared folders to my backup data drive. After that Heimdall works, and Plex has never stopped working, but Nextcloud still refuses to load up. @Virgil.A If I update my containers as you have described above in an attempt to get Nextcloud back up and running, what order would you update them? Would you update Nextcloud first and then see if it works without touching the other containers? I'm sure I only have one shot at t…

  • I spoke too soon. Everything looks good. No error windows at all. but after I pull the image and build the container - I'm just trying to get Heimdall on a Rpi3 - the Heimdall folder that I point the /config to dosen't populate. I have done this multiple times from scratch and the container simply doesn't do anything.

  • Quote from razvanrudy: “Finally working........with help from other users on a different thread The steps worked for me 1. Add 1.1.1.1 to DNS in network interface 2. Make sure plugin is not instaled , if it is just uninstall and refresh your browser ( and clear cache) 3. apt-get purge docker-ce 4. dpkg -l | grep openm and make sure no docker-gui listed 5. If docker-gui still on the output file rm /var/lib/dpkg/info/openmediavault-docker-gui.postrm and then apt-get purge openmediavault-docker-gui…

  • Quote from ryecoaaron: “On a fresh installation, installing the plugin from the web interface does fail although it is easily fixed by apt-get -f install and answer yes to the replace /etc/default/docker question. Installing docker-ce first is a bad idea because you might install a version of docker too new for the plugin and a downgrade might go badly. ” When I enter the command it never goes that far it stops at: Source Code (6 lines)