CUPS: Manual duplex dialog not showing

    • OMV 1.0
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • CUPS: Manual duplex dialog not showing

      Hello

      I am having an issue when printing Duplex. I am using a HP Laserjet 1020 connected to OMV and shared to my network. This particular printer has no buttons (just the On/Off switch) and has manual duplex.

      If I connect the printer directly to my computer via USB and select duplex printing, the printer will print first one side of the sheets and then make a halt. A dialog appears on the screen asking me to flip the pages and feed them again to the printer. After I do that, I click "continue" in the dialog and the printer resumes printing and prints the other side of the sheets. The dialog looks something like this, with the difference that my printer has no "Go" button. Instead I must click "Continue":



      However, when the printer is connected to OMV and shared to the network, there is no way that I can get this dialog. I can print without issues from any PC in my network. But if I choose Duplex, the printer will print one side and, then halt so I can flip the pages. But since I am not getting the duplex dialog in the PC, I can't instruct the printer to resume printing.

      I already tried resuming printing directly from the CUPS interface, but the job appears as completed. The printer has no buttons, meaning that I can't resume printing from the printer. I also tried with different drivers (tried both with Foomatic and HPLIP) but none of them worked.

      From the Foomatic webpage, I know that the driver supports duplex printing for my printer. Is this problem because the printer is being shared over the network? Or do you know a workaround for this.

      Thanks!
      Custom mini-ITX build
      Coolcube Mini, Intel Desktop Board DQ77KB, Intel Celeron G1610T, 4 GB DDR3 Ram, 30 GB Sandisk SSDnow 200 (OS), 1 TB Samsung M8 HN-M101MBB

      Dell Optiplex 960 sff (deprecated) - link


      Dell Optiplex FX160 (repurposed) - link

      "If you can't find it in Google, it simply doesn't exist!" - The Internetz

    • Hi Subzero

      Thanks for the fast reply. Yes, I found in several forums the solution you suggested. Oddly, I can't find the option to print odd/even pages. Perhaps I have to fiddle a little bit more with the printer settings.
      Custom mini-ITX build
      Coolcube Mini, Intel Desktop Board DQ77KB, Intel Celeron G1610T, 4 GB DDR3 Ram, 30 GB Sandisk SSDnow 200 (OS), 1 TB Samsung M8 HN-M101MBB

      Dell Optiplex 960 sff (deprecated) - link


      Dell Optiplex FX160 (repurposed) - link

      "If you can't find it in Google, it simply doesn't exist!" - The Internetz

    • I've not tried yet with Word, since most of the documents I print are PDFs.

      Looking around the web, it seems that it is a problem related to this particular printer and other similar ones like the HP LJ 1018 and 1022n, which have a software/firmware based Duplex. They are all relatively old (I found mine on a thrift shop for 20€, almost like new!). The user can't give a physical feedback to the printer via a button to resume printing. It must be given thru software. A possibility is to use gnome-manual-printing, but I doubt that it may work on headless clients. The problem is the same: gnome manual printing displays a dialog asking you to flip the pages. I don't see a way how this dialog can be passed from the OMV computer to my Windows PC.

      Anyhow, thanks for the support. If I find something else I'll post it.
      Custom mini-ITX build
      Coolcube Mini, Intel Desktop Board DQ77KB, Intel Celeron G1610T, 4 GB DDR3 Ram, 30 GB Sandisk SSDnow 200 (OS), 1 TB Samsung M8 HN-M101MBB

      Dell Optiplex 960 sff (deprecated) - link


      Dell Optiplex FX160 (repurposed) - link

      "If you can't find it in Google, it simply doesn't exist!" - The Internetz