Can't enable iscsi target

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't enable iscsi target

      Hi,

      I have a fresh install of OMV.
      I want to enable iscsi Target but when I apply to commit the settings I get:

      Source Code

      1. Failed to execute command 'export LANG=C; monit -t 2>&1': /etc/monit/conf.d/openmediavault-filesystem.conf:12: Error: syntax error '"legacy"'


      Full detail error:

      Source Code

      1. Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'export LANG=C; monit -t 2>&1': /etc/monit/conf.d/openmediavault-filesystem.conf:12: Error: syntax error '"legacy"'' in /usr/share/openmediavault/engined/module/monit.inc:55
      3. Stack trace:
      4. #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleMonit->applyConfig()
      5. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      6. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      8. #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      9. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      12. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      13. #9 {main}
      Display All


      After click enable, /etc/monit/conf.d/openmediavault-filesystem.conf gets this lines (several):

      Source Code

      1. check filesystem fslegacy with path "legacy"
      2. if space usage > 80% for 5 times within 15 cycles
      3. then alert else if succeeded for 10 cycles then alert
      4. #check program mplegacy with path "/bin/mountpoint -q 'legacy'"
      5. # if status == 1 then alert


      Any ideas?

      Thanks!
    • Just to add some info:

      in /etc/openmediavault/config.xml:

      Source Code

      1. ​ <mntent>
      2. <uuid>8703ddbf-79b0-4664-95e0-fcb6f2bace96</uuid>
      3. <fsname>pool_15k/.system</fsname>
      4. <dir>legacy</dir>
      5. <type>zfs</type>
      6. <opts>rw,relatime,xattr,noacl</opts>
      7. <freq>0</freq>
      8. <passno>0</passno>
      9. <hidden>1</hidden>
      10. </mntent>
      11. <mntent>
      12. <uuid>978c35fe-41d5-411b-b20c-f5e1d6a0c8cc</uuid>
      13. <fsname>pool_15k/.system/configs-f1ae6c68bbe041c7bb38cadeec088781</fsname>
      14. <dir>legacy</dir>
      15. <type>zfs</type>
      16. <opts>rw,relatime,xattr,noacl</opts>
      17. <freq>0</freq>
      18. <passno>0</passno>
      19. <hidden>1</hidden>
      20. </mntent>
      21. <mntent>
      22. <mntent>
      23. <uuid>d0c245b3-54fe-4307-bcb4-9860715031b5</uuid>
      24. <fsname>pool_15k/.system/cores</fsname>
      25. <dir>legacy</dir>
      26. <type>zfs</type>
      27. <opts>rw,relatime,xattr,noacl</opts>
      28. <freq>0</freq>
      29. <passno>0</passno>
      30. <hidden>1</hidden>
      31. </mntent>
      32. <mntent>
      33. <uuid>f859917e-31c0-40a7-8d84-a2a7268c33e3</uuid>
      34. <fsname>pool_15k/.system/rrd-f1ae6c68bbe041c7bb38cadeec088781</fsname>
      35. <dir>legacy</dir>
      36. <type>zfs</type>
      37. <opts>rw,relatime,xattr,noacl</opts>
      38. <freq>0</freq>
      39. <passno>0</passno>
      40. <hidden>1</hidden>
      41. </mntent>
      42. <mntent>
      43. <uuid>006dbd57-57ec-48e9-a1ec-f3f223f82d95</uuid>
      44. <fsname>pool_15k/.system/samba4</fsname>
      45. <dir>legacy</dir>
      46. <type>zfs</type>
      47. <opts>rw,relatime,xattr,noacl</opts>
      48. <freq>0</freq>
      49. <passno>0</passno>
      50. <hidden>1</hidden>
      51. </mntent>
      52. <mntent>
      53. <uuid>20ebf085-50fb-48ea-b790-878b26bf12c9</uuid>
      54. <fsname>pool_15k/.system/syslog-f1ae6c68bbe041c7bb38cadeec088781</fsname>
      55. <dir>legacy</dir>
      56. <type>zfs</type>
      57. <opts>rw,relatime,xattr,noacl</opts>
      58. <freq>0</freq>
      59. <passno>0</passno>
      60. <hidden>1</hidden>
      61. </mntent>
      Display All


      All these legacy dir are in the pool_15k pool.
      This pool was created 30 mins ago, and the disks were wiped before.
    • I ended up modifying the config.xml file, changing something else in the config and applying,
      It's working now.

      I think those directories were there it was because that zfs pool was part of FreeNAS before and it had those directories. I imported it from command line, but then destroyed them and created a new pool.