Accessing NAS services with same URL from LAN and WAN

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Accessing NAS services with same URL from LAN and WAN

      Hello,

      currently I use dyndns and NAT on my home router to access my NAS from WAN.
      Let's say my dyndns address is <wan.net> and my NAS name is "omv". My router already resolves omv.<wan.net> to the same IP from inside LAN and WAN. Accessing services from WAN via omv.<wan.net>:<port> works, but gives failures if I try to open this addresses from the LAN.

      E.g.:
      FTP: From LAN, logging into "ftp://omv.<wan.net>" gives "530 Login incorrect." but "ftp://omv" works.

      Owncloud: Accessing owncloud from WAN at "https://omv.<wan.net>:<port>" does work, but times out with the same url from inside the LAN. In the special case of owncloud I am not even able to access it from the inside, because I needed to configure "'overwrite.cli.url' => 'https://omv.<wan.net>:<port>'".

      Any idea, what could be the reason for that?

      Regards

      The post was edited 1 time, last by c.r. ().

    • Don't know the plugin. But you'll have to face this complications:
      Your NAS will be the DNS server in your network; that means "always-on".
      The router has to propagate your NAS box as DNS server via dhcp.
      Should work, I would prefer to buy another router...

      c.r. wrote:

      (you are forced by German providers to use crappy routers)

      This is exactly the reason why I do not use the fritzbox of my ISP.
    • I do not use exactly the dyndns.org service but another dynamic DNS provider, which is not in the plugin.

      I think the owncloud configuration is correct in general. There is only a problem to reach the FTP and the owncloud service form inside by the global address.
      I guess I have to turn my NAS into a DNS and DHCP server for my LAN or buy a professional and configurable router.
    • c.r. wrote:

      Accessing services from WAN via omv.<wan.net>:<port> works, but gives failures if I try to open this addresses from the LAN.


      The reason for this is that your router is not performing NAT reflection. There are ways to solve the problem. Here are two.

      1) If your router can do NAT reflection, then enable it. Almost all SOHO type routers do NOT have this capability. Maybe yours does?

      2) Edit the hosts file for each PC on your LAN where you want this to work. Add records like this, but use the correct local private IP address of the OMV machine. You may have to reboot or restart the networking service after editing the hosts file. Then you can use either omv.wan.net or omv and reach the server from the LAN.

      192.168.1.10 omv.wan.net omv
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380

      The post was edited 1 time, last by gderf ().

    • gderf wrote:

      If your router can do NAT reflection


      NAT reflection sounds more advanced :D , like pfsense. His probably not gonna find it anywhere with that name. In most soho routers this is called the NAT loopback. It depends I guess of the router and if is ISP branded or not. On the fritzbox a quick googlefu tells me some have others not, and that was apparently removed for "security reasons".
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server