Headphones - service starting but no GUI

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Headphones - service starting but no GUI

      All,
      Got a problem after recently installin a fresh build of OMV this weekend. I have a number of add-ons through omv-extras.org and they all work great. Thanks to everyone who contributed.

      The one problem I have is headphones is failing to be get a default webpage up. From theGUI, it attempts to connect to 192.168.1.10:8181/ but I just get the default webpage saying page not available with nothing else. Tried with https as well but no go.
      I've verified that noting is listening on this port, as when i disable the service for headphones, nothing else is listening.

      I have no idea where to go from here, as at one point it was working.
      I've searched the net high and low, and nothing can help me...
      Tried uninstalling several time, with reboots but still a no go...
      Can anyone help with where to look from here?
    • Thanks for the help, unfortunately the headphones log doesnt appear to give any clues... I cleared the log and restarted services.. it appears ok but still no web interface

      Could it be something with the web interface? Where could I go next to resolve this?


      root@NAS:/home/headphones/.headphones/logs# echo "" > headphones.log
      root@NAS:/home/headphones/.headphones/logs# cat headphones.log | more

      root@NAS:/home/headphones/.headphones/logs# service headphones restart
      Stopping headphones
      Starting headphones
      root@NAS:/home/headphones/.headphones/logs#
      root@NAS:/home/headphones/.headphones/logs#
      root@NAS:/home/headphones/.headphones/logs# cat headphones.log | more

      21-Jul-2015 18:47:12 - INFO :: MainThread : Signal 15 caught, saving and exiting...
      21-Jul-2015 18:47:12 - INFO :: MainThread : Writing configuration to file
      21-Jul-2015 18:47:12 - INFO :: MainThread : Headphones is shutting down...
      21-Jul-2015 18:47:12 - INFO :: MainThread : Removing pidfile /var/run/headphones/headphones.pid
      21-Jul-2015 18:47:12 - INFO :: MainThread : Checking to see if the database has all tables....
      21-Jul-2015 18:47:12 - INFO :: MainThread : Retrieving latest version information from GitHub
      21-Jul-2015 18:47:13 - INFO :: MainThread : Headphones is up to date
      21-Jul-2015 18:47:13 - INFO :: MainThread : Daemonized to PID: 2500
      21-Jul-2015 18:47:13 - INFO :: MainThread : Writing PID 2500 to /var/run/headphones/headphones.pid
      21-Jul-2015 18:47:13 - INFO :: MainThread : Starting Headphones web server on localhost:8181/
      21-Jul-2015 18:47:14 - INFO :: MainThread : Scheduled background task: Search for Wanted
      21-Jul-2015 18:47:14 - INFO :: MainThread : Scheduled background task: Download Scan
      21-Jul-2015 18:47:14 - INFO :: MainThread : Scheduled background task: Library Scan
      21-Jul-2015 18:47:14 - INFO :: MainThread : Scheduled background task: MusicBrainz Update
      21-Jul-2015 18:47:14 - INFO :: MainThread : Scheduled background task: Check GitHub for updates
      21-Jul-2015 18:47:14 - INFO :: MainThread : Scheduled background task: Torrent removal check
    • root@NAS:/etc/apt/sources.list.d# lsof -i :8181
      COMMAND PID USER FD TYPE DEVICE SIZE/OFF NODE NAME
      python 3923 headphones 4u IPv6 116076 0t0 TCP localhost:8181 (LISTEN)
      root@NAS:/etc/apt/sources.list.d#


      root@NAS:/etc/apt/sources.list.d# dpkg -l | grep openmediavault
      ii openmediavault 1.19 all Open network attached storage solution
      ii openmediavault-autoshutdown 1.0.8 all OpenMediaVault AutoShutdown Plugin
      ii openmediavault-backup 1.0.11 all backup plugin for OpenMediaVault.
      ii openmediavault-clamav 1.3 all OpenMediaVault ClamAV plugin
      ii openmediavault-couchpotato 1.0.3 all OpenMediaVault CouchPotatoServer plugin
      ii openmediavault-extplorer 1.1 all OpenMediaVault eXtplorer plugin
      ii openmediavault-headphones 1.0.2 all OpenMediaVault Headphones plugin
      ii openmediavault-keyring 0.3 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-mysql 1.0.16 all MySQL plugin for OpenMediaVault.
      ii openmediavault-omvextrasorg 1.29 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-plexmediaserver 1.0.12 all OpenMediaVault Plex Media Server plugin
      ii openmediavault-sabnzbd 1.0.5 all OpenMediaVault SABnzbd plugin
      ii openmediavault-sickbeard 1.0.3 all OpenMediaVault Sick Beard plugin
      ii openmediavault-snapraid 1.5 all snapraid plugin for OpenMediaVault.
      ii openmediavault-transmissionbt 1.4 all OpenMediaVault Transmission (BitTorrent client) plugin.
      ii openmediavault-unionfilesystems 1.8 all Union filesystems plugin for OpenMediaVault.
      ii openmediavault-virtualbox 1.3 all VirtualBox plugin for OpenMediaVault.
      ii openmediavault-wol 1.0.4 all OpenMediaVault WOL plugin
      root@NAS:/etc/apt/sources.list.d#




      The post was edited 1 time, last by switched ().

    • Stop HP, service headphones stop then edit the config file nano /home/headphones/.headphones/config.ini and change the port field to use another port http_port = 8181 to http_port = 9999 or whatever.

      Finally start HP service headphones start

      Just checked my config, make sure you have http_host = 0.0.0.0 in the [General] section of the config, check this before changing port (remember to stop HP before making changes to this file)


      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • Thank you thank you thank you !!!!

      Changed port to 9999 and from localhost to 0.0.0.0 and its all working!!
      I did change the ports a few nights ago when it wasnt working, but it didnt resolve the issue so I reverted the change back, I think the fix in this scenario was the "localhost" to 0.0.0.0

      In the interest of learning... do you know why it suddenly didn't work, and how did you know that this was the issue?
    • The host is what it is listening for, if not set to 0.0.0.0 then it will only listen for connections coming from localhost, your not connecting from the local machine so it fails to show the webui.
      This part of the config should have been auto created when installing, I will have to check to see why in your case it was not :(
      [IMG:http://widgets.trakt.tv/users/1f5d0f5ed67f98ed9d06d9849b42dd0e/watched/banner@1x.jpg]
      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS
    • Headphone still not working

      Hi everybody,

      I'm running OMV 2.x.
      I have the same problem explained regarding the GUI not working.
      I tried to modify the config.ini file and I put http_host = 0.0.0.0 as suggested.

      But the restart of the service reverts the config.ini and put http_host =localhost

      Any clue to solve my problem ?
    • Hey. I'm getting this an error message regarding my time zone. Looking through the file it relates to, I can see US/Eastern as an example.
      What should I do?

      Source Code

      1. ​root@Rufus:~# service headphones start
      2. Starting headphones
      3. root@Rufus:~# Traceback (most recent call last):
      4. File "/opt/headphones/Headphones.py", line 23, in <module>
      5. from headphones import webstart, logger
      6. File "/opt/headphones/headphones/__init__.py", line 67, in <module>
      7. SCHED = BackgroundScheduler()
      8. File "/opt/headphones/lib/apscheduler/schedulers/base.py", line 61, in __init__
      9. File "/opt/headphones/lib/apscheduler/schedulers/base.py", line 95, in configure
      10. File "/opt/headphones/lib/apscheduler/schedulers/background.py", line 27, in _configure
      11. File "/opt/headphones/lib/apscheduler/schedulers/base.py", line 576, in _configure
      12. File "/opt/headphones/lib/tzlocal/unix.py", line 108, in get_localzone
      13. File "/opt/headphones/lib/tzlocal/unix.py", line 61, in _get_localzone
      14. File "/opt/headphones/lib/pytz/__init__.py", line 180, in timezone
      15. pytz.exceptions.UnknownTimeZoneError: 'Europe/Stockholm'
      Display All
    • jhmiller wrote:

      make sure you have http_host = 0.0.0.0 in the [General] section of the config, check this before changing port (remember to stop HP before making changes to this file)


      this alone got me going with the latest OMV on a rpi. no need to change the port. would be useful if it was somehow changed in the default, so it 'just worked', but googling the forums also, 'just works'! thanks for the awesome software folks.
    • I'm running omv 2 and just had this issue with headphones gui not working...changed http_host from localhost to 0.0.0.0 and its now working.

      definitely a worth while thread ;D
      complete Newb...enough said really :D

      OMV 2.2
      Supermicro A1SRM-2558F Atom 2.4GHz
      16Gb Ram
      Lsi sas 9201-16i
      2 x 2.5" WD Hdd's on mainboard. 1 OS, 1 Spare
      4 WD 2Tb Hdd's on Lsi pooled with snapraid/mergerfs (mfs)