Web-GUI broken when using Firefox after update to v2.1.1

    • OMV 2.x
    • Resolved
    • Web-GUI broken when using Firefox after update to v2.1.1

      Hi,

      I recently updated to v2.1.1 and since then I can't access the Web-GUI via Firefox. Firefox and all Plug-Ins are the latest version. Usually I see just a plain white page, occasionally (I can't figure out any rule, though) I see the login screen. But after putting in my credentials and trying to log in it's back to the blank white screen. I whitelisted the IP in every possibly restrictive Firefox-Plugin I use (AdBlock, NoScript etc., although it worked perfectly before with OMV v1.19). I tried this and I cleared the Firefox-cache but no change.

      With Internet Explorer there is no problem whatsoever, SSH also works without any problems.
    • OMV 1.x uses extjs 4. OMV 2.x uses extjs 5. If the web interface works in IE, then adblock, noscript, whatever is the problem with Firefox. Did you try incognito mode?
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • I did, but the result was the same. As mentioned earlier I cleared the
      Firefox cache several times, had several reboots, Adblock is deactivated
      for that IP, NoScript deactivated, Cookies are allowed, Firefox and all
      PlugIns have been updated.

      I found this thread of a similar problem and opened the console and got the following JavaScript exceptions:


      - TypeError: a is null
      - Die Zeichenkodierung eines Dokuments im Frame wurde nicht deklariert. Das Dokument kann unterschiedlich aussehen, wenn es ohne das umgebende Frame-Dokument angesehen wird.
      - getPreventDefault() sollte nicht mehr verwendet werden. Verwenden Sie stattdessen defaultPrevented.


      the second and third one (for those of you who can't read german) roughly translated into english:


      - "the character encoding of one of the documents in this frame was not declared. The document might look different when viewed without the surrounding frame-document"
      and
      - "getPreventDefault() shouldn't be used anymore. use defaultPrevented instead."


      But I suppose "a" (whatever it is :) ) is the bad guy and shouldn't be Null.
    • This is looks like an nginx (OMV web server) protection. I'm guessing one of your protections is putting the OMV web interface in a frame which nginx will not accept. You could try installing the openmediavault-links plugin, create a link with media tab enabled. This will disable that protection and might work.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • I just installed the links plugin, but I'm not sure what it is for ?( Doesn't it create links inside of the Web-GUI ? How does it help accessing it? Could you explain this in a little more detail, please?

      However, I just created a link with the following settings: No preset selected, name "TEST" in group "TESTGROUP", entered the IP of my NAS as the URL and checked the media tab, but with no effect.
    • bta489 wrote:

      Doesn't it create links inside of the Web-GUI ? How does it help accessing it?
      Yes, but it also deactivates the nginx framing protection.

      Just out of curiosity, have you tried one more browser? Chrome, Opera..?
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • I don't have any other browser installed. So no, IE and FF are the only browsers I tested.

      In the meantime I updated to OMV 2.1.2 (since I saw it existed in ryecoaaron's signature :) ), but the problem persists. I deactivated all add-ons in FF and tried starting it in safe-mode, but still all I see is white.
    • FYI, I have the same problem it seems. I would get a white page in
      Firefox. Chromium would mostly work, but kind of hang sometimes and need
      to be refreshed. And even then sometimes the change I made would
      reflect, sometimes not.

      Anyway, I looked at the page source for the blank white page I was
      getting and saw a function that attempts to use LocalStorage instead of
      Cookies. I remembered that I don't like LocalStorage and disabled it.
      Going into about:config and searching for "dom.storage.enabled"
      and making sure it was "True", then refreshing my OMV WebUI and it all
      works fine now it seams.

      I still don't like LocalStorage, but maybe I'll keep a beater browser in
      a separate folder just for OMV WebUI if it insists on using it.
    • Hello,

      As the others, I tried everything and it's not working:
      1. Clearing cache
      2. Relaunch Firefox
      3. Relaunch computer
      4. tried with dom.storage.enabled and dom.storage.disabled
      5. I tried to rebuild the eMMC from scratch: same thing...
      Nothing work but in others computers and in private navigation, it's working on Firefox.

      How correct this, please?
      Images
      • Bug OMV.png

        8.79 kB, 828×275, viewed 64 times
      :evil: Mulder FOX