Remote Shares WebDAV

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Remote Shares WebDAV

      I want to us the WebDAV from the Remote Shares. When I aktivate the config I got the following message:

      Fehler #4000:
      exception 'OMVException' with message 'Failed to execute command 'omv-mkconf remoteshare 2>&1': /sbin/mount.davfs: kann das Cacheverzeichnis /var/cache/davfs2/accounts.login.idm.telekom.com-idmip?openid.ns=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0&openid.claimed_id=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&openid.identity=http%3A%2F%2Fspecs.openid.net%2Fauth%2F2.0%2Fidentifier_select&openid.return_to=https%3A%2F%2Fmediencenter.t-online.de%2Faas%2Frest%2F1.0%2Fsso%2Flogin&openid.realm=https%3A%2F%2Fmediencenter.t-online.de%2Faas%2F&openid.assoc_handle=S0bebe8f6-2fae-401b-8ddf-9aa95fd5bf32&openid.mode=checkid_setup&openid.ns.ext1=http%3A%2F%2Fidm.telekom.com%2Fopenid%2Fext%2F2.0&openid.ext1.logout_endpoint=https%3A%2F%2Fmediencenter.t-online.de%2Faas%2Frest%2F1.0%2Fsso%2Flogout&openid.ns.ext2=http%3A%2F%2Fopenid.net%2Fsrv%2Fax%2F1.0&openid.ext2.mode=fetch_request&openid.ext2.type.all=urn%3Atelekom.com%3Aall&openid.ext2.required=all&openid.ns.ext3=http%3A%2F%2Fspecs.openid.net%2Fextensions%2Fui%2F1.0&openid.ext3.x-name=true+media-9bab36d2-1913-4431-b6dc-2b4a47104f07-telekomMediaCenterWebDAV+root nicht erzeugen' in /usr/share/openmediavault/engined/module/remoteshare.inc:101
      Stack trace:
      #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleRemoteShare->applyConfig()
      #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      #9 {main}

      What is here going wrong ?
      Thanks for your help.

      The post was edited 1 time, last by ShadowPanda ().

    • Hi ShadowPanda,

      the cache directory to be created looks really weird. Guess the path is too long or something like that. How did you set up your webdav share? I mean I can see a lot of references to openid and the like in the error message.

      I also do sometimes use a T-Online share and the cache directory is definitely nothing like the path you have.

      Maybe you can also post the line from /etc/fstab for the share?

      Regards
      OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system
    • Thanks for your answer. I was also wondering of the big cache path. I mount the harddisk over the webfrontend may I have to mount the harddisk by hand with shorter names. Here is the output of the fstab:

      Source Code

      1. root@chappie:/etc# cat fstab
      2. # UNCONFIGURED FSTAB FOR BASE SYSTEM
      3. # 512 MB swapfile
      4. /swapfile1 swap swap defaults 0 0
      5. tmpfs /tmp tmpfs defaults 0 0
      6. # >>> [openmediavault]
      7. UUID=9bab36d2-1913-4431-b6dc-2b4a47104f07 /media/9bab36d2-1913-4431-b6dc-2b4a47104f07 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      8. UUID=3ee9b685-1bc6-4f35-9867-a90cc4f56260 /media/3ee9b685-1bc6-4f35-9867-a90cc4f56260 ext4 defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl 0 2
      9. https://webdav.mediencenter.t-online.de /media/9bab36d2-1913-4431-b6dc-2b4a47104f07/mediencenter/ davfs _netdev 0 0
      10. # <<< [openmediavault]
      11. root@chappie:/etc#
      Display All


      Is there a possibility to adjust the path by hand ?
    • ok, I compared my fstab with yours and the entries for the webdav share looks similar.

      My cache directory is somewhat a combination of the webdav URL and the path of the shared directory with the slashes exchanged by dashes plus something about Mediencenter+root.

      So it looks like the URL used for your cache directory is the problem. As in your URL openid is mentioned several times: how did you specify your credentials for the webdav share? Do you use openid to log in somehow? That might lead to the problem. I use my "normal credentials" like email and password.

      That's just a rough guess though. I will try to find out more about this. (I don't know much about openid, ...)

      Check the entry for the share in /etc/davfs2/secrets. Does it make sense? The first field is the path where the share should be mounted to, the second the account and the third is the password. PLEASE, don't post the content here though due to the password ;)
      OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system
    • Thank for your answer. I had made a mistake I picked up the wrong url. I change the url now but I get another error:

      Source Code

      1. Fehler #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'omv-mkconf remoteshare 2>&1': /sbin/mount.davfs: das Einhängen schlug fehl;
      3. Could not authenticate to server: rejected Basic challenge' in /usr/share/openmediavault/engined/module/remoteshare.inc:101
      4. Stack trace:
      5. #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleRemoteShare->applyConfig()
      6. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      8. #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      9. #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      10. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      11. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      12. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      13. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      14. #9 {main}
      Display All
    • Hi,

      seems like the credentials are wrong or were not updated correctly after you changed the URL. Did you update the existing configuration or did you remove it and create a new one? Would you mind removing the curernt configuration and create a new remote share connection?
      OMV 2.x - Kralizec // Hardware: HP Microserver N54L, 4GB RAM, 2x3TB WD Red - RAID 1, Sandisk SSD 60GB for system