Delete shared Folders

    • OMV 2.x
    • Resolved
    • Delete shared Folders

      Hi everybody!

      I wanted to do some housekeeping and changed the folder structure to simplify my shares. So instead of 10 shared folders there are 3 now.

      The problem I have now is that I can't delete the old and obsolete shares under: Access Rights Management > Shared Folders

      [Blocked Image: http://s23.postimg.org/3pfzyqiq3/omv_OMG.png]


      I disabled the deamons from SMB and nfs already and disabled all SMB-Shares and deleted all nfs-exports. I also did a restart - but within the shared folders page it still says: used -> yes ?(

      ...and I can't delete it 8| :cursing:

      BTW: I'm still on v1.19 and wanted to do the jump to v2.x now
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • username wrote:

      BTW: I'm still on v1.19 and wanted to do the jump to v2.x now
      There is no need to delete the shared folders for upgrading to 2.X.

      However, are you sure you do not use it anywhere else? In a plugin maybe? Plex etc?
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • WastlJ wrote:

      username wrote:

      BTW: I'm still on v1.19 and wanted to do the jump to v2.x now
      There is no need to delete the shared folders for upgrading to 2.X.

      However, are you sure you do not use it anywhere else? In a plugin maybe? Plex etc?


      It's only for houskeeping not for the update, I just want less shares...

      Good idea with the plugins. I will check that - maybe it's the extplorer?!
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • username wrote:

      WastlJ wrote:

      username wrote:

      BTW: I'm still on v1.19 and wanted to do the jump to v2.x now
      There is no need to delete the shared folders for upgrading to 2.X.

      However, are you sure you do not use it anywhere else? In a plugin maybe? Plex etc?


      It's only for houskeeping not for the update, I just want less shares...

      Good idea with the plugins. I will check that - maybe it's the extplorer?!


      Hmmm, doesn't look like.
      Just uninstalled extplorer and it say's the shares are still in use. Also a reboot didn't help...

      I have no daemons (except ssh) running.

      Anymore ideas`? Who's touching my shares? :|
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________

      The post was edited 2 times, last by username ().

    • Nope, I meant in the Access Right Management section:
      Images
      • homedirs.jpg

        16.01 kB, 420×219, viewed 468 times
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      Nope, I meant in the Access Right Management section:


      Checked: disabled (it is, and it was)

      [Blocked Image: http://s27.postimg.org/70yjiygwz/arm_reich.png]
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • WastlJ wrote:

      Output of:
      dpkg -l | grep openmediavault


      Here we go:

      Source Code

      1. ii openmediavault 1.19 all Open network attached storage solution
      2. ii openmediavault-cups 1.0.9 all OpenMediaVault CUPS (network printer server) plugin
      3. ii openmediavault-keyring 0.3 all GnuPG archive keys of the OpenMediaVault archive
      4. ii openmediavault-omvextrasorg 1.30 all OMV-Extras.org Package Repositories for OpenMediaVault
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • WastlJ wrote:

      So no special plugins installed, which could use the folder... hmm.


      Nope, and now I did the update to stoneburner 2.1.4 and the same problem still remains!
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • tekkb wrote:

      Did you check home folder for your users. One might be using a shared folder on that drive. If so disable it and set it back to none. Highlight the user and click on the Settings TAB to check.


      Just checked all of them and they are clear. Never used that "home folder" feature in the past
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • Sorry, I see you checked that already.

      Can you run the stat command on that folder????

      change directory to one level above it.
      stat Documents

      Also, copy the Documents shared folder section out of your /etc/openmediavault/config.xml file and post it in a code box.
      Here is an example for a public shared folder:


      Maybe some user still has perms on it.

      The post was edited 3 times, last by tekkb ().

    • tekkb wrote:

      Sorry, I see you checked that already.

      Can you run the stat command on that folder????

      change directory to one level above it.
      stat Documents

      Also, copy the Documents shared folder section out of your /etc/openmediavault/config.xml file and post it in a code box.
      Here is an example for a public shared folder:

      Source Code

      1. <sharedfolder>
      2. <uuid>fe3a2fff-0fcd-4416-a62b-15a80ac940ef</uuid>
      3. <name>public</name>
      4. <comment></comment>
      5. <mntentref>0abf8cd2-e241-4816-8153-55ef4401c665</mntentref>
      6. <reldirpath>public/</reldirpath>
      7. <privileges>
      8. <privilege>
      9. <type>user</type>
      10. <name>public</name>
      11. <perms>7</perms>
      12. </privilege>
      13. </privileges>
      14. </sharedfolder>
      Display All


      Maybe some user still has perms on it.



      Documents is a bad example because this is one of the folder's I keep. It's already in use again with a nfs-export. Following is showing the folder "test"

      Source Code

      1. <share>
      2. <uuid>2edf6cb0-75ae-4b2f-8508-37c033d463ef</uuid>
      3. <enable>0</enable>
      4. <sharedfolderref>46c4f8a0-238b-44ba-bef9-4aca85a0d2f2</sharedfolderref>
      5. <name>test</name>
      6. <comment></comment>
      7. <guest>no</guest>
      8. <readonly>0</readonly>
      9. <browseable>1</browseable>
      10. <inheritacls>1</inheritacls>
      11. <inheritpermissions>0</inheritpermissions>
      12. <recyclebin>0</recyclebin>
      13. <recyclemaxsize>0</recyclemaxsize>
      14. <recyclemaxage>0</recyclemaxage>
      15. <hidedotfiles>1</hidedotfiles>
      16. <easupport>0</easupport>
      17. <storedosattributes>0</storedosattributes>
      18. <hostsallow></hostsallow>
      19. <hostsdeny></hostsdeny>
      20. <audit>0</audit>
      21. <extraoptions></extraoptions>
      22. </share>
      Display All


      What I did was actually this:

      I took the HD (offline) where my share's are and delete a couple of them (or moved them around). Now there is only 4 folders left. So 5 are just gone. They don't exist any more, nobody can access them.

      Now I made already my new shares (4 in total) with nfs-exports.

      Now there are just these fragments in the GUI I can't get out. Let see :P
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________
    • tekkb wrote:

      That folder is still being used by SMB/CIFS.... You need to delete it from the SMB/CIFS Shares TAB.

      You should not do what you did. I'm not sure if you config.xml file is OK now.


      You genius! I didn't deleted the smb-shares - just deactivated them and turned the daemon off! Was not enough :whistling:

      So when I delete them - there are not "used" anymore and I can kill kick them.
      :thumbsup: Heads up! You’re editing your own user account, careless changes might lock you out! :whistling:
      _____________________________________________________________________________

      :) :( ;) :P ^^ :D ;( X( :* :| 8o =O || :/ :S X/ 8) :huh: :rolleyes: 8| :thumbdown: :thumbsup: :thumbup: :sleeping: :whistling:
      _____________________________________________________________________________