Questions / Problems / Discussions - [Guide] Howto install OpenMediaVault on Debian 8.x (Jessie) TESTING - EXPERIMENTAL

  • OMV 2.x

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • subzero79 wrote:

    Quote from jurra: “Why I need a Debian? because OMV ISO does not permit create Software RAID during install!!, I need RAID on / filesystem....”

    Have you ever considered the option of creating the raid with a live distro and then debootstrapping…



    Thanks for your quick response!!

    sorry, but what you mean with debootstrapping ??

    Best regards!
  • Hi,

    I did some tests and I saw there are some problem with :
    The samba file service,
    The script for generating fstab file (which is all the time corupted because of a problem of creating newline),
    And a problem package instalation because openmediavault search for Debian 7.x version file and no Debian 8.x.

    But for the moment it's only that i saw.
    NSA325v2 on Debian Wheezy + Openmediavault 1.16, 1.6Ghz, 512MB, 1TB + 500GB.
    D2-Network on Debian Wheezy + Openmediavault 1.16, 1.2Ghz, 256MB, 500GB.
    And a custom made NAS/Server on Debian Wheezy + Openmediavault 1.16, Core2Duo 2.4Ghz, 4GB, 4*2TB Raid5 + 4*3TB Raid5.
  • Hello,
    i´m a new Linux user and have some problems with understanding at that stadium ... i´m sorry for that.
    I´ld like to ask you, if there is a solution at that time to install OMV under Betsy (Linux Mint Debian Edition - LMDE 2)?
    I followed your guide ..... but at that point are mistakes:

    #24 : dpkg -i php5-pam_1.0.3-2_amd64.deb
    .... i had to correct it to dpkg -i php5-pam_1.0.3-4_amd64.deb

    #25: dpkg -i php5-proctitle_0.1.2-2_amd64.deb
    ..... did´nt exist

    Is there any solution?
    Could you help me, please?
    Files
    • terminal.txt

      (224.69 kB, downloaded 339 times, last: )
  • @Michelle_Br you can install OMV only in a Debian systen. OMV 2 is based on a Debian 7.x system. All you will make on a Debian 8.x is not safty.
    omv 3.0.88 | 64 bit | omvextrasorg 3.4.26 | kernel 4.9
    used plugins: nginx | mysql | docker-gui | flashmemory |rsnapshot | antivirus | apt tool | letsEncrypt | fail2ban for omv-webgui/Nextcloud/emby
    used other: netxtcloud | logitechmediaserver | emby
  • OMV 2.x only works on Debian 7 primarily because of the init system it uses (sysvinit). LMDE2 (uses systemd), Ubuntu and kubuntu (use upstart). The guideline you are following does not work either. If you are using the system as only a server (no desktop), you shouldn't need lmde2 or any of the others.
    omv 4.0.6 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.1.0
    omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

    Please don't PM for support... Too many PMs!
  • @Michelle_Br You need carry on, you 're nearly there.
    php5-proctitle need to be compiled and installed see Howto

    The link for proftpd-mod-vroot appear dead, sorry
    The good : debian.asis.io/debian/pool/mai…ot_0.9.2-2%2bb2_amd64.deb

    Howto updated
    Open Media Vault 2.2.6 (Stone burner) in Prod
    Open Media Vault 3.0.32 (Erasmus) in Test

    openmedivault Docker Container
    https://github.com/prbond/openmedivault-dockerfile

    Dev :
    openmediavault-fail2ban 1.1.5 for OMV2.X
    openmediavault-fail2ban 1.3.0 for OMV3.X
    https://github.com/prbond/openmediavault-fail2ban
    https://github.com/OpenMediaVault-Plugin-Developers/openmediavault-fail2ban
  • thank you .... but i´m a DAU (in Linux....)
    As i wrote in my statment #5.....
    "I followed your guide ..... but at that point are mistakes:

    #24 : dpkg -i php5-pam_1.0.3-2_amd64.deb
    .... i had to correct it to dpkg -i php5-pam_1.0.3-4_amd64.deb

    #25: dpkg -i php5-proctitle_0.1.2-2_amd64.deb
    ..... did´nt exist"

    I could only follow your guideline .... i dont know how compiling works. I´m sorry.
    :(

    If i try to follow you:
    ".....The link for proftpd-mod-vroot appear dead, sorry

    The good : debian.asis.io/debian/pool/mai…ot_0.9.2-2%2bb2_amd64.deb.....

    I downloaded it and try to install .... then came following message:

    laptop-lmde deb # dpkg -i proftpd-mod-vroot_0.9.2-2+b2_amd64.deb
    Vormals nicht ausgewähltes Paket proftpd-mod-vroot wird gewählt.
    (Lese Datenbank ... 171362 Dateien und Verzeichnisse sind derzeit installiert.)
    Vorbereitung zum Entpacken von proftpd-mod-vroot_0.9.2-2+b2_amd64.deb ...
    Entpacken von proftpd-mod-vroot (0.9.2-2+b2) ...
    dpkg: Abhängigkeitsprobleme verhindern Konfiguration von proftpd-mod-vroot:
    proftpd-mod-vroot hängt ab von proftpd-abi-1.3.4a; aber:
    Paket proftpd-abi-1.3.4a ist nicht installiert.

    dpkg: Fehler beim Bearbeiten des Paketes proftpd-mod-vroot (--install):
    Abhängigkeitsprobleme - verbleibt unkonfiguriert
    Trigger für doc-base (0.10.6) werden verarbeitet ...
    1 hinzugefügte Doc-base-Datei wird verarbeitet...
    Dokumente werden mit scrollkeeper registriert ...
    Fehler traten auf beim Bearbeiten von:
    proftpd-mod-vroot

    I don´t know, what it means .....
    :(
  • i thought to follow the guideline a second time.....it does´nt work.

    Step #16:
    cd openmediavault-code/deb/php5-pam/
    dpkg-buildpackage -b

    Message:
    dpkg-shlibdeps: Warnung: debian/php5-pam/usr/lib/php5/20131226/pam.so enthält eine nicht auflösbare Referenz auf Symbol zend_hash_find: wahrscheinlich eine Erweiterung
    dpkg-shlibdeps: Warnung: 12 andere, ähnliche Warnungen wurden übersprungen (verwenden Sie -v, um alle zu sehen)
    dh_gencontrol
    dh_md5sums
    dh_builddeb
    dpkg-deb: Paket »php5-pam« wird in »../php5-pam_1.0.3-4_amd64.deb« gebaut.
    dpkg-genchanges -b >../php5-pam_1.0.3-4_amd64.changes
    dpkg-genchanges: Binärpaket(e) hochzuladen (kein Quellencode enthalten)
    dpkg-source --after-build php5-pam
    dpkg-buildpackage: Binärpaket(e) hochzuladen (keine Quellen enthalten)

    At #20:
    cd php5-proctitle/

    ..... does´nt exist.
  • Some Typos in Tutorial

    Hello,

    to keep this up to date ...

    1. proctilte is gone from SVN ??

    cd php5-proctitle/
    dpkg-buildpackage -b
    cd ..

    Has to be corrected. I' ve installed a version from

    2. Version mixed ...

    wget debian.asis.io/debian/pool/mai…ot_0.9.2-2%2bb2_amd64.deb
    dpkg -i proftpd-mod-vroot_0.9.2-2+b5_amd64.deb


    has to be "b5" ....

    wget debian.asis.io/debian/pool/mai…ot_0.9.2-2%2bb5_amd64.deb
    dpkg -i proftpd-mod-vroot_0.9.2-2+b5_amd64.deb


    3. Missing slashes in 10webgui Box line 5

    -o " fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;" -n \


    has to be ...

    -o " fastcgi_param SCRIPT_FILENAME \$document_root\$fastcgi_script_name;" -n \

    It is correct in the second part

    regards