Plex pass manual update, i messed something up

    • OMV 2.x
    • Resolved
    • Plex pass manual update, i messed something up

      Hi All,
      I have updated plex pass before and after the last update attempt i had some issue's.
      I followed the guide in the plex plugin and used ubuntu 64 bit as the download link, The guide for the download is depreciated as plex seems to have changed the download location. not sure if there was a debian specific download in the past.
      When i run;
      dpkg -i plex
      i get this error;
      root@HOME-SERVER:/var/cache/apt/archives# dpkg -i plexmediaserver_0.9.12.8.1362-4601e39_amd64.deb(Reading database ... 63275 files and directories currently installed.)Preparing to replace plexmediaserver 0.9.12.8.1362-4601e39 (using plexmediaserver_0.9.12.8.1362-4601e39_amd64.deb) .../var/lib/dpkg/info/plexmediaserver.prerm: 9: /var/lib/dpkg/info/plexmediaserver.prerm: stop: not foundUnpacking replacement plexmediaserver ...Setting up plexmediaserver (0.9.12.8.1362-4601e39) .../var/lib/dpkg/info/plexmediaserver.postinst: 39: /var/lib/dpkg/info/plexmediaserver.postinst: start: not found
      if i run:
      ​root@HOME-SERVER:/var/cache/apt/archives# /etc/init.d/plexmediaserver stop
      or
      root@HOME-SERVER:/var/cache/apt/archives# /etc/init.d/plexmediaserver start​
      i get
      ​-bash: /etc/init.d/plexmediaserver: No such file or directory

      I have tried to the update twice, i rebooted the server after the first failed attempt.
      Does someone have some advice on how to proceed on fixing plex?
      Thanks
    • Plex does not directly provide a Debian specific version. Any references to Debian packages are to those provided by yakumo and it is my understanding that it his repository that is pulled by OMV when he releases new versions. You can find details about his packages and repo here (this is a public forum, not restricted to Plex Pass):

      forums.plex.tv/discussion/5142…edia-server-for-debian/p1

      The current versions that are available are:

      OMV: Version: 0.9.12.8.1362-4601e39-debian
      Plex: Version: 0.9.12.8.1362-4601e39 (ubuntu)

      The above are identical save for the init system used.

      If you install or upgrade Plex Media Server on OMV using an Ubuntu package it will replace the OMV Debian Wheezy /etc/init.d/plexmediaserver script with Ubuntu's Debian Jessie Systemd item and you will not be able to start Plex via /etc/init.d/plexmediaserver. So make a backup copy of that script before installing/upgrading OMV with a Plex sourced Ubuntu package and restore the script from the backup after installing.

      There is also another individual who provides Debian Wheezy packages, but he has asked that details not be discussed outside Plex Pass only accessible areas. He doesn't have anything newer yet anyway.

      If you are a Plex Pass User, there is currently a Plex Media Server - Transcoder Preview: plexmediaserver_0.9.12.10.1368-63adf2b_amd64.deb. Again, this is an Ubuntu package and installing it on OMV will break the /etc/init.d/plexmediaserver script, so backup that script before upgrading/installing and then restore the script. yakumo has stated that he will not be providing Debian packages of this or similar Transcoder Preview versions until they become non-preview Plex Pass releases.

      Posting links to anything available only to Plex Pass users is pointless as they can not be accessed unless you are logged into Plex.tv with an account that has been upgraded to Plex Pass.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380

      The post was edited 1 time, last by gderf ().

    • I am trying to install a preview version on my OMV 2 installation. Am I correct to assume that this is the correct process:
      1. Backup init.d script
      2. Download the preview .deb package file
      3. Install the package
      4. Restore the init.d script
      What I am specifically trying to figure out is if the difference between the Plex Ubuntu package and Yakumo's package is JUST the startup/control methods/scripts (ignoring that the Ubuntu package may have some extra stuff relevant to systemd that will also be installed but irrelevant on my Debian Wheezy server).
    • @OzanMakinaci

      Your understanding is basically correct from my experience some time ago. But I do not know if it is still fully valid. Go ahead and try it. The worst that can happen is that it will not work, and you can uninstall the preview version package and reinstall the latest @yakumo package.
      --
      Google is your friend and Bob's your uncle!

      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380