Some help please - virtualbox won't update to latest version

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Sorry I didn't wrote the complete command, I thought you knew how dpkg works.
      So, you must write the full file name :
      dpkg -i virtualbox-5.0_5.0.2-102096~Debian~wheezy_amd64.deb virtualbox-extpack-installer_5.0.2_all.deb phpvirtualbox_5.0-1_all.deb openmediavault-virtualbox_1.4_all.deb
    • ok, ok :) so installing worked but I'm back for good - nothing changed.

      But there was a error in removing virtualbox-5 in the first place and so I guess the fresh install wasn't that fresh. I'll try again later...

      It worked. I had to launch the purge command for virtualbox-5.0 twice.
      Thank you!
      OMV 2.1.1 with backport-kernel 3.16
      Antworten/ Answers/ Réponse: deutsch - english - français und/and/et Linux :)

      The post was edited 2 times, last by lebernd ().

    • I'm having the same install problem and am getting this error:

      Source Code

      1. ​The following packages have unmet dependencies:
      2. virtualbox-5.0 : Depends: libqt4-network (>= 4:4.5.3) but it is not going to be installed

      When I try to install libqt4-network, I get this:

      Source Code

      1. ​The following packages have unmet dependencies:
      2. libqt4-network : Depends: libqtcore4 (= 4:4.8.2+dfsg-11) but 4:4.8.6+git64-g5dc8b2b+dfsg-3~bpo70+1 is to be installed
      3. Depends: libqtdbus4 (= 4:4.8.2+dfsg-11) but it is not going to be installed

      Any suggestions?

    • Nice way to help people...

      It was already said that this is not recommended to upgrade from testing packages, but for people like me with a windows 10 client, RDP only works with virtualbox 5.
      I successfully upgraded with testing packages and everything works (I'm a linux user for more than 10 years now, I know how to do these things...).
    • shwaiz wrote:

      It should remove virtualbox 4 if you did not. Did you purge all the virtualbox 4 related packages ?
      I don't remember if I had this problem.
      For information, I'm running the 3.16 kernel, and my system si up to date (Debian 7.9) : apt-get update; apt-get dist-upgrade

      Yes, I removed/purged vbox4. I'm on the same versions as you.

      I just went through the process again and it worked this time. No idea what I did differently. Very interesting.

    • Hi out there,

      when i followed throughout this procedure, i managed to installed the mentioned packeages. I deleted those two files in /etc/default and touched one back.

      After reboot an trying to start vbox-service via omv i get:

      Source Code

      1. Fehler #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'export LANG=C; omv-mkconf virtualbox 2>&1': VBoxManage: error: Failed to initialize COM! (hrc=NS_ERROR_FAILURE)' in /usr/share/openmediavault/engined/module/
      3. Stack trace:
      4. #0 /usr/share/openmediavault/engined/rpc/ OMVModuleVirtualBox->applyConfig()
      5. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      6. #2 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      7. #3 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      8. #4 /usr/share/openmediavault/engined/rpc/ OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      9. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      10. #6 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      11. #7 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      12. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      13. #9 {main}
      Display All

      What can i do to resolv this problem.
      Does anyone know how long may we have to wait for an updated omv-extra\virtualbox-pack?

      Auch das geht vorbei ...
      HP Microserver Gen8, E3-1265Lv3, 16GB, OCZ-Vertex3 256GB OS, OMV 3.0, 4x 2TB, IBM-Raid5
    • Hi,

      You shouldn't have done this, these two files in /etc/default MUST NOT be deleted they are created at the very first installation of virtualbox.
      As I said, to get them back you have to delete the vbox user and vboxusers group, and remove /tmp/.vbox-vbox-ipc/. Then reinstall virtualbox.

      Next time you read a topic, go to the end before doing anything, it will save you time.
    • I use scrip to install virtualbox 5.02 and works fine for several weeks.

      some idea a bout update of the plugging so other users can install virtualBox as pluging and not using shell?.
      OMV 4.1.11 x64 on a HP T510, 16GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
      Dockers: MLDonkey ; PiHole ; weTTY
      Videos: @TechnoDadLife
    • I've mentioned this before but you have to purge virtualbox 4.3 before installing virtualbox 5.0. Allowing updates of the plugin will never do this. So, I don't know how to change the plugin to fix the issue. It would really need to be fixed in the virtualbox 5.0 packages to allow upgrading from 4.3.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!