Some help please - virtualbox won't update to latest version

    • OMV 2.x
    • Resolved
    • Some help please - virtualbox won't update to latest version

      Hello.

      I've been using OMV for quite some time now without any major problems. I am currently at v2.1.11 with v1.34 of the omv-extras plugin.

      A while back I installed virtualbox through there and although I had some minor issues in getting it to work at first then everything was fine. However, I recently realized that there is a newer version than the one I currently have installed (v1.3) but no matter how I try to update (either through the web gui or command) I don't receive the latest version.

      Any help would be much appreciated on this.

      Many thanks!
      P.
    • ryecoaaron wrote:

      1.3 is the newest version.


      Hey, thanks for replying.

      I must be mising something then... The changelog at github.com/OpenMediaVault-Plug…b/master/debian/changelog reads:

      openmediavault-virtualbox (1.4) stable; urgency=low
      * Add vbox user to cdrom group * Update to Virtualbox 5.0
      -- OpenMediaVault Plugin Developers <plugins@omv-extras.org> Thu, 06 Aug 2015 07:40:15 -0500

      So I assumed that 1.4 is now the latest version.

      I guess I could pose another (similar) question: is it possible at all to update phpvirtualbox on OMV to its current version (5)?

      Thanks again for your time and assistance!
      P.

      The post was edited 1 time, last by phoebus ().

    • I made the changes on github (v1.4) but there is a big issue moving to virtualbox 5.0... You have to completely uninstall virtualbox 4.3 before installing it. That is why the plugin is not in the repo.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I don't know what to do. This is the way virtualbox has always been with major upgrades. I can't think of a way around it and we don't package virtualbox. So, difficult to fix.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Yep, it works fine in my tests.

      wget http://download.virtualbox.org/virtualbox/5.0.2/virtualbox-5.0_5.0.2-102096~Debian~wheezy_amd64.deb
      wget http://omv-extras.org/testing2/openmediavault-virtualbox_1.4_all.deb
      wget http://omv-extras.org/testing2/virtualbox-extpack-installer_5.0.2_all.deb
      wget http://omv-extras.org/testing2/phpvirtualbox_5.0-1_all.deb

      (Don't remember if you have to just remove or purge. Try remove first)
      apt-get remove virtualbox-4.3 openmediavault-virtualbox virtualbox-extpack-installer

      dpkg -i virtualbox-extpack-installer_5.0.2_all.deb openmediavault-virtualbox_1.4_all.deb virtualbox-5.0_5.0.2-102096~Debian~wheezy_amd64.deb phpvirtualbox_5.0-1_all.deb
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!

      The post was edited 1 time, last by ryecoaaron ().

    • Hi,

      Thank you for the upgrade guide, since I updated to Windows 10 I could not connect to Virtualbox RDP (Bug solved with virtualbox 5.0.2).
      You just forgot the phpvirtualbox package : omv-extras.org/testing2/phpvirtualbox_5.0-1_all.deb

      Without it, dpkg refuses to install openmediavault-virtualbox 1.4.

      Just upgraded, restarted my NAS, Virtualbox runs fine, but when opening phpvirtualbox I get a 404 error. Any idea ?

      Thanks.
    • Try:
      rm -f /etc/default/openmediavault-virtualbox /etc/default/virtualbox
      apt-get install --reinstall openmediavault-virtualbox
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Nope, I didn't mean dpkg -r. Remove all of the packages (virtualbox, openmediavault-virtualbox, phpvirtualbox, virtualbox-extpack-installer) and delete the two files in /etc/default. Then reinstall using the dpkg commands in my previous post (fixed for missing phpvirtualbox). You can't just create an empty file. The plugin should create it. All of this is why these packages aren't in the repo. Major upgrades are a pain in the ass.
      omv 4.1.22 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I followed the thread but I don't get phpvirtualbox working.

      Message:
      ​readyState: "4"
      responseText: "File not found.
      "
      status: "404"
      statusText: "Not Found"


      any ideas?

      I've got two warnings during installation:

      Source Code

      1. ​insserv: warning: current start runlevel(s) (empty) of script `vboxinit' overrides LSB defaults (2 3 4 5).
      2. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `vboxinit' overrides LSB defaults (0 1 6).
      OMV 2.1.1 with backport-kernel 3.16
      Antworten/ Answers/ Réponse: deutsch - english - français und/and/et Linux :)
    • Which package gave you these warnings ?
      Did you purge the pevious packages ?

      You should run this :
      dpkg --purge php-virtualbox virtualbox-5.0 virtualbox-extpack-installer openmediavault-virtualbox
      then reinstall the downloaded packages :
      dpkg -i virtualbox-5.0 virtualbox-extpack-installer php-virtualbox openmediavault-virtualbox

      Then restart your NAS.
    • ok, I think I've missed something - now nothing works anymore...
      after downloading I get:

      root@my-omv:~# dpkg -i virtualbox-5.0 virtualbox-extpack-installer php-virtualbox openmediavault-virtualbox
      dpkg: Fehler beim Bearbeiten von virtualbox-5.0 (--install):
      Auf das Archiv kann nicht zugegriffen werden: Datei oder Verzeichnis nicht gefunden
      dpkg: Fehler beim Bearbeiten von virtualbox-extpack-installer (--install):
      Auf das Archiv kann nicht zugegriffen werden: Datei oder Verzeichnis nicht gefunden
      dpkg: Fehler beim Bearbeiten von php-virtualbox (--install):
      Auf das Archiv kann nicht zugegriffen werden: Datei oder Verzeichnis nicht gefunden
      dpkg: Fehler beim Bearbeiten von openmediavault-virtualbox (--install):
      Auf das Archiv kann nicht zugegriffen werden: Datei oder Verzeichnis nicht gefunden
      Fehler traten auf beim Bearbeiten von:
      virtualbox-5.0
      virtualbox-extpack-installer
      php-virtualbox
      openmediavault-virtualbox
      OMV 2.1.1 with backport-kernel 3.16
      Antworten/ Answers/ Réponse: deutsch - english - français und/and/et Linux :)