Help with ethtool WOL a.s.o.

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Help with ethtool WOL a.s.o.

      Hello experts,

      i tried to use the WOL option but the Manual referenced for ethtool in the GUI is of no help for me - a total *-nix newbie ....

      Source Code

      1. root@OMV:~# ethtool eth0
      2. Settings for eth0:
      3. Supported ports: [ TP ]
      4. Supported link modes: 10baseT/Half 10baseT/Full
      5. 100baseT/Half 100baseT/Full
      6. 1000baseT/Full
      7. Supported pause frame use: No
      8. Supports auto-negotiation: Yes
      9. Advertised link modes: 10baseT/Half 10baseT/Full
      10. 100baseT/Half 100baseT/Full
      11. 1000baseT/Full
      12. Advertised pause frame use: No
      13. Advertised auto-negotiation: Yes
      14. Speed: 1000Mb/s
      15. Duplex: Full
      16. Port: Twisted Pair
      17. PHYAD: 2
      18. Transceiver: internal
      19. Auto-negotiation: on
      20. MDI-X: on
      21. Supports Wake-on: pumbg
      22. Wake-on: g
      23. Current message level: 0x00000007 (7)
      24. drv probe link
      25. Link detected: yes
      Display All


      and

      Source Code

      1. root@OMV:~# ethtool eth1
      2. Settings for eth1:
      3. Supported ports: [ TP MII ]
      4. Supported link modes: 10baseT/Half 10baseT/Full
      5. 100baseT/Half 100baseT/Full
      6. 1000baseT/Half 1000baseT/Full
      7. Supported pause frame use: No
      8. Supports auto-negotiation: Yes
      9. Advertised link modes: 10baseT/Half 10baseT/Full
      10. 100baseT/Half 100baseT/Full
      11. 1000baseT/Half 1000baseT/Full
      12. Advertised pause frame use: Symmetric Receive-only
      13. Advertised auto-negotiation: Yes
      14. Link partner advertised link modes: 10baseT/Half 10baseT/Full
      15. 100baseT/Half 100baseT/Full
      16. 1000baseT/Full
      17. Link partner advertised pause frame use: Symmetric
      18. Link partner advertised auto-negotiation: Yes
      19. Speed: 1000Mb/s
      20. Duplex: Full
      21. Port: MII
      22. PHYAD: 0
      23. Transceiver: internal
      24. Auto-negotiation: on
      25. Supports Wake-on: pumbg
      26. Wake-on: g
      27. Current message level: 0x00000033 (51)
      28. drv probe ifdown ifup
      29. Link detected: yes
      Display All


      my problem - i don't have any idea how to use the WOL settings - like m (my guess a magic password pattern)
      and in my bios i can only set wake on PCIE/PCI - but no other parameters - so for every round robin or broadcast call
      from the router the system wakes up ....

      so please can you tell me how to use nettool because i am quite ?(

      cheers ahab666
      the system starts ....
    • @gderf

      thx for the link - altering the biossettings did not solve my problem but as the guy in your first link replied ... not really obvious -

      network stack in bios meant booting an OS via the network (at least in the old days)

      now i just need to find a wol tool for windows that works - somehow the router or the switches seem to block the wol packages ...

      cheers - ahab666

      The post was edited 2 times, last by ahab666 ().