omv 1.9 broken after attempted upgrade from webgui

    • OMV 1.0
    • Resolved
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • omv 1.9 broken after attempted upgrade from webgui

      Now I can't get into the webgui any more.
      I do have ssh access though.
      Tried the usual apt commands but just can't make any progress.
      when I do

      Source Code

      1. apt-get install openmediavault

      I get

      Source Code

      1. Reading package lists... Done
      2. Building dependency tree
      3. Reading state information... Done
      4. Some packages could not be installed. This may mean that you have
      5. requested an impossible situation or if you are using the unstable
      6. distribution that some required packages have not yet been created
      7. or been moved out of Incoming.
      8. The following information may help to resolve the situation:
      9. The following packages have unmet dependencies:
      10. openmediavault : Depends: php5-pam but it is not going to be installed
      11. Depends: proftpd-mod-vroot but it is not going to be installed
      12. Depends: php5-proctitle but it is not going to be installed
      13. E: Unable to correct problems, you have held broken packages
      Display All


      Is this fixable or do I just reinstall from cd?
      Thanks for any help
    • Source Code

      1. root@openmediavault:~# cat /etc/debian_version
      2. 8.1


      Also tried with aptitude.
      This is what I get

      Source Code

      1. root@openmediavault:~# aptitude install openmediavault
      2. The following NEW packages will be installed:
      3. avahi-daemon{a} beep{a} bind9-host{a} collectd{a} collectd-core{a} cpufrequtils{a} cron-apt{a} gdisk{a} hdparm{a} libavahi-core7{a} libcpufreq0{a}
      4. libdaemon0{a} libdbi1{a} libjavascript-minifier-xs-perl{a} libjs-extjs4{a} libjson-perl{a} liblocale-po-perl{a} libltdl7{a} libmagic1{a}
      5. libnss-mdns{a} libonig2{a} libossp-uuid16{a} libperl4-corelibs-perl{a} libqdbm14{a} librrd4{a} libxslt1.1{a} lsof{a} lvm2{a} monit{a} nginx{a}
      6. nginx-common{a} nginx-full{a} ntfs-3g{a} openmediavault openssh-blacklist-extra{a} php-json-schema{a} php5-cgi{a} php5-cli{a} php5-common{a}
      7. php5-fpm{a} php5-json{a} php5-pam{ab} php5-proctitle{ab} pm-utils{a} python-apt-common{a} python3-apt{a} quotatool{a} rrdcached{a} rrdtool{a}
      8. rsync{a} samba{a} samba-common{a} samba-common-bin{a} samba-dsdb-modules{a} sdparm{a} smartmontools{a} snmpd{a} socat{a} tftpd-hpa{a} uuid{a}
      9. xmlstarlet{a}
      10. The following packages are RECOMMENDED but will NOT be installed:
      11. attr default-jre-headless iso-codes libcurl3-gnutls libesmtp6 libgdk-pixbuf2.0-0 libjson-xs-perl liblvm2app2.2 libmnl0 libmodbus5 libmysqlclient18
      12. libnotify4 libnspr4 libnspr4-0d libnss3 libnss3-1d libopenipmi0 liboping0 libowcapi-2.9-8 libpcap0.8 libpq5 libprotobuf-c1 librabbitmq1
      13. libtokyotyrant3 libupsclient4 libvirt0 libyajl2 lsb-release openssh-blacklist php5-readline samba-vfs-modules vbetool
      14. 0 packages upgraded, 61 newly installed, 0 to remove and 1 not upgraded.
      15. Need to get 26.7 MB/33.7 MB of archives. After unpacking 142 MB will be used.
      16. The following packages have unmet dependencies:
      17. php5-pam : Depends: phpapi-20100525+lfs which is a virtual package.
      18. php5-proctitle : Depends: phpapi-20100525+lfs which is a virtual package.
      19. The following actions will resolve these dependencies:
      20. Keep the following packages at their current version:
      21. 1) openmediavault [Not Installed]
      22. 2) php5-pam [Not Installed]
      23. 3) php5-proctitle [Not Installed]
      24. Accept this solution? [Y/n/q/?]
      Display All
    • Ok, thanks for trying.
      But I've managed to fix it by following this page
      ispire.me/downgrade-from-debia…le-from-jessie-to-wheezy/
      In particular, things started happening after I did what was suggested in post by Todd, purging Python and reinstalling it.
      After that I had to run several rounds of apt-get upgrade and reboots.
      Then finally

      Source Code

      1. apt-get install openmediavault
      worked
      I now have omv-2.1.11 installed and working.
      My configuration was not lost and my raid volume is there.
      So I'm happy for now.

      However, the Update Manager in the webgui is showing similar packages like before the breakage.
      It's showing for example both gcc-4.7 and gcc-4.9 and libsystemd-daemon0 which leads me to suspect I'd end up with the same mess as before (Jessie stable) if I allowed it to upgrade.
      So is there a fix for this?
    • I've copied the sources.list from a clean, fresh install of omv-2.1.11
      that I did on another system just a few days ago.
      But I suspect it has to do with the sources config somewhere.
      This is what I have in my sources.list

      Source Code

      1. #
      2. # deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official Snapshot amd64 LIVE/INST
      3. #deb cdrom:[Debian GNU/Linux 7.0.0 _Wheezy_ - Official Snapshot amd64 LIVE/INSTA
      4. deb http://ftp.ca.debian.org/debian/ wheezy main
      5. deb-src http://ftp.ca.debian.org/debian/ wheezy main
      6. deb http://security.debian.org/ wheezy/updates main contrib non-free
      7. deb-src http://security.debian.org/ wheezy/updates main contrib non-free
      8. # wheezy-updates, previously known as 'volatile'
      9. deb http://ftp.ca.debian.org/debian/ wheezy-updates main contrib non-free
      10. deb-src http://ftp.ca.debian.org/debian/ wheezy-updates main contrib non-free
      Display All
    • subzero79 wrote:

      Replace the value stable for wheezy in /etc/apt/sources.list

      then run apt-get update


      Ok, I can add to my previous reply that I've made one more change afterwards that resolved the Update Manager
      I had in my /etc/apt one more file I've added during the repair process.
      It's "preference" and it contains

      Source Code

      1. Package: *
      2. Pin: release n=wheezy
      3. Pin-Priority: 1001


      I've renamed it to preference.old (to keep it for reference in case it's needed again)
      and all is good now.
      Update manager showed only 3 updates
      omv-2.1.12
      vsftp updat
      and timezone updates (forgot the exact names)

      But all is good now.