Kernel 4.x wanted, running OMV 1.19

    • OMV 1.0
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Cool, thanks :)

      I'll do another compile run today and see if things work out.

      Any further things somebody needs in the kernel? I am very willing to share the packages once omvextras is working correctly again! In case people want to try btrfs raid56 or other new features like the ext4 encryption (already compiled in), etc. Currently, the most vital FSes are compiled into the kernel, the remaining ones are are modules. I also can include more device drivers as modules for convinience.
    • Impressive progress! I'm afraid I lack the experience you guys have. I tried to compile, but failed, among others because of lack of space on my VM (disc size was only 10 GB). I noticed that bc was missing as well.
      I downloaded a Ubuntu/Debian 4.2 kernel from here to try out, and i used the updated btrfs-tools as well. System booted at least and OMV seems to be running.
      But... I noticed the same behavior in regards to the repo-options (missing categories) in the omv-extras tab.

      @stone49th, subzero79
      Would you be willing to make the kernels you compiled available to me (as a .deb packages, the image and header package i think?).
    • Well, not so much progress after all ;) My box has not come to live this morning and is not responding to wol I can't compile the kernel until I get back home to the machine...

      I've actually never compiled a kernel "The Debian Way", but it might be worth a try. Let's see if the wol / rtc-start issue is kernel or config related...I might have messed up with ACPI/Network/Drivers there or it did not configure it properly (maybe a redo in the webgui would help...)

      You already poked around with the debian source...did you use this one?
    • Yes that one. I modified the control
      file for gcc4.9, but it wasn't enough, plenty of other references. My guess is to use the vanilla one to avoid this annoyances. @davidh2k once mentioned me the steps for building vanilla to be standardized to Debian package, including the headers
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • Ok, my attempt would also be to work with vanilla, and provide those to people willing to use a more recent "non-debian" kernel if they wish to do so. It's much easier to compile and deal with.

      I was building with something like

      Source Code

      1. make -j5 deb-pkg LOCALVERSION=-omvstone KDEB_PKGVERSION=5

      soon to be changed to

      Source Code

      1. make -j5 deb-pkg LOCALVERSION=-omvstone_amd64 KDEB_PKGVERSION=6

      Hopefully omvextras will accept that. Outcome is the usual .deb collection of headers, images, firmware, libc-dev and debug-image. I incremented the pkgversion after each run (to avoid dpkg yelling at me) because I wasn't sure if I could re-install the .deb in a simple way otherwise without switching kernels, reboot, purge, install, switch, reboot. So far the simple dpkg -i for all packages worked without issues, plus the usual reboot.

      Main problem from my point of view is to know/find all of those patches that are necessary/nice to have for most people in the omv-universe which are not in stable-vanilla. aufs was one of them, which was easy to copy and apply and configure (aufs4.1-standalone). Don't know whether there are other "vital" patches for debian and if they are a major pain in the ass to apply. And a correct config, of course :)

      Edit: Just checked on those patches in the linux-source-4.1.6 by debian. Nothing special there for amd64, and besides aufs4, there is only grsecurity patched in which could be of importance for us. So I guess we're fine with vanilla then?!

      The post was edited 2 times, last by stone49th ().

    • Ok, forget about the wakeup fault in wrong auto-shutdown setup to pm-hibernate which my mainboard can't handle for some reasons.

      The kernel is compiling and I will test omvextras with it this evening. After that, I'll upload the debs to github along with my current source directory.

      Edit: omvextras is fine again. I'll upload during the course of the day, along with some basic instructions on how I build / install the kernel. Is there a way to "export the kernel config" to a more pretty format? So that people could easily see if a module/buildin code in question is in there?

      The post was edited 2 times, last by stone49th ().

    • Virtualbox from can not use any more

      I have install kernel 4.1.7-omvstone-amd64

      After reboot and install Virtualbox again this error message occur:

      Source Code

      1. root@xxxx:~# cat /var/log/vbox-install.log
      2. make KBUILD_VERBOSE=1 SUBDIRS=/tmp/vbox.0 SRCROOT=/tmp/vbox.0 CONFIG_MODULE_SIG= -C /lib/modules/4.1.7-omvstone-amd64/build modules
      3. test -e include/generated/autoconf.h -a -e include/config/auto.conf || ( \
      4. echo >&2; \
      5. echo >&2 " ERROR: Kernel configuration is invalid."; \
      6. echo >&2 " include/generated/autoconf.h or include/config/auto.conf are missing.";\
      7. echo >&2 " Run 'make oldconfig && make prepare' on kernel src to fix it."; \
      8. echo >&2 ; \
      9. /bin/false)
      10. mkdir -p /tmp/vbox.0/.tmp_versions ; rm -f /tmp/vbox.0/.tmp_versions/*
      11. make -f ./scripts/ obj=/tmp/vbox.0
      12. gcc -Wp,-MD,/tmp/vbox.0/linux/.SUPDrv-linux.o.d -nostdinc -isystem /usr/lib/gcc/x86_64-linux-gnu/4.7/include -I./arch/x86/include -Iarch/x86/include/generated/uapi -Iarch/x86/include/generated -Iinclude -I./arch/x86/include/uapi -Iarch/x86/include/generated/uapi -I./include/uapi -Iinclude/generated/uapi -include ./include/linux/kconfig.h -D__KERNEL__ -Wall -Wundef -Wstrict-prototypes -Wno-trigraphs -fno-strict-aliasing -fno-common -Werror-implicit-function-declaration -Wno-format-security -std=gnu89 -m64 -mno-80387 -mno-fp-ret-in-387 -mtune=generic -mno-red-zone -mcmodel=kernel -funit-at-a-time -maccumulate-outgoing-args -DCONFIG_X86_X32_ABI -DCONFIG_AS_CFI=1 -DCONFIG_AS_CFI_SIGNAL_FRAME=1 -DCONFIG_AS_CFI_SECTIONS=1 -DCONFIG_AS_FXSAVEQ=1 -DCONFIG_AS_SSSE3=1 -DCONFIG_AS_CRC32=1 -DCONFIG_AS_AVX=1 -DCONFIG_AS_AVX2=1 -pipe -Wno-sign-compare -fno-asynchronous-unwind-tables -mno-sse -mno-mmx -mno-sse2 -mno-3dnow -mno-avx -fno-delete-null-pointer-checks -O2 --param=allow-store-data-races=0 -Wframe-larger-than=2048 -fstack-protector -Wno-unused-but-set-variable -fno-var-tracking-assignments -g -pg -mfentry -DCC_USING_FENTRY -Wdeclaration-after-statement -Wno-pointer-sign -fno-strict-overflow -fconserve-stack -Werror=implicit-int -Werror=strict-prototypes -DCC_HAVE_ASM_GOTO -include /tmp/vbox.0/include/VBox/SUPDrvMangling.h -I/lib/modules/4.1.7-omvstone-amd64/build/include -I/tmp/vbox.0/ -I/tmp/vbox.0/include -I/tmp/vbox.0/r0drv/linux -I/tmp/vbox.0/vboxdrv/ -I/tmp/vbox.0/vboxdrv/include -I/tmp/vbox.0/vboxdrv/r0drv/linux -D__KERNEL__ -DMODULE -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 -DIN_SUP_R0 -DVBOX -DRT_WITH_VBOX -DVBOX_WITH_HARDENING -Wno-declaration-after-statement -DCONFIG_VBOXDRV_AS_MISC -DRT_ARCH_AMD64 -DVBOX_WITH_64_BITS_GUESTS -DMODULE -D"KBUILD_STR(s)=#s" -D"KBUILD_BASENAME=KBUILD_STR(SUPDrv_linux)" -D"KBUILD_MODNAME=KBUILD_STR(vboxdrv)" -c -o /tmp/vbox.0/linux/.tmp_SUPDrv-linux.o /tmp/vbox.0/linux/SUPDrv-linux.c
      13. scripts/genksyms/genksyms: /lib/x86_64-linux-gnu/ version `GLIBC_2.14' not found (required by scripts/genksyms/genksyms)
      14. make[2]: *** [/tmp/vbox.0/linux/SUPDrv-linux.o] Error 1
      15. make[1]: *** [_module_/tmp/vbox.0] Error 2
      16. make: *** [vboxdrv] Error 2)
      Display All
    • read this one until the end - same issue, i guess -->

      I'll update to a more recent 4.1 in the next days, just FYI (which probably wont resolve your issue...)

      Since we now had this problem two times already, it seems like something is wrong with some installations...did you also update from old versions like the fellow member in the github issue?
    • Thanks for your information’s.
      I have install Openmediavault 2.1 iso and then update to 2.1.16 and after that to 2.1.17.
      In Version 2.1.16 I install plugin ( Virtualbox, Plex ).
      Now I want use your kernel. I install Git in Openmediavault version 2.1.17 and install your kernel with dpkg -i linux-*.deb.
    • Hm, first up the config seems to be missing in the source. Please go to the kernel source dir (should be in /usr/src/) and run "make oldconfig && make prepare".

      I guess you just have to install a newer version of glibc, I personally installed 2.17 back when I started with the kernel for no apperent reason from this thread here:…on-2-13-to-2-15-on-debian. Should be working out of the box, but do not forget to remove the sid from the sources list afterwards or your system will break very badly.
    • Please go to the kernel source dir (should be in /usr/src/) and run "make oldconfig && make prepare

      Not possible if I install the Kernel from your DEB packets. But your hind to install a newer version of glibc solve the problem.

      Source Code

      1. Add the following line to the file /etc/apt/sources.list:
      2. deb sid main
      3. apt-get update
      4. apt-get -t sid install libc6 libc6-dev libc6-dbg
      5. remove deb sid main from sources.list
      6. reboot
      7. dpkg-reconfigure virtualbox-4.3
      8. dpkg-reconfigure virtualbox-extpack-installer
      Display All

      Short question why you install a new libc6
      Is it possible to provide a kernel that is compiled with the original version from Debian Wheezy?

      Thanks a lot!
    • Hm, not sure why I needed the libc update in the first place, whether it was a kernel dependency or by other programs. I'm rather busy right now, so I sadly cant do a further investigation in a vm right now. Maybe someone could help out...

      Setup would be:
      -OMV with extras+backports
      -Stock glibc (not sure if backports has a more recent version than stock wheezy)
      -get my github stuff and compile with my config
      -see if it works and report back the outputs, if it is fine, i'll look into providing two sets of packages for the different lib versions if one can specify the lib to be used for the build without rewriting all make files...

      So long,