Docker GUI plugin now stable

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • flvinny521 wrote:

      majorpayne wrote:

      So, I know this is simple but i can't find my rutorrent config file so I can change the port. Everytime I attempt to change it via the WebGui it resets itself back to 51500. I tried to open it but i'm afraid that my ISP is blocking it.
      Did you specify a path for /config in the image settings?
      Yes I did, I did it outside the container, the problem is that there is nothing there.
    • Hello everyone

      Unfortunately, I have a problem with Docker.
      I followed the following tutorial:

      When I install the docker plugin, it seems to work. However when I want to activate it I have an error message.

      Source Code

      1. Erreur #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start 'docker' 2>&1' with exit code '1': Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/ OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/ OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/omvdocker/Utils.php(108): OMV\System\SystemCtl->start()
      7. #3 /usr/share/omvdocker/Utils.php(645): OMVModuleDockerUtil::startDockerService()
      8. #4 /usr/share/openmediavault/engined/rpc/ OMVModuleDockerUtil::changeDockerSettings(Array, 42005, '/srv/dev-disk-b...')
      9. #5 [internal function]: OMVRpcServiceDocker->setSettings(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/ call_user_func_array(Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/ OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
      12. #8 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'setSettings', Array, Array, 1)
      13. #9 {main}
      Display All
      So I can not run a program like Jeedom or zoneminder.

      Could you give me a hand?

      Thank you in advance.

    • majorpayne wrote:

      I just don't get it... Qbittorent never needs me to open ports, Deluge doesn't need it either. One is running in a docker the other is not. rtorrent the port is ALWAYS closed.This means I get horrible throughput.
      Based on this not being related to the topic of the Docker GUI plugin, I'd suggest opening a separate thread or even opening an issue with the Docker container creator/maintainer.

      On the "never needs me to open ports" - It's not necessarily an issue of opening ports in Docker. If you can get connections and downloads to work at all, then it's the first issue of firewall/router ports. If the ports weren't open or functioning inside the docker container, you would get 0 connection. I'd suggest that perhaps the other apps are using a default port that is the same and already opened on your firewall/router, or are using UPnP to open the ports and the other is not. Lastly, make sure if you are "testing" that you are using the same exact torrent file in multiple apps to compare "horrible throughput". Every torrent is different and can't be compared independently or you will no-doubtedly see great variations in perceived performance.
    • Hi all,

      I am a docker newbie and I am trying to get the OMV docker GUI plugin working on my rock64 board - OMV3 / linux / jessie / armhf

      From the rock64 forum boards, I have read that some people have docker working so I think it is possible but it looks quite complicated (for me).

      My OMV 3 setup is clean/new and up to date (apt-get update) and working well but I get the following error(s) when I try to add the docker CE repo and update.

      W: Failed to fetch Unable to find expected entry 'stable/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

      W: Failed to fetch…cker/dists/jessie/Release Unable to find expected entry 'main/binary-arm64/Packages' in Release file (Wrong sources.list entry or malformed file)

      Any ideas how I can resolve these errors? I'm running armhf (not arm64).

    • Looks like you will have to build docker to your arch. Docker doesn't supply arm64. Be careful after building to download images corresponding to your arch, not anything you find on the hub.
      omv plugins are arch agnostic, but in this case originally it was restricted to amd64, since docker started distributing this arch originally. @ryecoaaron lifted the restriction to add armhf because docker now ships armhf.

      Once you get docker build for your arch you can install the plugin manually
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • first step (installing docker CE) was easier than I expected...

      Used instructions here to install docker CE…bian/#install-docker-ce-1

      then tested by using

      sudo docker run armhf/hello-world

      latest: Pulling from armhf/hello-world
      a0691bf12e4e: Pull complete
      Digest: sha256:9701edc932223a66e49dd6c894a11db8c2cf4eccd1414f1ec105a623bf16b426
      Status: Downloaded newer image for armhf/hello-world:latest

      Hello from Docker on armhf!
      This message shows that your installation appears to be working correctly.

      To generate this message, Docker took the following steps:
      1. The Docker client contacted the Docker daemon.
      2. The Docker daemon pulled the "hello-world" image from the Docker Hub.
      3. The Docker daemon created a new container from that image which runs the
      executable that produces the output you are currently reading.
      4. The Docker daemon streamed that output to the Docker client, which sent it
      to your terminal.
    • 1activegeek wrote:

      Have you followed the instructions of the error message? It might be wise to take that first step, and the potentially share the output.
      Unfortunately I do not understand the error message.
      Here are the actions and messages that OMV returns to me

      Source Code

      1. root@NAS:~# apt-get install openmediavault-docker-gui
      2. Lecture des listes de paquets... Fait
      3. Construction de l'arbre des dépendances
      4. Lecture des informations d'état... Fait
      5. Les paquets supplémentaires suivants seront installés :
      6. docker-engine imagemagick-common liblqr-1-0 libmagickcore-6.q16-2
      7. libmagickwand-6.q16-2 omvextras-common php-symfony-class-loader php5-curl
      8. php5-imagick
      9. Paquets suggérés :
      10. libmagickcore-6.q16-2-extra
      11. Paquets recommandés :
      12. aufs-tools cgroupfs-mount cgroup-lite git ghostscript gsfonts
      13. ttf-dejavu-core
      14. Les NOUVEAUX paquets suivants seront installés :
      15. docker-engine imagemagick-common liblqr-1-0 libmagickcore-6.q16-2
      16. libmagickwand-6.q16-2 omvextras-common openmediavault-docker-gui
      17. php-symfony-class-loader php5-curl php5-imagick
      18. 0 mis à jour, 10 nouvellement installés, 0 à enlever et 0 non mis à jour.
      19. Il est nécessaire de prendre 21,7 Mo dans les archives.
      20. Après cette opération, 102 Mo d'espace disque supplémentaires seront utilisés.
      21. Souhaitez-vous continuer ? [O/n] o
      22. Réception de : 1 jessie/main liblqr-1-0 amd64 0.4.2-2 [24,6 kB]
      23. Réception de : 2 jessie/updates/main imagemagick-common all 8: [153 kB]
      24. Réception de : 3 jessie/main php-symfony-class-loader all 2.3.21+dfsg-4+deb8u3 [21,4 kB]
      25. Réception de : 4 jessie/updates/main libmagickcore-6.q16-2 amd64 8: [1 695 kB]
      26. Réception de : 5 jessie/main php5-curl amd64 5.6.30+dfsg-0+deb8u1 [28,0 kB]
      27. Réception de : 6 jessie/main omvextras-common all 3.0.1 [6 628 B]
      28. Réception de : 7 debian-jessie/main docker-engine amd64 17.05.0~ce-0~debian-jessie [19,2 MB]
      29. Réception de : 8 jessie/main php5-imagick amd64 3.2.0~rc1-1 [101 kB]
      30. Réception de : 9 jessie/main openmediavault-docker-gui amd64 3.1.9 [49,5 kB]
      31. Réception de : 10 jessie/updates/main libmagickwand-6.q16-2 amd64 8: [407 kB]
      32. 72% [7 docker-engine 13,2 MB/19,2 MB 69%] 191 kB/s 31s 21,7 Mo réceptionnés en 1min 34s (229 ko/s)
      33. Sélection du paquet imagemagick-common précédemment désélectionné.
      34. (Lecture de la base de données... 96600 fichiers et répertoires déjà installés.)
      35. Préparation du dépaquetage de .../imagemagick-common_8%3a6.8.9.9-5+deb8u11_all.deb ...
      36. Dépaquetage de imagemagick-common (8: ...
      37. Sélection du paquet liblqr-1-0:amd64 précédemment désélectionné.
      38. Préparation du dépaquetage de .../liblqr-1-0_0.4.2-2_amd64.deb ...
      39. Dépaquetage de liblqr-1-0:amd64 (0.4.2-2) ...
      40. Sélection du paquet libmagickcore-6.q16-2:amd64 précédemment désélectionné.
      41. Préparation du dépaquetage de .../libmagickcore-6.q16-2_8%3a6.8.9.9-5+deb8u11_amd64.deb ...
      42. Dépaquetage de libmagickcore-6.q16-2:amd64 (8: ...
      43. Sélection du paquet libmagickwand-6.q16-2:amd64 précédemment désélectionné.
      44. Préparation du dépaquetage de .../libmagickwand-6.q16-2_8%3a6.8.9.9-5+deb8u11_amd64.deb ...
      45. Dépaquetage de libmagickwand-6.q16-2:amd64 (8: ...
      46. Sélection du paquet docker-engine précédemment désélectionné.
      47. Préparation du dépaquetage de .../docker-engine_17.05.0~ce-0~debian-jessie_amd64.deb ...
      48. Dépaquetage de docker-engine (17.05.0~ce-0~debian-jessie) ...
      49. Sélection du paquet php-symfony-class-loader précédemment désélectionné.
      50. Préparation du dépaquetage de .../php-symfony-class-loader_2.3.21+dfsg-4+deb8u3_all.deb ...
      51. Dépaquetage de php-symfony-class-loader (2.3.21+dfsg-4+deb8u3) ...
      52. Sélection du paquet omvextras-common précédemment désélectionné.
      53. Préparation du dépaquetage de .../omvextras-common_3.0.1_all.deb ...
      54. Dépaquetage de omvextras-common (3.0.1) ...
      55. Sélection du paquet php5-curl précédemment désélectionné.
      56. Préparation du dépaquetage de .../php5-curl_5.6.30+dfsg-0+deb8u1_amd64.deb ...
      57. Dépaquetage de php5-curl (5.6.30+dfsg-0+deb8u1) ...
      58. Sélection du paquet php5-imagick précédemment désélectionné.
      59. Préparation du dépaquetage de .../php5-imagick_3.2.0~rc1-1_amd64.deb ...
      60. Dépaquetage de php5-imagick (3.2.0~rc1-1) ...
      61. Sélection du paquet openmediavault-docker-gui précédemment désélectionné.
      62. Préparation du dépaquetage de .../openmediavault-docker-gui_3.1.9_amd64.deb ...
      63. Dépaquetage de openmediavault-docker-gui (3.1.9) ...
      64. Traitement des actions différées (« triggers ») pour man-db ( ...
      65. Traitement des actions différées (« triggers ») pour systemd (215-17+deb8u7) ...
      66. Traitement des actions différées (« triggers ») pour openmediavault (3.0.93) ...
      67. Restarting engine daemon ...
      68. Traitement des actions différées (« triggers ») pour php5-fpm (5.6.30+dfsg-0+deb8u1) ...
      69. Paramétrage de imagemagick-common (8: ...
      70. Paramétrage de liblqr-1-0:amd64 (0.4.2-2) ...
      71. Paramétrage de libmagickcore-6.q16-2:amd64 (8: ...
      72. Paramétrage de libmagickwand-6.q16-2:amd64 (8: ...
      73. Paramétrage de docker-engine (17.05.0~ce-0~debian-jessie) ...
      74. Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.
      75. invoke-rc.d: initscript docker, action "start" failed.
      76. dpkg: erreur de traitement du paquet docker-engine (--configure) :
      77. le sous-processus script post-installation installé a retourné une erreur de sortie d'état 1
      78. Paramétrage de php-symfony-class-loader (2.3.21+dfsg-4+deb8u3) ...
      79. Paramétrage de omvextras-common (3.0.1) ...
      80. Paramétrage de php5-curl (5.6.30+dfsg-0+deb8u1) ...
      81. php5_invoke: Enable module curl for cgi SAPI
      82. php5_invoke: Enable module curl for fpm SAPI
      83. php5_invoke: Enable module curl for cli SAPI
      84. Paramétrage de php5-imagick (3.2.0~rc1-1) ...
      85. php5_invoke: Enable module imagick for cgi SAPI
      86. php5_invoke: Enable module imagick for fpm SAPI
      87. php5_invoke: Enable module imagick for cli SAPI
      88. dpkg: des problèmes de dépendances empêchent la configuration de openmediavault-docker-gui :
      89. openmediavault-docker-gui dépend de docker-engine (>= 1.12) ; cependant :
      90. Le paquet docker-engine n'est pas encore configuré.
      91. dpkg: erreur de traitement du paquet openmediavault-docker-gui (--configure) :
      92. problèmes de dépendances - laissé non configuré
      93. Traitement des actions différées (« triggers ») pour libc-bin (2.19-18+deb8u10) ...
      94. Traitement des actions différées (« triggers ») pour openmediavault (3.0.93) ...
      95. Updating file permissions ...
      96. Purging internal cache ...
      97. Restarting engine daemon ...
      98. Traitement des actions différées (« triggers ») pour php5-fpm (5.6.30+dfsg-0+deb8u1) ...
      99. Des erreurs ont été rencontrées pendant l'exécution :
      100. docker-engine
      101. openmediavault-docker-gui
      102. E: Sub-process /usr/bin/dpkg returned an error code (1)
      Display All
    • Hello All,
      I am New to docker, I love the idea of containers.

      I did get docker installed on my OMV 3.0.

      Source Code

      1. sudo apt-get update
      2. sudo apt-get install docker-ce

      I then tested it with

      Source Code

      1. sudo docker run hello-world
      everything worked fine.

      I am looking to install the plugin but it keeps failing.
      Here is the install log.

      Source Code

      1. >>> *************** Error ***************
      2. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-docker-gui 2>&1' with exit code '100': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Some packages could not be installed. This may mean that you have
      6. requested an impossible situation or if you are using the unstable
      7. distribution that some required packages have not yet been created
      8. or been moved out of Incoming.
      9. The following information may help to resolve the situation:
      10. The following packages have unmet dependencies:
      11. openmediavault-docker-gui : Depends: php5-imagick but it is not installable
      12. E
      13. :
      14. Unable to correct problems, you have held broken packages.
      15. <<< *************************************
      Display All
      Any Ideas ?
    • I just installed it from the ISO downloaded form

      here is my sources.

      Source Code

      1. cat /etc/apt/sources.list
      2. #
      3. # deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20170731-21:43]/ jessie contrib main non-free
      4. #deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20170731-21:43]/ jessie contrib main non-free
      5. deb jessie/updates main contrib non-free
      6. deb-src jessie/updates main contrib non-free
      7. # jessie-updates, previously known as 'volatile'
      8. deb jessie-updates main contrib non-free
      9. deb-src jessie-updates main contrib non-free
      10. root@openmediavault:~#
      Display All