Docker GUI plugin now stable

    • OMV 2.x
    • JanBanan wrote:

      I have the exact same issue, discovered it after i restarted the server today. I dont really keep track of the updates i apply but i know Docker was updated the other week and i 'think' i received a kernel update as well.
      OMV 3.0.95, kernel Linux 4.9.0-0.bpo.4-amd64 and Docker 17.12.0-ce.
      Do you still have this issue? I believe it should have been fixed now (the URL to the looks to be corrected).
    • Yep issue still there when i checked now:

      Error #0:exception 'ImagickException' with message 'Imagick::__construct(): HTTP request failed! HTTP/1.1 404 Not Found' in /usr/share/openmediavault/engined/rpc/docker.inc:1504Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(1504): Imagick->__construct('https://raw.git...')#1 [internal function]: OMVRpcServiceDocker->syncDockerLogos(NULL, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('syncDockerLogos', NULL, Array)#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'syncDockerLogos', NULL, Array, 1)#5 {main}

      And:

      Next exception 'ImagickException' with message 'Failed to read the file' in /usr/share/openmediavault/engined/rpc/docker.inc:1504Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(0): Imagick->__construct()#1 [internal function]: OMVRpcServiceDocker->syncDockerLogos(NULL, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('syncDockerLogos', NULL, Array)#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'syncDockerLogos', NULL, Array, 1)#5 {main}
    • Yep issue still there when i checked now:

      Error #0:exception 'ImagickException' with message 'Imagick::__construct(): HTTP request failed! HTTP/1.1 404 Not Found' in /usr/share/openmediavault/engined/rpc/docker.inc:1504Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(1504): Imagick->__construct('https://raw.git...')#1 [internal function]: OMVRpcServiceDocker->syncDockerLogos(NULL, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('syncDockerLogos', NULL, Array)#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'syncDockerLogos', NULL, Array, 1)#5 {main}

      And:

      Next exception 'ImagickException' with message 'Failed to read the file' in /usr/share/openmediavault/engined/rpc/docker.inc:1504Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(0): Imagick->__construct()#1 [internal function]: OMVRpcServiceDocker->syncDockerLogos(NULL, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('syncDockerLogos', NULL, Array)#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'syncDockerLogos', NULL, Array, 1)#5 {main}
    • Yep issue still there when i checked now..

      Edit: i am trying to paste the exception here but en exception is thrown =)

      Error #0:exception 'ImagickException' with message 'Imagick::__construct(): HTTP request failed! HTTP/1.1 404 Not Found' in /usr/share/openmediavault/engined/rpc/docker.inc:1504Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(1504): Imagick->__construct('https://raw.git...')#1 [internal function]: OMVRpcServiceDocker->syncDockerLogos(NULL, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('syncDockerLogos', NULL, Array)#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'syncDockerLogos', NULL, Array, 1)#5 {main}
    • Hi guys,

      there 2 issues while using docker, are there any solutions for that?

      1. system is not shutting down (with autoshutdown) while container is running
      2. if the system is shut down manually and is booting again - the container is running but not reachable

      For point 2: I have to deactivate docker in the gui and activate it again, after that the container is reachable again.
    • JanBanan wrote:

      Yep issue still there when i checked now..

      Edit: i am trying to paste the exception here but en exception is thrown =)

      Error #0:exception 'ImagickException' with message 'Imagick::__construct(): HTTP request failed! HTTP/1.1 404 Not Found' in /usr/share/openmediavault/engined/rpc/docker.inc:1504Stack trace:#0 /usr/share/openmediavault/engined/rpc/docker.inc(1504): Imagick->__construct('https://raw.git...')#1 [internal function]: OMVRpcServiceDocker->syncDockerLogos(NULL, Array)#2 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('syncDockerLogos', NULL, Array)#4 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Docker', 'syncDockerLogos', NULL, Array, 1)#5 {main}
      I just did a clean installation of OMV4 and installed the docker plugin. I get no errors... It feels like there was some issue with one of the URL's to the logos and that you might have that information cached on your end somehow...

      Could you try to access the plugin while in incognito mode in your browser?
    • I tried accessing the Docker service in Chromium browser incognito mode. It still throws that same error popup. And I have cleared the browser cache several times before too.

      Firefox and Chrome browsers also throw that same error and I do not recall visiting that page ever in those.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380