TFTP Server not running

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • TFTP Server not running

      I recently got Open Media Vault 0.4.6 running on a box for testing purposes.
      I installed many plugins and they all work flawless except DNS and DHCP plugin and the TFTP Service.
      Both gave me pretty much the same error.
      I removed the DNS and DHCP plugin first of all because i believed it was messing up with the TFTP service ,
      (probably I'm wrong about it) and second of all because I have an alternative solution for that.
      Even after that, TFTP service didn't start with the same error :

      Error #4000:
      exception 'OMVException' with message 'Failed to execute command 'export LANG=C; sudo invoke-rc.d 'tftpd-hpa' start 2>&1': Starting HPA's tftpd: in.tftpdinvoke-rc.d: initscript tftpd-hpa, action "start" failed.' in /usr/share/php/openmediavault/
      Stack trace:
      #0 /usr/share/php/openmediavault/ OMVSysVInitScript->invoke('start')
      #1 /usr/share/php/openmediavault/ OMVSysVInitScript->start()
      #2 /var/www/openmediavault/module/ OMVSysVInitScript->exec()
      #3 [internal function]: OMVTFTPModule->updateService(Array)
      #4 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      #5 /var/www/openmediavault/rpc/ OMVNotifyDispatcher->notify(8, 'org.openmediava...', Array)
      #6 [internal function]: TFTPRpc->set(Array)
      #7 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      #8 /usr/share/php/openmediavault/ OMVRpc::exec('TFTP', 'set', Array)
      #9 /var/www/openmediavault/rpc.php(44): OMVJsonRpcServer->handle()
      #10 {main}

      Hope this helps.
      Thanks in advance.