Manually configured DNS servers are not used

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Manually configured DNS servers are not used

      I've manually configured 3 DNS servers in the web GUI. I set a static IP. However, if I check with nslookup, the DNS server is wrong (my default router DNS, configured for OpenDNS). I've read some similar posts about deleting the eth0 entry, but that did not work. Any tips?

      Ralph

      Source Code

      1. cat /etc/network/interfaces
      2. # The loopback network interface
      3. auto lo
      4. iface lo inet loopback
      5. iface lo inet6 loopback
      6. # eth0 network interface
      7. auto eth0
      8. allow-hotplug eth0
      9. iface eth0 inet static
      10. address 192.168.1.7
      11. gateway 192.168.1.1
      12. netmask 255.255.255.0
      13. dns-nameservers 37.235.1.174 84.200.69.80 91.239.100.100
      14. iface eth0 inet6 manual
      15. pre-down ip -6 addr flush dev $IFACE
      Display All


      Source Code

      1. root@NAS:~# nslookup [url]www.ibm.com[/url]
      2. Server: 208.67.222.222
      3. Address: 208.67.222.222#53
      4. Non-authoritative answer:
      5. [url]www.ibm.com[/url] canonical name = [url]www.ibm.com.cs186.net[/url].
      6. [url]www.ibm.com.cs186.net[/url] canonical name = [url]www.ibm.com.edgekey.net[/url].
      7. [url]www.ibm.com.edgekey.net[/url] canonical name = [url]www.ibm.com.edgekey.net.globalredir.akadns.net[/url].
      8. [url]www.ibm.com.edgekey.net.globalredir.akadns.net[/url] canonical name = e2874.x.akamaiedge.net.
      9. Name: e2874.x.akamaiedge.net
      10. Address: 2.17.43.195
      Display All

      ASRock H97 Pro4 | 8Gb 1600 | i3 4130T | 3x WD Red 4TB with SnapRAID | Backup to Crashplan & External HDD

      The post was edited 1 time, last by MrMister2015 ().

    • Why are you doing this manually?
      It can be done easily from the Sytem/Network/Interfaces
      Then click on the interface you want and click edit.
      In the pop up scroll down to DNS servers and Search Domains.
      The DNS server should be ip of your router.
      The Search domains will be all the external DNS server ips you want to use. (we recommend normally google's 8.8.8.8)

      The entry in the interface file for the search domains will show as:
      dns-search 8.8.8.8

      Make your edits via the web gui for this and then test. Then if there is issue we try to sort it out or file bug report.
    • With "manually configured ... in the web GUI" I meant I changed it by hand from Sytem/Network/Interfaces. So no DHCP.

      I am not sure I understand your suggestions about DNS setting en Search Domains. From Sytem/Network/Interfaces, I changed:
      - IPv4 to Static
      - Address to 192.168.1.7 (local address outside DHCP range) with netmask 255.255.255.0
      - Gateway 192.168.1.1 (IP of router)
      - DNS servers to my preferred external DNS servers.
      - No additional search domains

      OMV creates a correct /etc/network/interfaces, see above.

      Your suggestion about using my router IP as DNS server is counter-intuitive. Router IP is normally the gateway.

      But, I will test and report back...

      Ralph
      ASRock H97 Pro4 | 8Gb 1600 | i3 4130T | 3x WD Red 4TB with SnapRAID | Backup to Crashplan & External HDD
    • I've changed as per your suggestions. No change.

      Source Code

      1. root@NAS:~# cat /etc/network/interfaces
      2. # The loopback network interface
      3. auto lo
      4. iface lo inet loopback
      5. iface lo inet6 loopback
      6. # eth0 network interface
      7. auto eth0
      8. allow-hotplug eth0
      9. iface eth0 inet static
      10. address 192.168.1.7
      11. gateway 192.168.1.1
      12. netmask 255.255.255.0
      13. dns-nameservers 192.168.1.1
      14. dns-search 37.235.1.174 84.200.69.80 91.239.100.100
      15. iface eth0 inet6 manual
      16. pre-down ip -6 addr flush dev $IFACE
      Display All


      Source Code

      1. root@NAS:~# nslookup www.ibm.com
      2. Server: 208.67.222.222
      3. Address: 208.67.222.222#53
      4. Non-authoritative answer:
      5. www.ibm.com canonical name = www.ibm.com.cs186.net.
      6. www.ibm.com.cs186.net canonical name = www.ibm.com.edgekey.net.
      7. www.ibm.com.edgekey.net canonical name = www.ibm.com.edgekey.net.globalredir.akadns.net.
      8. www.ibm.com.edgekey.net.globalredir.akadns.net canonical name = e2874.x.akamaiedge.net.
      9. Name: e2874.x.akamaiedge.net
      10. Address: 2.17.43.195
      Display All
      ASRock H97 Pro4 | 8Gb 1600 | i3 4130T | 3x WD Red 4TB with SnapRAID | Backup to Crashplan & External HDD
    • I've found the solution. Problem is that there is no /etc/resolv.conf. This is accomplished by executing

      Source Code

      1. dpkg-reconfigure --frontend=noninteractive resolvconf


      as indicated in [RESOLVE] DNS out

      I think this configuration should be part of the OVM installation script. My initial configuration was fine.

      Ralph
      ASRock H97 Pro4 | 8Gb 1600 | i3 4130T | 3x WD Red 4TB with SnapRAID | Backup to Crashplan & External HDD