Enable HTTP/2 on Nginx

    • OMV 2.x
    • @monsen,
      Can let us know the result, if you use it?

      Add the http2 keywords to your virtualhost configuration.

      Source Code

      1. server {
      2. listen 443 ssl http2;
      3. server_name your.fqdn.tld;
      4. access_log access.log main;
      5. error_log error.log error;
      6. # Start the SSL configurations
      7. ssl on;
      8. ssl_certificate /etc/nginx/conf.d/certificate.crt;
      9. ssl_certificate_key /etc/nginx/conf.d/certificate.key;
      10. # Add any other TLS optimisations like strong ciphers etc ...
      11. # ...
      12. }
      Display All

      Enabling really is this simple, just change your current ssl-line from this:

      Source Code

      1. server {
      2. listen 443 ssl;
      3. ...
      4. }to this:
      5. server {
      6. listen 443 ssl http2;
      7. ...
      8. }
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10
    • @tinh_x7
      If i am really doing this i will let you know.
      Not sure if i should take the step right now. Every configuration outside of what is intended by OMV seems to be a pain in the ****
      (I actually like the idea of having a frontend to administer my NAS but i am unsure about the flexiblity of it until here.)

      I worry about the long-term issues resulting out of these manual changes. When the next updates come everything might go to pieces. Also i am still in the process of doing the base setup for me, so doing a lot in parallel.....

      besides, and about owncloud:
      What is really anyoing me about owncloud is the performance. It got a lot better with some tweaks but still is not good.
      So either i will try or might get rid of it.
    • After some more screwing here and there here is my opinion: the owncloud idea ist good, the implementation is crap. I got enough of it! Hopefully Future Versions are ging to be better. I will then try again.

      I am happy with OMV though. I got a Little angry trying to get owncloud to run but figured it is not OMV causing the main issues.
      i will try to replace owncloud with other Services.
      therefore i am not trying to get http2 to run for now
    • We need a newer version of nginx. I have known this for some time. I wish Volker would upgrade the version even before we get to OMV 3.


      But Debian repos are to blame.

      Source Code

      1. dpkg -l | grep nginx
      2. ii nginx 1.2.1-2.2+wheezy3 all small, powerful, scalable web/proxy server
      3. ii nginx-common 1.2.1-2.2+wheezy3 all small, powerful, scalable web/proxy server - common files
      4. ii nginx-full 1.2.1-2.2+wheezy3 amd64 nginx web/proxy server (standard version)
      5. root@omv:~# apt-cache policy nginx
      6. nginx:
      7. Installed: 1.2.1-2.2+wheezy3
      8. Candidate: 1.2.1-2.2+wheezy3
      9. Version table:
      10. 1.6.2-5~bpo70+1 0
      11. 100 http://ftp.debian.org/debian/ wheezy-backports/main amd64 Packages
      12. *** 1.2.1-2.2+wheezy3 0
      13. 500 http://ftp.us.debian.org/debian/ wheezy/main amd64 Packages
      14. 500 http://security.debian.org/ wheezy/updates/main amd64 Packages
      15. 100 /var/lib/dpkg/status
      Display All
    • tkeil69575 wrote:

      Pitty, omv3 still running with nginx 1.6.2 two years later
      Check your facts... OMV doesn't determine which version is used. OMV 3.x is Debian 8. So, it uses whatever Debian 8 has available. Looking here, 1.10 is in jessie-backports. And you have plenty of other options like using the docker plugin. There is no reason you have to use OMV's nginx. You could also use OMV 4.x
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!