How to setup bonding

    • OMV 2.x
    • I assume you have two ethernet NICS.

      1. Go to your OMV web gui.
      2. Delete your current NIC, but DO NOT hit Apply yet.
      3. Click Create 'Bond'
      4. Select your NICS, your primary slave, and mode.
      5. Click 'OK', then click 'Apply'.
      6. You should see your bond0.
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10
    • Tried that, but when I should choose a nic for primary it is empty. I choose Balance-rr for mode.

      And after I save and apply, I try to ping the static adr but only got a few answer, and can't login either via webgui.

      Another problem is that it looks like the dns is not working on the omv. I can ping, but not if I use Have tried to put in "search domains" but didn't help
    • One thing at a time.
      If the drop-down list for primary slave is empty, then it could be in used, or not detected in the system.
      Make sure you delete the interfaces that you need that's on web gui before create a bond.

      If that doesn't work, then just create one interface, and leave it enabled.
      Reboot the system, and try again.
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 1 time, last by tinh_x7 ().

    • I now did the following; made a bond0 With only eth1, but when I choose Balance-rr I can't choose a nic, only when I choose some of the other. Choosed the second last in the list, saved and apply.

      The I try to ping the New ip to the bond, it Works, so logged into webgui With this New ip. Deleted eth0 saved without apply, edited bond0 and put also eth0 into. Saved and apply. And then it comes an error on the console telling that one of the nic is active, and on the webgui it says error.

      The I can't log in before I run the ovm-firstaid and set a New ip to eth0
    • Don't edit bond0, but remove it.
      If bond0 doesn't work after you created, then SSH into the server, and remove the bond0 interface in /etc/network/interface.
      Save, & reboot the server, then try again.

      Here is mine:

      Source Code

      1. ​ cat /proc/net//bonding/bond0
      2. Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)
      3. Bonding Mode: transmit load balancing
      4. Primary Slave: None
      5. Currently Active Slave: eth4
      6. MII Status: up
      7. MII Polling Interval (ms): 100
      8. Up Delay (ms): 200
      9. Down Delay (ms): 200
      10. Slave Interface: eth0
      11. MII Status: up
      12. Speed: 1000 Mbps
      13. Duplex: full
      14. Link Failure Count: 0
      15. Permanent HW addr: 08:62:66:c7:3c:ff
      16. Slave queue ID: 0
      17. Slave Interface: eth4
      18. MII Status: up
      19. Speed: 1000 Mbps
      20. Duplex: full
      21. Link Failure Count: 0
      22. Permanent HW addr: 00:15:17:2e:40:f0
      23. Slave queue ID: 0
      Display All
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10