sickbeard user locale not set

    • OMV 2.x
    • sickbeard user locale not set

      Hi,

      Since a recent update to sickbeard I have been having problems with the post processor crashing, the problem seems to be caused by the locale of the system user account not being set to force to UTF8, this results in the error:

      UnicodeEncodeError: 'ascii' codec can't encode character u'\u2019' in position 99: ordinal not in range(128)

      being produced by sickbeard when trying to post process and I believe it has started when sickbeard was changed away from forcing utf-8 and started using the user account locale.

      I can avoid thew error by starting sickbeard from command line under the root account with the locale set correctly but I have not yet found a way to get the account called sickbeard to correctly start sickbeard with the correct locale using the init.d script. I suspect the script with need to export the LANG to function correctly.

      I have tried to set the locale for the sickbeard account by creating .profile and .rcbash files with the following:

      export LC_ALL=en_NZ.UTF-8
      export LANG=en_NZ.UTF-8
      export LANGUAGE=en_NZ.UTF-8

      But this has not worked. I think the change that's required is in the init.d/sickbeard file but this is over my head.

      Does any body have any suggestions on how to get the sickbeard init.d to correct set the encoding to UTF-8?

      Thanks and regards,
      John