Updates

    • OMV 2.x
    • Update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • I have not had any updates forever and just tried this command:
      Any thoughts.
      P.S. I have no idea about this stuff.

      root@NAS-DG:~# apt-get update
      Err security.debian.org wheezy/updates Release.gpg
      Temporary failure resolving 'security.debian.org'
      Ign file: Release.gpg
      Err packages.openmediavault.org kralizec Release.gpg
      Temporary failure resolving 'packages.openmediavault.org'
      Err packages.openmediavault.org kralizec-proposed Release.gpg
      Temporary failure resolving 'packages.openmediavault.org'
      Ign file: Release
      Err ftp.us.debian.org wheezy Release.gpg
      Temporary failure resolving 'ftp.us.debian.org'
      Err ftp.us.debian.org wheezy-updates Release.gpg
      Temporary failure resolving 'ftp.us.debian.org'
      Ign file: Translation-en_US
      Ign file: Translation-en
      Reading package lists... Done
      W: Failed to fetch ftp.us.debian.org/debian/dists/wheezy/Release.gpg Temporary failure resolving 'ftp.us.debian.org'

      W: Failed to fetch security.debian.org/dists/wheezy/updates/Release.gpg Temporary failure resolving 'security.debian.org'

      W: Failed to fetch ftp.us.debian.org/debian/dists/wheezy-updates/Release.gpg Temporary failure resolving 'ftp.us.debian.org'

      W: Failed to fetch packages.openmediavault.org/pu…ists/kralizec/Release.gpg Temporary failure resolving 'packages.openmediavault.org'

      W: Failed to fetch packages.openmediavault.org/pu…izec-proposed/Release.gpg Temporary failure resolving 'packages.openmediavault.org'

      W: Some index files failed to download. They have been ignored, or old ones used instead.
      root@NAS-DG:~#
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • Found some thoughts about DNS servers and was told to check the "resolv.conf"
      When I do i get:
      root@NAS-DG:~# /etc/resolv.conf
      -bash: /etc/resolv.conf: Permission denied

      I cant figure this one I will try in the AM
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • root@NAS-DG:~# ifconfig -a
      eth0 Link encap:Ethernet HWaddr 00:26:18:9e:9a:18
      inet addr:192.168.1.6 Bcast:192.168.1.255 Mask:255.255.255.0
      UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
      RX packets:23554 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2733 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:10760172 (10.2 MiB) TX bytes:685604 (669.5 KiB)
      Interrupt:18

      eth1 Link encap:Ethernet HWaddr 00:26:18:9e:9a:17
      BROADCAST MULTICAST MTU:1500 Metric:1
      RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:1000
      RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
      Interrupt:17

      lo Link encap:Local Loopback
      inet addr:127.0.0.1 Mask:255.0.0.0
      inet6 addr: ::1/128 Scope:Host
      UP LOOPBACK RUNNING MTU:16436 Metric:1
      RX packets:2106 errors:0 dropped:0 overruns:0 frame:0
      TX packets:2106 errors:0 dropped:0 overruns:0 carrier:0
      collisions:0 txqueuelen:0
      RX bytes:171136 (167.1 KiB) TX bytes:171136 (167.1 KiB)
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • gderf wrote:

      /etc/resolv.conf is not an executable, so entering that on the commandline gives you nothing.

      Try:

      cat /etc/resolv.conf


      root@NAS-DG:~# cat /etc/resolv.conf
      # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
      # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
      nameserver 127.0.1.1
      search home
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • Hi Rye, how have you been? Long time since the NAS I thought has been running great.
      Yes they are in under the web interface.
      Originally it stated under : Network>DNS Server> Primary 127.0.0.1, Secondary was empty
      I changed them to my ISP providers DNS servers 71.***.*.** Primary and Secondary
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • drewgost wrote:

      could it be there are no updates for 1.11?

      Read your other thread :)
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • gderf wrote:

      /etc/resolv.conf is not an executable, so entering that on the commandline gives you nothing.

      Try:

      cat /etc/resolv.conf



      root@NAS-DG:~# cat /etc/resolv.conf
      # Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
      # DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
      nameserver 127.0.1.1
      search home
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • Ok so I tried to run vi and or vim: "command not found" ftp.us.debian.org/debian/pool/main/v/vim/
      I attempted to install vim: root@NAS-DG:~# sudo apt-get install vim
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      The following packages were automatically installed and are no longer required:
      libdb4.7 libssl0.9.8
      Use 'apt-get autoremove' to remove them.
      The following extra packages will be installed:
      libgpm2 vim-common vim-runtime
      Suggested packages:
      gpm ctags vim-doc vim-scripts
      The following NEW packages will be installed:
      libgpm2 vim vim-common vim-runtime
      0 upgraded, 4 newly installed, 0 to remove and 0 not upgraded.
      Need to get 5,583 kB of archives.
      After this operation, 25.1 MB of additional disk space will be used.
      Do you want to continue [Y/n]? y
      Err ftp.us.debian.org/debian/ wheezy/main libgpm2 i386 1.20.4-6
      Temporary failure resolving 'ftp.us.debian.org'
      Err ftp.us.debian.org/debian/ wheezy/main vim-common i386 2:7.3.547-7
      Temporary failure resolving 'ftp.us.debian.org'
      Err ftp.us.debian.org/debian/ wheezy/main vim-runtime all 2:7.3.547-7
      Temporary failure resolving 'ftp.us.debian.org'
      Err ftp.us.debian.org/debian/ wheezy/main vim i386 2:7.3.547-7
      Temporary failure resolving 'ftp.us.debian.org'
      Failed to fetch ftp.us.debian.org/debian/pool/…libgpm2_1.20.4-6_i386.deb Temporary failure resolving 'ftp.us.debian.org'
      Failed to fetch ftp.us.debian.org/debian/pool/…common_7.3.547-7_i386.deb Temporary failure resolving 'ftp.us.debian.org'
      Failed to fetch ftp.us.debian.org/debian/pool/…runtime_7.3.547-7_all.deb Temporary failure resolving 'ftp.us.debian.org'
      Failed to fetch ftp.us.debian.org/debian/pool/…im/vim_7.3.547-7_i386.deb Temporary failure resolving 'ftp.us.debian.org'
      E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

      So I followed the path to where they are: ftp.us.debian.org/debian/pool/main/v/vim/


      I downloaded to my computer the 4 files OMV tried to fetch and I attempted to upload them through Upload in Update Manager.
      When I tried to run vim:
      root@NAS-DG:~# vim testfile
      -bash: vim: command not found

      So I would really like to straighten out my NAS should I reinstall OMV if so can you point me to a solid procedure to do this so I don't loose my very important DATA? ?(

      Thanks for your help,

      DrewG
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive
    • Just use nano to edit files or to test, echo "nameserver 8.8.8.8" > /etc/resolv.conf and then apt-get update
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi everyone,

      I currently have the same problem as drewgost.
      First, if useful: What I did this morning:
      - Set up OpenVPN partially successful (Could connect, but had no access to my mapped drives - but that's another topic!)
      - then I realized that there were updates available (dpkg dpkg-dev libdpkg-perl libnspr4 openmediavault-omvextrasorg) - so i performed the updates via the webgui.
      Everything fine so far, but in the evening I recognized that jDownloader could not be found on my.jdownloader.org. I tried everything including restarting the system, resetting the settings and my last plan was to reinstall jdownloader, so i disabled the plugin and removed it via the extensions page in omv. After that I could no longer find plugin even though the repository is enabled. Then I tried to check for updates and noticed that it took incredibly long - I waited about 10 minutes until I refreshed the page and tried again to check for updates. The result:

      Source Code

      1. Failed to execute command 'export LANG=C; apt-get update 2>&1': E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/

      I removed the lock rm /var/lib/apt/lists/lock and tried to update via console with the result (took about 20-30 minutes!) that the system can not resolve the hostname:
      Display Spoiler

      Source Code

      1. [...]
      2. Fehl http://security.debian.org wheezy/updates Release.gpg
      3. Beim Auflösen von »security.debian.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      4. Fehl http://dh2k.omv-extras.org virtualbox-wheezy-mirror Release.gpg
      5. Beim Auflösen von »dh2k.omv-extras.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      6. Fehl http://ftp2.de.debian.org wheezy Release.gpg
      7. Beim Auflösen von »ftp2.de.debian.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      8. Fehl http://packages.omv-extras.org stoneburner-backports Release.gpg
      9. Beim Auflösen von »packages.omv-extras.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      10. Fehl http://packages.openmediavault.org stoneburner Release.gpg
      11. Beim Auflösen von »packages.openmediavault.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      12. [...]
      Display All


      I did not change the network settings for month.
      DNS server is the same as the gateway, ie my router. First i though it is a problem of my ISP and changed the DNS Server to 8.8.8.8, but that did not help. Trivial procedures such as rebooting all systems also did not lead to the desired goal :(

      I hope you guys have an idea what's going on here.

      Thanks for your help!
      dingo

      P.S.: Sorry for the long post. :P
      OMV Stone burner | Kernel 3.16 | 64bit | omvextras
      AMD Athlon 5350 | ASRock AM1H-ITX | 4GB DDR3 | 64 GB SSD OS
    • Hi everyone,

      I currently have the same problem as drewgost.
      First, if useful: What I did this morning:
      - Set up OpenVPN partially successful (Could connect, but had no access to my mapped drives - but that's another topic!)
      - then I realized that there were updates available (dpkg dpkg-dev libdpkg-perl libnspr4 openmediavault-omvextrasorg) - so i performed the updates via the webgui.
      Everything fine so far, but in the evening I recognized that jDownloader could not be found on my.jdownloader.org. I tried everything including restarting the system, resetting the settings and my last plan was to reinstall jdownloader, so i disabled the plugin and removed it via the extensions page in omv. After that I could no longer find plugin even though the repository is enabled. Then I tried to check for updates and noticed that it took incredibly long - I waited about 10 minutes until I refreshed the page and tried again to check for updates. The result:

      Source Code

      1. Failed to execute command 'export LANG=C; apt-get update 2>&1': E: Could not get lock /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) E: Unable to lock directory /var/lib/apt/lists/

      I removed the lock rm /var/lib/apt/lists/lock and tried to update via console with the result (took about 20-30 minutes!) that the system can not resolve the hostname (see apt-get_update_20151130.txt):
      Display Spoiler

      Source Code

      1. [...]
      2. Fehl http://security.debian.org wheezy/updates Release.gpg
      3. Beim Auflösen von »security.debian.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      4. Fehl http://dh2k.omv-extras.org virtualbox-wheezy-mirror Release.gpg
      5. Beim Auflösen von »dh2k.omv-extras.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      6. Fehl http://ftp2.de.debian.org wheezy Release.gpg
      7. Beim Auflösen von »ftp2.de.debian.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      8. Fehl http://packages.omv-extras.org stoneburner-backports Release.gpg
      9. Beim Auflösen von »packages.omv-extras.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      10. Fehl http://packages.openmediavault.org stoneburner Release.gpg
      11. Beim Auflösen von »packages.openmediavault.org:http« ist etwas Schlimmes passiert (-5 - Zu diesem Hostnamen gehört keine Adresse).
      12. [...]
      Display All


      I did not change the network settings for month.
      DNS server is the same as the gateway, ie my router. First i though it is a problem of my ISP and changed the DNS Server to 8.8.8.8, but that did not help. Trivial procedures such as rebooting all systems also did not lead to the desired goal :(

      I hope you guys have an idea what's going on here.

      Thanks for your help!
      dingo

      P.S.: Sorry for the long post. :P
    • ryecoaaron wrote:

      Just use nano to edit files or to test, echo "nameserver 8.8.8.8" > /etc/resolv.conf and then apt-get update

      root@NAS-DG:~# echo "nameserver 8.8.8.8"
      nameserver 8.8.8.8
      root@NAS-DG:~# /etc/resolv.conf
      -bash: /etc/resolv.conf: Permission denied
      root@NAS-DG:~# apt-get update
      Err security.debian.org wheezy/updates Release.gpg
      Temporary failure resolving 'security.debian.org'
      Ign file: Release.gpg
      Err packages.openmediavault.org kralizec Release.gpg
      Temporary failure resolving 'packages.openmediavault.org'
      Err packages.openmediavault.org kralizec-proposed Release.gpg
      Temporary failure resolving 'packages.openmediavault.org'
      Ign file: Release
      Err ftp.us.debian.org wheezy Release.gpg
      Temporary failure resolving 'ftp.us.debian.org'
      Err ftp.us.debian.org wheezy-updates Release.gpg
      Temporary failure resolving 'ftp.us.debian.org'
      Ign file: Translation-en_US
      Ign file: Translation-en
      Reading package lists... Done
      W: Failed to fetch ftp.us.debian.org/debian/dists/wheezy/Release.gpg Tem porary failure resolving 'ftp.us.debian.org'

      W: Failed to fetch security.debian.org/dists/wheezy/updates/Release.gpg Temporary failure resolving 'security.debian.org'

      W: Failed to fetch ftp.us.debian.org/debian/dists/wheezy-updates/Release. gpg Temporary failure resolving 'ftp.us.debian.org'

      W: Failed to fetch packages.openmediavault.org/public/dists/kralizec/Rele ase.gpg Temporary failure resolving 'packages.openmediavault.org'

      W: Failed to fetch packages.openmediavault.org/public/dists/kralizec-prop osed/Release.gpg Temporary failure resolving 'packages.openmediavault.org'

      W: Some index files failed to download. They have been ignored, or old ones used instead.

      Still lost regarding fix? ?(
      3.0.97 (Erasmus)
      Intel(R) Core(TM) i7 CPU 920 @920 2.67GHz
      Linux 4.9.0-0.bpo.5-amd64
      1 M4-CT128M4SSD2 > OMV
      3 x 2TB WD Red (Raid 5)
      1 4TB WD External Drive