Headless clonezilla backup, ssh login refused

    • OMV 2.x
    • Resolved
    • Headless clonezilla backup, ssh login refused

      Hi,
      I'm runing a OMV 2.1.19 headless and installed clonezilla with the openmediavault-backup plugin.
      After rebooting to clonezilla the ssh login is refused.

      If i plug in a Monitor i can see the menu prompt for choosing a language and the Keyboard keymap. After Setting These Options the Login with ssh is working.
      So the question is how can i set these options by default to enable ssh login to clonezilla in a headless Setup?
    • Are you sure you have connected to the correct IP?
      For example, I run OMV at 192.168.1.230 static (configured in OMV webGUI), then, when I reboot on Clonezilla, it uses DHCP and my router assigns 192.168.1.84 and I have to connect via PuTTY using a different IP.

      To be able to check if you are SSHing to the correct IP, you can use "advanced IP scanner" for Windows. It's portable and it will scan all your network and you will be able to see at which IP is your OMV box listening.

      Hope it helps.
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • No it wasn't a wrong IP settings problem.

      I had to provide the default settings the grub boot options for clonezilla.

      Following options have to be provided in the "/etc/grub.d/42_clonezilla" file:

      Source Code

      1. locales="de_DE.UTF8"
      2. keyboard-layouts="de"
      3. ocs_live_keymap="/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.kmap.gz"


      My menu entry now:

      Source Code

      1. user@omvnas:~# cat /etc/grub.d/42_clonezilla
      2. #!/bin/sh
      3. exec tail -n +3 $0
      4. menuentry "Clonezilla Live" {
      5. set isofile="/boot/clonezilla-live-2.3.1-18-i686-pae.iso"
      6. loopback loop $isofile
      7. linux (loop)/live/vmlinuz boot=live live-config noswap nolocales edd=on nomodeset ocs_live_run="ocs-live-general" ocs_live_extra_param="" keyboard-layouts="de" ocs_live_keymap="/usr/share/keymaps/i386/qwertz/de-latin1-nodeadkeys.kmap.gz" ocs_live_batch="no" locales="de_DE.UTF8" ocs_daemonon="ssh" vga=788 nosplash toram=filesystem.squashfs findiso=$isofile
      8. initrd (loop)/live/initrd.img
      9. }


      Now its possible to dirctly connect via ssh after a reboot.

      See clonezilla.org/fine-print-live…_live-boot-parameters.doc for more information.