Newbee can't activate Calibre, error #4000

    • OMV 2.x
    • Resolved
    • Newbee can't activate Calibre, error #4000

      Hello.

      I have a problem installing Calibre. Whenever I try to apply the changes after installing I get the following error:

      Error #4000:
      exception 'OMVException' with message 'Failed to execute command 'export LANG=C; invoke-rc.d 'calibre' stop 2>&1': /etc/init.d/calibre: 1: /etc/calibre-server.conf: Syntax error: "(" unexpected
      invoke-rc.d: initscript calibre, action "stop" failed.' in /usr/share/php/openmediavault/initscript.inc:176
      Stack trace:
      #0 /usr/share/php/openmediavault/initscript.inc(148): OMVSysVInitScript->invoke('stop')
      #1 /usr/share/php/openmediavault/initscript.inc(53): OMVSysVInitScript->stop()
      #2 /usr/share/openmediavault/engined/module/calibre.inc(113): OMVSysVInitScript->exec()
      #3 /usr/share/openmediavault/engined/rpc/config.inc(164): OMVModuleCalibre->stopService()
      #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      #5 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #6 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      #7 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      #8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      #9 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #10 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      #11 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      #12 {main}

      I Tried to install Calibre several time, but with the same result.

      Does anyone have a clue?
      Any help is welcome.
    • Looks like a config error. Can you post a screen shot of your settings tab? The output of cat /etc/calibre.conf would helpful too.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!