Installation HP Microserver Gen8

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Installation HP Microserver Gen8

      Hi, dies ist mein erstes NAS und ich bin schon am verzweifeln.
      Ich habe 4 unterschiedliche USB sticks.
      2 x 2GB
      1 x 8 GB
      1 x 16 GB

      Ich habe es bisher 2 mal geschafft OMV erfolgreich zu installieren.
      beide Male habe ich zum herstellen des boot sticks unetbootin benutzt.
      beim letzten mal wo es funktioniert hat, wollte ich danach die system festplatte noch einmal partitionieren, damit ich den speicherplatz auch nutzen kann, danach ging dann aber nichts mehr.

      Ich bekomme in der Regel immer eine von zwei Fehlermeldungen.
      error: you need to load the kernel first.

      oder direkt in grub rescue.

      in den letzten drei installationsversuchen habe ich den boot stick mit rufus 2.3 erstellt, welcher direkt zum start das OMV logo zeigt, was ich vorher nicht hatte. aber die fehler danach sind dieselben.
      Ich habe bisher alle USB ports bis auf einen ausprobiert... es wirkt auf mich so als ginge es nur um Glück ob es läuft oder nicht.

      hat jemand ähnliche probleme?
      Kann mir jemand helfen?

      Danke
    • Mahlzeit,
      die beiden hinteren USB-3 Ports (blau) sind zum Booten ungeeignet.
      Ich habe damals zum Erstellen des USB-Sticks sourceforge.net/projects/win32diskimager verwendet.
      Wohin willst du eigentlich OMV installieren ? (Festplatte, SSD, USB-Stick) und wo ist der/die/das angeschlossen ?
      Ist der Onboard SATA Controller im RAID oder im AHCI Mode ?
      Und welche ISO Datei hast du zum Erstellen des USB Sticks benutzt ?

      Cheers,
      Thomas
    • Hi,
      OMW soll auf eine normale seagate 3TB NAS HDD.
      ich habe meines achtens den SATA controler auf AHCI eingestellt, sprich enable geclickt, aber er zeigt keinen unterschied zu vorher an (glaube ich).
      Die HDD ist ganz normal in dem ersten Einschub. Ich habe andere Festplatten auch entfernt, damit es da keine eventuellen Probleme gibt.
      Ich werde heute mal den Win32diskimager ausprobieren und die vorderer USB ports.
      Bei dem einen vorderer Port habe ich beim ausprobieren auch das erste Mal das OMV Logo direkt zu beginn gesehen.
      Danke schonmal für die Tipps, vielleicht war das ja der Knackpunkt.
    • Hi,
      mich hat es auch das halbe Wochenende gekostet und ganz zufrieden bin ich bisher auch nicht.
      Es gibt noch viele Nicklichkeiten.

      Meine Vorgehensweise:
      Im Bios SATA auf AHCI eingestellt.
      Zur Installation braucht man zwingend 4 GB-Sticks. Obwohl das Installationsfile nur 700 MB groß ist, haben 2 GB-Sticks bei mir nicht funktioniert.
      Installationsort waren erstmal testweise ein USB Stick mit 8GB, anschließend die Installation nochmals auf eine 120 GB SSD mit USB-Sata-Adapter wiederholt, jeweils angeschlossen am internen USB-Port. Also 4GB-Stick vorne ans Gehäuse, 8GB (oder nachher die SSD) intern auf den USB-Port. Alle vorderen Schächte leer.

      Da bei mir der vordere Stick als /sda und der hintere als /sdb erkannt wurden, ging alles gut, bis Grub geschrieben wurde, der landete dann auf der /sda wo er nicht hingehört.
      Meine Abhilfe: Installation bis zum Grub, dann mit "Esc" abrechen (Liste der Installationsschritte erscheint), vorderen Stick ziehen, in der Liste den Eintrag "Grub-Installation" neu starten und dieser landete dann auf dem internen Stick. Danach war die Installation abgeschlossen.
      Sollte der Installationsort direkt als /sda erkannt werden, kann alles so durchlaufen.
      Warscheinlich ist das alles auch kein Problem, wenn man von CD-Rom installiert, habe ich aber nicht probiert.

      Eine SSD ist natürlich besser als ein USB-Stick, da OMV den Stick ziemlich schnell zersägt (es gibt eine Erweiterung die MLC-Sticks schont). Eine richtige Abhilfe wären USB-Sticks mit SLC, die kosten etwa 30 € für 8GB.
      Eine Installaton auf der Datenplatte mit anschließender Partitionierung würd ich nicht machen. Das Schöne ist ja halt die Trennung von Installation und Daten. Und einen Tacken schneller ist die SSD auch.

      Viel Erfolg noch
      Erik
    • Habe gerade openmediavault_2.1_amd64.iso mit unetbootin auf einen FAT32-formatierten 8GB-Stick geschrieben, den Stick vorn an den G8 gesteckt und gebootet.
      Installationsziel war eine 500GB-2,5"HDD an Port5 (DVD-Anschluss).

      während der Installation kam

      "Unable to install GRUB in /dev/sda"

      Bei der Installation ist der Stick sda und die HDD sdb.

      Die Grub-Installation auf sdb funktionierte wie hier wiki.openmediavault.org/index.php?title=Installation beschrieben.

      Allerdings bootete die Kiste hinterher nicht, weil sdb1 beim Vorgehen nach der Anleitung nicht bootfähig markiert wurde.
      Also musste zur manuellen Grub-Installtion auf sdb auch noch sdb1 mit fdisk als bootfähig markiert werden.

      Jetzt bootet die Kiste wie gewünscht.
      Es ist aber noch keine weitere Platte im System.
    • Hey,
      danke der Empfehlung von Erik, habe ich mir einen USB Stick der SLC version gekauft mit 16GB, dazu einen 4GB USB stick für die installation.
      Der SLC stick ist nun im Gehäuse und wurde als sdb erkannt, der installationsstick als sda. der grub2 hat sich auf den sda geschrieben, sprich, ohne den konnte ich nicht starten, erster Versuch des startes schlug fehl, also dachte ich alles klar, Stick in anderen port und neu installieren (beide male vorderer port).

      Und auf einmal started alles direkt nach der ersten installation. SUPER ERIK, danke.
      Allgemein, danke vielmals für eure Tipps !!
    • ... für Eure hilfreichen Hinweise. :D

      Habe seit einigen Tagen hier einen Microserver Gen8 stehen - und bin an der Installation von OMV schier verzweifelt, diese leidige Geschichte mit sda/sdb.
      Wollte die Kiste schon zurückschicken und mir ein von-der-Stange NAS von Synology oder Qnap zulegen.

      Dank der hilfreichen Hinweise habe ich nicht von einem Stick gebootet, sondern
      - das Installationsimage auf CD gebrannt
      - in ein transportables CD-ROM eingelegt
      - dieses am äußeren USB Port im Frontpanel angeschlossen
      - einen 4Gb Stick eingesteckt
      und nach fünf Minuten war der Spuk erledigt. 8o



      Jetzt muss ich mich mal mit den Möglichkeiten auseinandersetzen, performant sieht die ganze Geschichte schon aus.
    • CD-Rom an USB ist natürlich der beste Weg, manche USB-Sticks zicken, wenn sie als Bootmedium missbraucht werden sollen.
      Ich freu mich aber, dass es Ihr beide jetzt weiterkommt, viel Erfolg noch.

      An meinem HP Microserver verzweifle ich auch.
      Da ich aber schon 2 Singlebay-Synologys besitze, möchte ich mir kein drittes hinstellen. Der Hardwareschub des MicroServers ist schon gewaltig. Wenn der endlich mal läuft, gehen die Synologys in den Backup-Keller

      Aktuell schwanke (teste) ich noch zwischen XPEnology und OMV.
      XPEnology ist natürlich super vom Funktionsumfang her, allerdings kann jedes Update den Datentod bedeuten.
      Da wird die Katze gegen den Strich gebürstet - und die mag das garnicht.

      Bei OMV gibt es zwar einen risesigen Funktionsnumfang, aber irgendwie ist das was für Leute, die ihr Geld tagsüber auf der Kommandozeile verdienen. Für Umsteiger oder Amateure für mich, wirkt das alles sehr bedienungsunfreundlich.

      Die sda/sdb-Problematik ist für eine Installationsroutine natürlich der Hammer. Hat mich auch den halben Abend gekostet.

      Häufige Abstürze und Freeze habe ich auf einen USB-Sata-Adapter für die SSD zurückgeführt. SLC-Stick ist bestellt.
      Dies war wohl auch die Ursache für ein Nichteinstellenkönnen der Uhrzeit. Mit einem normalen USB-Stick ging dieser Punkt sofort.

      Für ein Backup der Konfiguration wird in Clonezilla gebootet und die Systempartition geclont.
      Rücksetzten auf Werkseinstellung ist defacto eine Neuinstallation vom Scratch.
      Warum gibt es kein Download eines Konfigurationsfiles?

      Zur Datensicherung gibt es "rsync" und "rsnapshot". Soweit ich es verstanden und eingerichtet habe, geht "rsync" auch übers Netzwerk auf einen entfernten Server, bei "rsnapshot" kann ich keine Netzwerkadresse einstellen, nur Volume im MicroServer. Das machst aber keinen Sinn für mich. Außerdem ist die Versionierung mit day.0, day.1, usw. ziemlich kryptisch für Leute, die mit einem normalem Kalender (Tag, Monat, Jahr) sozialisiert wurden.

      Gefühlt gibt es in OMV ein halbes Dutzend Download-Plugins für irgendwelche Mediadienste, aber kein brauchbares Datenbackup-Tool.

      OwnCload als Plugin liegt in der Version 6.0.4 vor. Das sind 2 Major-Releases hinter dem aktuellen Stand. Außerdem wg. SQLite schnarchlangsam.
      Nach umfangreichem Lesen in diversen Foren habe ich keine brauchbare Info zum Update gefunden.

      Docker läuft, trotz Pfadangabe auf Datenvolume werden aber auch Dateien in die OMV-Installation geschrieben (/var/lib/docker glaube ich). Was ist wenn dieses Volume volläuft?

      mySQL ist installiert, ich kann aber kein Passwort setzen, Anmelden leer ist aber möglich (dies liegt wohl an meiner Unkenntnis).

      OwnCload in aktueller Version 8.2 als Docker-Container läuft, aber aktuell stecke ich fest, eine mySQL-Datenbank anzubinden.


      Das sind die wichtigsten Punkte für mich, um einigermaßen damit arbeiten zu können (Datenhaltung, Datensicherung, Datenverteilung, vielleicht später mal ein PlexServer), aber es wird einem nicht leicht gemacht.
      Ich verdiene mein Geld nicht auf der Kommandozeile, aber mit leidlich privater Linux-Erfahrung, 2 Satreceivern mit Enigma2, Kodi auf nem Fire-TV, usw., hatte ich gedacht, ausreichend Erfahrung für eine Basiskonfiguration von OMV zu haben.
      Ich dachte immer, DSM (Synology) wäre nur eine GUI auf den Linux-Tools. Weit gefehlt.

      Eigentlich schade, denn OMV hat in meinen Augen ein Superpotential, ist superperformant und man merkt, dass die Entwickler viel Herzblut reingesteckt haben. Aber so richtig "flutschen" tuts für mich noch nicht. Es hat zu viele Ecken und Kanten.

      Mir ist natürlich bewußt, dass viele der oben geschilderte Probleme auf OSI-Level 8 liegen, und ich bin auch für jeden Hinweis, der mich weiterbringt, dankbar.
      Gruss
      Erik

      The post was edited 1 time, last by erik ().