Transmission won't start. Permission problem?

    • OMV 2.x
    • Resolved
    • Transmission won't start. Permission problem?

      I've run transmission for years. A couple of days ago I added a torrent but it wouldn't download. I eventually restarted OMV but now transmission won't even start.

      I looked in my transmission logs and got a lot of errors like:

      Source Code

      1. Dec 7 07:35:05 openmediavault transmission-daemon[29004]: Couldn't read "/var/lib/transmission-daemon/info/torrents/epl+2015+day15+05+dec+arsenal+v+sunderland+720p+en+jaguar777.d4fb4ceefa680683.torrent": Permission denied (utils.c:218)

      When I try to start transmission I get this: Failed to execute command 'export LANG=C; invoke-rc.d 'transmission-daemon' start 2>&1': Starting bittorrent daemon: transmission-daemon[07:01:06.129] Couldn't read "/var/lib/transmission-daemon/info/settings.json": Permission denied (warning). invoke-rc.d: initscript transmission-daemon, action "start" failed.

      Error details are:

      Source Code

      1. Error #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'export LANG=C; invoke-rc.d 'transmission-daemon' start 2>&1': Starting bittorrent daemon: transmission-daemon[17:16:57.718] Couldn't read "/var/lib/transmission-daemon/info/settings.json": Permission denied
      3. (warning).
      4. invoke-rc.d: initscript transmission-daemon, action "start" failed.' in /usr/share/php/openmediavault/
      5. Stack trace:
      6. #0 /usr/share/php/openmediavault/ OMVSysVInitScript->invoke('start')
      7. #1 /usr/share/php/openmediavault/ OMVSysVInitScript->start()
      8. #2 /usr/share/openmediavault/engined/module/ OMVSysVInitScript->exec()
      9. #3 /usr/share/openmediavault/engined/rpc/ OMVModuleTransmissionBt->startService()
      10. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      11. #5 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      12. #6 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      13. #7 /usr/share/openmediavault/engined/rpc/ OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      14. #8 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      15. #9 /usr/share/php/openmediavault/ call_user_func_array(Array, Array)
      16. #10 /usr/share/php/openmediavault/ OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      17. #11 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      18. #12 {main}
      Display All

      Any ideas?
    • OMV is mounted on HDD.
      mount gives:
      root@openmediavault:~# mount
      sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
      proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
      udev on /dev type devtmpfs (rw,relatime,size=10240k,nr_inodes=368698,mode=755)
      devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
      tmpfs on /run type tmpfs (rw,nosuid,noexec,relatime,size=296300k,mode=755)
      /dev/disk/by-uuid/1bf8cdd4-4667-4a06-917f-286abd341c23 on / type ext4 (rw,relatime,errors=remount-ro,user_xattr,acl,barrier=1,data=ordered)
      tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
      tmpfs on /run/shm type tmpfs (rw,nosuid,nodev,noexec,relatime,size=1550440k)
      tmpfs on /tmp type tmpfs (rw,relatime)
      /dev/sdb1 on /media/8307d85e-116f-466b-bb84-366f9028fa08 type ext4 (rw,noexec,relatime,user_xattr,acl,barrier=1,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,,_netdev)
      /dev/sdc1 on /media/8b48f1c6-de36-454f-9427-90fb1953b794 type ext4 (rw,noexec,relatime,user_xattr,acl,barrier=1,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,,_netdev)
      /dev/sde1 on /media/97516248-60be-46bc-8528-5eb3d1708497 type ext4 (rw,noexec,relatime,user_xattr,acl,barrier=1,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,,_netdev)
      /dev/sdd1 on /media/f0cffec4-ed8a-41cd-89c4-7a7d066a27d6 type ext4 (rw,noexec,relatime,user_xattr,acl,barrier=1,data=ordered,jqfmt=vfsv0,usrjquota=aquota.user,,_netdev)
      /media/8307d85e-116f-466b-bb84-366f9028fa08;/media/8b48f1c6-de36-454f-9427-90fb1953b794;/media/f0cffec4-ed8a-41cd-89c4-7a7d066a27d6 on /media/0a08d3df-bdd9-4bdc-8de7-a6198639892a type fuse.mhddfs (rw,relatime,user_id=0,group_id=0,allow_other)
      fusectl on /sys/fs/fuse/connections type fusectl (rw,relatime)
      rpc_pipefs on /var/lib/nfs/rpc_pipefs type rpc_pipefs (rw,relatime)
      none on /var/spool/greyhole/mem type tmpfs (rw,relatime,size=4096k)
    • Ah, of course.
      Ok, here it is

      root@openmediavault:/etc/transmission-daemon# ls -la /etc/transmission-daemon
      total 36
      drwxrwsr-x 2 root debian-transmission 4096 Dec 10 07:18 .
      drwxrwxr-x 106 root root 12288 Dec 9 18:22 ..
      -rw-r--r-- 1 root root 303 Jan 6 2013 README.json
      -rw-r--r-- 1 root debian-transmission 12288 Dec 10 07:18 .README.json.swp
      --w------- 1 debian-transmission debian-transmission 1849 Dec 9 17:39 settings.json
    • Hello Subzero79 I hope you can help solving the problem I am having with 1 of 3 OMV nas servers. all same configurations, but on the last one I can't use transmission. Have tried everything as written below:
      shared folder has correct permissions (user Mastro, users)
      watch directory is /media/UUID/temp/torrent
      incomplete directory is /media/UUID/temp/dnl
      I have manually edited the /etc/debian-transmission/settings.json and permission of /etc/debian-transmission is 664 as you suggested
      when I copy a file into watch directory nothing happens
      if I upload the same file using transmission web gui (to the same watch directory) the download starts but I get the error access to watch directory denied. The torrent file is not renamed in .added as usual.
      I upgraded to OMV 2.0 with same results. Reinstalled transmission several time without any success.... running out of options..
    • mastro59 wrote:

      I have manually edited the /etc/debian-transmission/settings.json and permission of /etc/debian-transmission is 664 as you suggested

      Editing settings.json file manually is pointless, don't keep trying wont do anything.
      If you have a shared folder for /media/UUID/temp/ go to the section, and to reset permission tab. Reset the permissions to everyone with drop down menu.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10 broadcast channel
      openmediavault discord server
    • First of all tahnks for helping...
      I have done that already, but doing it again:
      torrent dir is showing the permissions or the folders after resetting the permission form OMV gui (clear all ACLs and R/W to everyone)
      as you can see there are 2 torrent files in the watch directory and are not renamed to .added, no download is started
      I tried as well changing owner of /media/uuid/temp and subfolder to mastro and permissions to 777
      chown -R mastro /media/uuid/temp
      chmod -R 777 /media/uuid/temp
      results in second picture
      no downloads are starting
      attached is the settings.json file as well (renamed to .txt for simplicity)
      must be something else I am missing... i have another NAS server running well, with exact same configuration ( same permissions, same user name, same folders structures... only the uuids are different) really wierd...
      • torrent dir.png

        25.05 kB, 900×395, viewed 612 times
      • manual permissions set.png

        37.88 kB, 900×575, viewed 618 times
    • one more point... if I upload a torrent file to transmission using the transmission web gui ( I can use the media/uuid/Media/DNL proposed destination link or change it to media/uuid/temp/torrent, same outcome: starts downloading but then stops for permission denied... but I do not see any torrent fine in any one of my directories... where is the torrent file actually written?

      The post was edited 1 time, last by mastro59 ().

    • Your /media and /media/{uuid} directory is missing executable permissions for others. Currently Transmission can never reach directories beneath it because of it.

      Also, the correct permissions for /etc/transmission-daemon/settings.json is 600. It used to contain the plaintext password for the webui in earlier versions of Transmission. And the permissions that was there on /etc/transmission-daemon was already correct.

      The post was edited 2 times, last by HK-47 ().

    • hi HK-47
      I just noticed the permission for /media/uuid is currently still 776, same for all subfolders
      going to change it to 777... but in my first OMV NAS (where transmission is working fine) the /media/uuid permission is 776, so why is this working for one NAs and not for another?
      permission of settings.json is 600
      I tried changing that to 777 but no luck
      see attached png file...
      I was not kidding when i said I run out of options...
      I believe there is something with one of the plugin files... When I open the transmission web GUI the connection failed error message keeps popping up. I may have a corrupted file in my system. so is there a way I can uninstall transmission completely, get rid of all the files to make a new transmission clean installation?

      • Untitled.png

        41.51 kB, 900×575, viewed 615 times

      The post was edited 2 times, last by mastro59 ().