shared folder on the system disk

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • ryecoaaron wrote:

      EruIluvatar wrote:

      Is there a way to create a shared folder for the @home subvolume?
      Nope.

      EruIluvatar wrote:

      Do I have to do the symlink trick proposed by @tekkb?
      No. If you don't enable home directories Access Rights Management -> User -> Settings, when you enable home directories in samba, it will use whatever the home directory in /etc/passwd is for the user. Just change the home directory there and you should be able to use that location for samba home directory only.
      Hmm but /etc/passwd seems to look ok:

      Source Code

      1. stefan:x:1000:100:*my name with spaces in it*:/home/stefan:/bin/bash


      When I enable the samba setting "Enable user home directories", I get the error:
      Which is why I'm asking the question in the first place. :)


      Can't share user home directories because they are not enabled.
      Error #0:exception 'OMV\ConstraintException' with message 'Can't share user home directories because they are not enabled.' in /usr/share/openmediavault/engined/rpc/smb.inc:85
      Stack trace:
      #0 [internal function]: OMVRpcServiceSmb->setSettings(Array, Array)
      #1 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      #2 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('setSettings', Array, Array)
      #3 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('SMB', 'setSettings', Array, Array, 1)
      #4 {main}
    • EruIluvatar wrote:

      When I enable the samba setting "Enable user home directories", I get the error:
      Which is why I'm asking the question in the first place.
      This must be a fairly recent change. I have all of my OMV 3.x boxes setup this way. So, enable home directories and enable homes in samba. Then change the home directory for your user in /etc/passwd.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      EruIluvatar wrote:

      When I enable the samba setting "Enable user home directories", I get the error:
      Which is why I'm asking the question in the first place.
      This must be a fairly recent change. I have all of my OMV 3.x boxes setup this way. So, enable home directories and enable homes in samba. Then change the home directory for your user in /etc/passwd.
      You mean I should move the user directory to its own share on a different disk?

      I wanted to enable home directories in Access Rights Management -> User -> Settings, but /home doesn't show up (because it's not a Shared Folder I guess).




      But I also can't create a Shared Folder /home on the system disk.
    • EruIluvatar wrote:

      You mean I should move the user directory to its own share on a different disk?
      Just temporarily. Changing /etc/passwd will move it back to /home/username

      EruIluvatar wrote:

      I wanted to enable home directories in Access Rights Management -> User -> Settings, but /home doesn't show up (because it's not a Shared Folder I guess).
      Right. You can't use the system disk. Samba home looks at /etc/passwd but the samba plugin requires home directories to be enabled.
      omv 4.0.16 arrakis | 64 bit | 4.14 backports kernel | omvextrasorg 4.1.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • It has been widely discussed if it makes sense at all to partition the OMV systemdisk, but I simply wanted to use the extra space as a "transfer" share to move stuff across or to park data for a moment (a "temp" drive). This worked fine for me:

      1. After OMV install boot the machine with gparted
      2. resize the root partition to 20 GB
      3. create an ext4 partition on the remaining drive space (200 GB in my case)
      4. Boot into OMV
      5. You will find the partition showing up in the web gui
      6. Mount the partition
      7. create a shared folder
      8. Set all permissions as usual
      9. start using the share
      OMV 2.0 on several machines with different configurations
    • well that is not exactly sharing things on "System" disk.
      for me, System disk is the disk(Partition) where the OS is installed.
      as in, not the physical disk but the volume where OS resides.
      but that is semantics :)
      omv 3.0.56 erasmus | 64 bit | 4.7 backport kernel
      SM-SC846(24 bay)| H8DME-2 |2x AMD Opteron Hex Core 2431 @ 2.4Ghz |49GB RAM
      PSU: Silencer 760 Watt ATX Power Supply
      IPMI |3xSAT2-MV8 PCI-X |4 NIC : 2x Realteck + 1 Intel Pro Dual port PCI-e card
      OS on 2×120 SSD in RAID-1 |
      DATA: 3x3T| 4x2T | 2x1T
    • i am also trying to create a share on my system disk (i don't actually want to share anything on that folder but use it for virtualbox images). however I am lost with the UUID part.

      I have create a /OMV-data folder
      then under media i created a dummy UUID 123e4567-e89b-12d3-a456-426655440000 (the post said i can use any UUID i want...)
      then created the symlink, but i cannot see the volume in the 'add shared folder' menu... any suggestions?
      HP N40L, 4 GB ECC RAM, 3x WD RED 3TB + OCZ Vertex3 128 GB SSD