Can't mount unRAID xfs drives in OMV

    • Can't mount unRAID xfs drives in OMV

      I am in the process of migrating my unraid setup to OMV. Have been an unRaid user for several months but OMV seems like a much cleaner approach. Love the UI and the fact that i have a full fledged linux install at my finger tips.

      My unraid drives are configured with xfs filesystem and have lots of data on them already. Three, 1TB drives in total for now. Unfortunately for the life of me i cant get them to mount in OMV. OMV should be able to recognize the xfs filesystem but instead every attempt to mount from the WebUI presents the error below.

      Does unRaid do anything special with the data drives that prevents them from mounting directly in OMV? Any guidance on how i can get around this issue?

      Attempting a Mount from the WebUI:


      Error #6000:
      exception 'OMVException' with message 'Failed to mount '1eeed9bc-ca15-4e2b-938f-1bb01ae107ab': mount: wrong fs type, bad option, bad superblock on /dev/sda1,
      missing codepage or helper program, or other error
      In some cases useful info is found in syslog - try
      dmesg | tail or so
      ' in /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc:921
      Stack trace:
      #0 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
      #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('mount', Array, Array)
      #3 /usr/sbin/omv-engined(500): OMVRpc::exec('FileSystemMgmt', 'mount', Array, Array, 1)
      #4 {main}

      OKHide details



      Attempting a Mount from the Command Line:

      root@Tower:/media# mount -a

      mount: wrong fs type, bad option, bad superblock on /dev/sda1,

      missing codepage or helper program, or other error

      In some cases useful info is found in syslog - try

      dmesg | tail or so

      mount: wrong fs type, bad option, bad superblock on /dev/sdd1,

      missing codepage or helper program, or other error

      In some cases useful info is found in syslog - try

      dmesg | tail or so
    • OMV (or any other linux os) can't read unraid arrays. It can read the xfs filesystem but that doesn't help in this case. You will need to convert to standard linux raid or something.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Sorry, it is but it is their proprietary protocol/software. Just about any other NAS filesystem would work on OMV except unraid.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!