Cant ping domain names(DNS problem?)

    • OMV 2.x
    • Cant ping domain names(DNS problem?)

      When I try to ping google.com I get this: ping: unknown host google.com.
      When I ping 8.8.8.8 then there is no problem.

      I have tried manually setting the interface dns to 8.8.8.8 but that doesn't change anything.
      OMW is new to me so it can be something stupid I have overlooked.

      hope someone can help :)

      Also a side question: The firewall has a default allow all rule if I have not made any rules myself right?
    • ping 8.8.8.8 doesn't use dns. Did you set dns nameserver in the web interface?

      Everything is allowed when there are no firewall rules.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • In a properly functioning network, the router should do dns. No idea what kind of setup you have. What is the output of:

      cat /etc/network/interfaces
      cat /etc/resolv.conf
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • With DNS from DHCP

      cat /etc/network/interfaces
      The loopback network interface
      auto lo
      iface lo inet loopback

      # eth0 network interface
      auto eth0
      allow-hotplug eth0
      iface eth0 inet dhcp
      iface eth0 inet6 manual
      pre-down ip -6 addr flush dev $IFACE

      cat /etc/resolv.conf
      search local
      nameserver 192.168.0.1

      With Manual DNS

      cat /etc/network/interfaces
      # The loopback network interface
      auto lo
      iface lo inet loopback

      # eth0 network interface
      auto eth0
      allow-hotplug eth0
      iface eth0 inet dhcp
      dns-nameservers 8.8.8.8
      iface eth0 inet6 manual
      pre-down ip -6 addr flush dev $IFACE

      cat /etc/resolv.conf
      search local
      nameserver 192.168.0.1
    • What version of OMV? None of your output looks like it is being written correctly.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • If you have omv-extras installed, post the output of: omv-showkey network
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • omv-showkey network
      Display Spoiler

      <network>
      <hostname>1337NAS</hostname>
      <domainname>local</domainname>
      <interfaces>
      <!--
      <interface>
      <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx xx</uuid>
      <type>ethernet|bond|vlan|wireless|...</t ype>
      <devicename>xxx</devicename>
      <method>dhcp|static|manual</method>
      <address>xxx.xxx.xxx.xxx</address>
      <netmask>xxx.xxx.xxx.xxx</netmask>
      <gateway>xxx.xxx.xxx.xxx</gateway>
      <method6>auto|dhcp|static|manual</method 6>
      <address6>xxxx:xxxx:...:xxxx</address6>
      <netmask6>0-128</netmask6>
      <gateway6>xxxx:xxxx:...:xxxx</gateway6>
      <dnsnameservers></dnsnameservers>
      <dnssearch></dnssearch>
      <mtu></mtu>
      <wol>0|1</wol>
      <options></options>
      <comment>xxx</comment>
      # Optional arguments by type:
      # - ethernet
      # - bond
      <slaves>((eth|wlan)\d+,)*(eth|wlan)\d+</ slaves>
      <bondprimary>(eth|wlan)\d+</bondprimary>
      <bondmode>0|1|2|3|4|5|6</bondmode>
      <bondmiimon>0</bondmiimon>
      <bonddowndelay>0</bonddowndelay>
      <bondupdelay>0</bondupdelay>
      # - vlan
      <vlanid>1-4095</vlanid>
      <vlanrawdevice>(eth|wlan|bond)\d+</vlanr awdevice>
      # - wireless
      <wpassid>xxx</wpassid>
      <wpapsk>xxx</wpapsk>
      </interface>
      -->
      <interface>
      <uuid>ce93afd4-ba22-11e5-ade9-305a3a8116ef</uuid>
      <devicename>eth0</devicename>
      <method>dhcp</method>
      <address></address>
      <netmask></netmask>
      <gateway></gateway>
      <method6>manual</method6>
      <address6></address6>
      <netmask6>64</netmask6>
      <gateway6></gateway6>
      <dnsnameservers>8.8.8.8</dnsnameservers>
      <dnssearch></dnssearch>
      <mtu></mtu>
      <wol>0</wol>
      <options></options>
      <comment></comment>
      <type>ethernet</type>
      </interface>
      </interfaces>
      <iptables>
      <!--
      <rule>
      <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxx xx</uuid>
      <family>inet|inet6</family>
      <rulenum>1...x</rulenum>
      <chain>INPUT|OUTPUT</chain>
      <action>ACCEPT|REJECT|DROP|LOG|</action>
      <source>[!]?xxx.xxx.xxx.xxx|[!]?xxx.xxx. xxx.xxx/xx|xxx.xxx.xxx.xxx-yyy.yyy.yyy.yyy</source>
      <sport>xxx|xxx-yyy</sport>
      <destination>[!]?xxx.xxx.xxx.xxx|[!]?xxx .xxx.xxx.xxx/xx|xxx.xxx.xxx.xxx-yyy.yyy.yyy.yyy</destination>
      <dport>xxx|xxx-yyy</dport>
      <protocol>[!]?(tcp|udp|icmp|icmpv6)|all< /protocol>
      <extraoptions>xxx</extraoptions>
      <comment>xxx</comment>
      </rule>
      -->
      </iptables>
      </network>
    • You shouldn't need to set DNS when using DHCP. If it doesn't work when using DHCP without setting DNS, you meed to check your router. I would use static ip though.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • static ip was also the plan I just hit this problem before I got to set up static ip.
      I dont think it is my router when my other 2 computer have no problem with DHCP and my friend with another router and internet have the same problem.
      We did the exact same thing when we installed OMW and Plex. So I think we did the same thing wrong to.