Update pkg problem (solved)

    • OMV 2.x
    • Resolved
    • Update
    • Update pkg problem (solved)

      Hi dea rall,
      today I tried to update pkgs source and plugin on my openmeviavault (version 2.0.15) installed on raspberry pi2, using Web GUI and terminal session too, but i can not a upgrade ;(
      by terminal session when I do "app-get update" system respond me whit more error (Paste of blog below),
      this is a a problem on my machine or a problem on remote server? ?( ?(


      file with past of errors
      ----------------------



      ----------------------


      Thanks in advantage to all for time spent to read my post!

      PS: sorry for my lower level of english ;)
      Files
    • You need to set your dns server in network settings. Did you just change to a static IP?
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • In reality my ip addresses is automatic on ethernet board, for have always same internal ip address, i set up my router, the router assign the same ip address to my device (in this case rasperei pi2) based on mac address...
      suggest in any case that is better set up static ip and static des over network card?
    • I'm not sure how you setup your router but your system is not resolving DNS. It needs to know the address of the dns server however you set it up. Try a static IP and don't forget the dns server.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ok, this is the con with static ip and des server (i choose open dns for this try)



      # The loopback network interface

      auto lo

      iface lo inet loopback

      # eth0 network interface

      auto eth0

      allow-hotplug eth0

      iface eth0 inet static

      address 192.168.0.3

      gateway 192.168.0.1

      netmask 255.255.255.0

      dns-nameservers 208.67.222.222 208.67.220.220

      iface eth0 inet6 manual

      pre-down ip -6 addr flush dev $IFACE

      -----


      for you are all correct?

      i have set the file /etc/network/interfaces and not etc/resolv.conf because the second one is automaticcally edit from pkg resolveconf installed on mov dietro
    • damiakaorso wrote:

      i dont understand only one thing, why set up the same dns on my router is not enought for works??
      Other users, other networks. It does not have to be the same DNS in your router and your OMV. Therefore you have to type it by yourself.
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive