openmediavault-letsencrypt

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • i have a problem to install openmediavault-letsencrypt for omv 3.0.35.
      The Pacage need the certbot but the cetbot have many
      dependencies. I can't solve it.Someone can help me?
      omv 3.0.76 | 64 bit | omvextrasorg 3.4.25 | kernel 4.9
      used plugins: nginx | mysql | docker-gui | flashmemory |rsnapshot | antivirus | apt tool | letsEncrypt | fail2ban for omv-webgui/Nextcloud/emby
      used other: netxtcloud | logitechmediaserver | emby
    • luxflow wrote:

      What error did you encounter?
      I upgraded omv 3.0.35, no error appears
      Certbot is in jessie backports
      You should ensure that jessie backports is in your repositories
      Try reinstall omv-extras
      i have jessie backports in my repositories enabled.
      The error in omv is here:

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. >>> *************** Error ***************
      5. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --allow-unauthenticated --reinstall install openmediavault-letsencrypt 2>&1': Reading package lists...
      6. Building dependency tree...
      7. Reading state information...
      8. Some packages could not be installed. This may mean that you have
      9. requested an impossible situation or if you are using the unstable
      10. distribution that some required packages have not yet been created
      11. or been moved out of Incoming.
      12. The following information may help to resolve the situation:
      13. The following packages have unmet dependencies:
      14. openmediavault-letsencrypt : Depends: certbot but it is not going to be installed
      15. E: Unable to correct problems, you have held broken packages.
      16. <<< *************************************
      Display All
      omv 3.0.76 | 64 bit | omvextrasorg 3.4.25 | kernel 4.9
      used plugins: nginx | mysql | docker-gui | flashmemory |rsnapshot | antivirus | apt tool | letsEncrypt | fail2ban for omv-webgui/Nextcloud/emby
      used other: netxtcloud | logitechmediaserver | emby
    • If you install the backports kernel with omv-extras, the backports repo will be in the /etc/apt/sources.list.b/backports.list file
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      If you install the backports kernel with omv-extras, the backports repo will be in the /etc/apt/sources.list.b/backports.list file

      luxflow wrote:

      post result of`cat /etc/apt/sources.list`
      you should have a following line`deb ftp.debian.org/debian jessie-backports main`

      and try
      apt-get update && apt-get install -t jessie-backports certbot
      I have in the backports.list thees:

      Source Code

      1. deb http://httpredir.debian.org/debian jessie-backports main contrib non-free
      omv 3.0.76 | 64 bit | omvextrasorg 3.4.25 | kernel 4.9
      used plugins: nginx | mysql | docker-gui | flashmemory |rsnapshot | antivirus | apt tool | letsEncrypt | fail2ban for omv-webgui/Nextcloud/emby
      used other: netxtcloud | logitechmediaserver | emby
    • output of: apt-cache policy certbot

      Source Code

      1. certbot:
      2. Installiert: (keine)
      3. Installationskandidat: 0.8.1-2~bpo8+1 Versionstabelle:
      4. 0.8.1-2~bpo8+1 0
      5. 100 http://httpredir.debian.org/debian/ jessie-backports/main amd64 Packages
      and the apt-get install certbot:

      Source Code

      1. Paketlisten werden gelesen... Fertig
      2. Abhängigkeitsbaum wird aufgebaut.
      3. Statusinformationen werden eingelesen.... Fertig
      4. Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
      5. Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
      6. Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
      7. nicht erstellt wurden oder Incoming noch nicht verlassen haben.
      8. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
      9. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      10. certbot : Hängt ab von: python-certbot (= 0.8.1-2~bpo8+1) soll aber nicht installiert werden
      11. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
      Display All
      omv 3.0.76 | 64 bit | omvextrasorg 3.4.25 | kernel 4.9
      used plugins: nginx | mysql | docker-gui | flashmemory |rsnapshot | antivirus | apt tool | letsEncrypt | fail2ban for omv-webgui/Nextcloud/emby
      used other: netxtcloud | logitechmediaserver | emby
    • ryecoaaron wrote:

      What do you get when you try: apt-get install python-certbot

      Source Code

      1. Paketlisten werden gelesen... Fertig
      2. Abhängigkeitsbaum wird aufgebaut.
      3. Statusinformationen werden eingelesen.... Fertig
      4. Einige Pakete konnten nicht installiert werden. Das kann bedeuten, dass
      5. Sie eine unmögliche Situation angefordert haben oder, wenn Sie die
      6. Unstable-Distribution verwenden, dass einige erforderliche Pakete noch
      7. nicht erstellt wurden oder Incoming noch nicht verlassen haben.
      8. Die folgenden Informationen helfen Ihnen vielleicht, die Situation zu lösen:
      9. Die folgenden Pakete haben unerfüllte Abhängigkeiten:
      10. python-certbot : Hängt ab von: python-acme (>= 0.8.1) soll aber nicht installiert werden
      11. Hängt ab von: python-cryptography (>= 0.7) aber 0.6.1-1 soll installiert werden
      12. Hängt ab von: python-psutil (>= 2.2.1) aber 2.1.1-1+b1 soll installiert werden
      13. E: Probleme können nicht korrigiert werden, Sie haben zurückgehaltene defekte Pakete.
      Display All
      omv 3.0.76 | 64 bit | omvextrasorg 3.4.25 | kernel 4.9
      used plugins: nginx | mysql | docker-gui | flashmemory |rsnapshot | antivirus | apt tool | letsEncrypt | fail2ban for omv-webgui/Nextcloud/emby
      used other: netxtcloud | logitechmediaserver | emby
    • You need a couple of other packages from jessie-backports...

      apt-get -t jessie-backports install certbot python-cryptography python-psutil python-certbot
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hello everyone,
      I'm having a little problem with the automatic renew of the certificate. I had this issue also when I first had to renew the cert because it expired. So now, the new certificate has expired again and can't renew it. I got an error that shows something like: could not get config path ...
      Same problem as the first certificate I used. So I repeated the same process I did the other time: delete certificate, uninstall plugin and reinstall plugin and issuing a new cert.
      But now, I can't install the plugin anymore.
      "Install log" is here:

      pasted.co/154c4f23
      password: openmediavault

      I don't know why it's broken and I don't know how to completely uninstall the plugin to reinstall it later and start from scratch once again.

      Any help will be very appreciated!


      .-Guillem
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • I love this plugin!
      I have my OMV open to the outside so I can reach couchpotato and sonarr etc.
      I have no problem reaching my server via my domain from every network except my own home network (where the NAS-server is connected to). It won't load the page, but as soon as I connect to another network it loads fine.

      Is there something I am missing?

      I have port 80 and 443 open, and I use Enable SSL and Force Secure connection.
    • hey joq3,
      When inside your own LAN, are you trying to access OMV using IP or domain name? Some routers, the majority I think, don't let access your own LAN if you use your WAN IP from inside the same LAN.
      If you plan to access OMV from inside, you could 2 two things:
      1. Use private IP adress to access OMV
      2. Modify your local DNS server to point your private IP when asking for your Domain Name.

      I don't know if you understand me. Lets' have an example:
      My OMV has IP 192.168.2.230
      My LAN has WAN IP x.x.x.x
      I have a DDNS service that points lordwektabyte.no-ip.org to x.x.x.x

      Since I use option 2, I have added a static DNS entry on my router (my local DNS server) to point lordwektabyte.no-ip.org to 192.168.2.230. So when I type lordwektabyte.no-ip from inside my LAN, the DNS takes me to 192.168.2.230 instead of ' resolving from outside' and taking me to x.x.x.x


      Hope it helps!
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • Lord Wektabyte wrote:

      hey joq3,
      When inside your own LAN, are you trying to access OMV using IP or domain name? Some routers, the majority I think, don't let access your own LAN if you use your WAN IP from inside the same LAN.
      If you plan to access OMV from inside, you could 2 two things:
      1. Use private IP adress to access OMV
      2. Modify your local DNS server to point your private IP when asking for your Domain Name.

      I don't know if you understand me. Lets' have an example:
      My OMV has IP 192.168.2.230
      My LAN has WAN IP x.x.x.x
      I have a DDNS service that points lordwektabyte.no-ip.org to x.x.x.x

      Since I use option 2, I have added a static DNS entry on my router (my local DNS server) to point lordwektabyte.no-ip.org to 192.168.2.230. So when I type lordwektabyte.no-ip from inside my LAN, the DNS takes me to 192.168.2.230 instead of ' resolving from outside' and taking me to x.x.x.x


      Hope it helps!
      Thank you for a great explanation! Did some searching, and my router (Asus RT-AC68U) which uses Merlin firmware does support NAT Loopback which should solve this problem. It has always worked, and at almost the same time I installed this plugin Lets Encrypt, I updated the router. So maybe it is a router firmware issue. Will try to fix it that way.

      Because NAT Loopback does this right?