Email notifications does not work anymore

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Email notifications does not work anymore

      Hey folks,
      I recently found that I don't receive email notifications from my OMV box. I looked at the system logs, and in the syslog, it appears that Postfix can't find the "smtp.gmail.com" server to send the emails. It was working until December and I did not touch anything in the email configuration.
      Trying to resolve the problem I had changed different ports, different servers (using the hotmail one "smtp.live.com") and the log shows that Postfix email server is always complaining that the SMTP server could not be found.

      Has anyone any idea to solve that? Maybe a bug in the postfix server?


      Thanks in advance.
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • I don't think it's a DNS problem because I can ping successfully from OMV to the SMTP servers...
      [IMG:ftp://gsola96.no-ip.org/Public/Captura.PNG]
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • Using port 465 as I found in a lot of webpages... I did not change any configuration and suddenly, email does not work.
      [IMG:ftp://gsola96.no-ip.org/Public/Captura2.PNG]
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • I'm using OMV 2.1.x
      Two factor authentication in Gmail?
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • Is secure authentication model for gmail, where you link your account to mobile devices (using sms codes), authenticator app and extra security codes. When this model is enabled you need to create whats called app password for postfix since you cannot be checking mobile devices for the headless server to send an email. An app password is unique password that can be generated for the specific application.
      if you don't know about 2 favor authenticiation you probably don't have it enabled.
      this seems like weird error in postifx, maybe try to type tye smtp address in case you pasted and some weird char
      got in the there
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • I don't understand anything. I tried with Yahoo, Hotmail.com, Outlook.com and I always get the same error...
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • Is dig a command to execute?

      EDIT: After installing DNS utils:

      Source Code

      1. root@OMV:~# dig mx gmail.com
      2. ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> mx gmail.com
      3. ;; global options: +cmd
      4. ;; connection timed out; no servers could be reached


      By the way, I pinged smtp.gmail.com from Windows machine and I get this:

      Source Code

      1. Haciendo ping a gmail-smtp-msa.l.google.com [74.125.206.108] con 32 bytes de datos:
      2. Respuesta desde 74.125.206.108: bytes=32 tiempo=65ms TTL=45

      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • I get this:

      Source Code

      1. root@OMV:~# dig mx gmail.com
      2. ; <<>> DiG 9.8.4-rpz2+rl005.12-P1 <<>> mx gmail.com
      3. ;; global options: +cmd
      4. ;; connection timed out; no servers could be reached
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • Changed DNS to 8.8.8.8 (without secondary one) --> Same output

      After rebooting and executing 'dig mx gmail.com' --> Same output
      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.
    • Source Code

      1. ping 8.8.8.8
      2. PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
      3. 64 bytes from 8.8.8.8: icmp_req=1 ttl=47 time=64.4 ms
      4. 64 bytes from 8.8.8.8: icmp_req=2 ttl=47 time=64.9 ms
      5. 64 bytes from 8.8.8.8: icmp_req=3 ttl=47 time=64.9 ms
      6. 64 bytes from 8.8.8.8: icmp_req=4 ttl=47 time=65.0 ms


      Source Code

      1. ping www.gmail.com
      2. PING googlemail.l.google.com (216.58.211.229) 56(84) bytes of data.
      3. 64 bytes from www.gmail.com (216.58.211.229): icmp_req=1 ttl=55 time=45.6 ms
      4. 64 bytes from www.gmail.com (216.58.211.229): icmp_req=2 ttl=55 time=45.3 ms
      5. 64 bytes from www.gmail.com (216.58.211.229): icmp_req=3 ttl=55 time=45.5 ms
      6. 64 bytes from www.gmail.com (216.58.211.229): icmp_req=4 ttl=55 time=45.7 ms


      Source Code

      1. cat /etc/resolv.conf
      2. search Home
      3. nameserver 192.168.1.1

      DISCLAIMER: :!: I'm not a native English speaker, I'm sorry if I don't explain as good as you would want. :!:

      My NAS:
      Always the latest OMV Erasmus running on an AMD Sempron 3850 @1.3GHz with 4.9.0 Backports Kernel
      with 120GB Samsung SSD 850 EVO for OpenMediaVault & 2x500GB Primary Data HDD + 1TB Secondary HDD for Backup & 2TB USB 3.0 External HDD for offline backup

      Plugin list:
      Flash Memory, Locate, OMV-Extras.org, RSnapshot, Sensors, Syncthing, SMB/CIFS, SSH, USB Backup
      _____________________________________________________________________________________________________________________________

      The Schrödinger's code is that one which is going to work and it's full of bugs at the same time; until you test it, you won't be able to determine it.