ownCloud Ordner mit Windows Explorer zugreifen (Netzwerkfreigabe)

    • OMV 2.x
    • Resolved
    • ownCloud Ordner mit Windows Explorer zugreifen (Netzwerkfreigabe)

      Hallo,
      ich habe mir gestern einen Nas zusammen gebaut mit OpenMediaVault + Dienst ownCloud.
      Ich möchte vom meinem Hauptrechner, wo meine ganzen Fotos gespeichert sind, diese per ownCloud auf die Nas legen.
      Gleichzeitig möchte ich aber per PC/Laptop ganz einfach auf die Fotos zugreifen, am besten per Windows Explorer und Netzwerkfreigabe.
      Eine Cifs/SMB Freigabe habe ich für die ganze HDD der Nas gemacht und ich kann mich mit dieser auch Verbinden. Wenn ich aber auf den von mir angelegten Ordner ownCloud zu greifen will,
      geht das nicht.
      Ich versuche es wie in dieser Beschreibung tecchannel.de/server/cloud_com…client_und_co/index3.html
      per Netzwerk verbinden -> http(s)://<owncloud-Server>/remote.php/webdav/
      dann kommt zwar ein Anmeldefenster, aber später die Nachricht das ich das Zertifikat nicht habe.
      Weiter bin ich nicht gekommen.
      Wie bekomme ich das Zertifikat (ich musste ja eins in OMV erstellen), von meinem Pi auf den PC?
      Oder wie erstelle ich ein Zertifikat am Windows PC was ich dann in OMV importieren kann?
      Oder gibt es einen ganz anderen einfachen Weg wie ich auf meine Fotos komme?

      Vielen Dank
    • hast du für den (die) Ordner auf die du über owncloud zugreifen möchtest auch die Rechte für den Benutzer www-data eingerichtet? Sonst kannst du nicht darauf zugreifen.
      Andere Frage noch am Rande, benutzt du das omv-owncloud Plugin oder die manuelle owncloud Einrichtung?
      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • ich meinte unter freigegebene Ordner dann ACL und ein Häckchen bei - wenn vorhanden- owncloud oder ansonsten www-data.
      Dann müsste es gehen
      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • Das mit dem ACL hat nix gebracht.
      Hab aber dann das Zertifikat aus Firefox exportiert (unter Einstellungen -> erweitert -> Zertifikate) und mit certmgr.msc das Zertifikat importiert.
      Hier kann man es nachlesen: phutility.de/2010/03/11/webdav-mit-ssl-unter-windows-7/

      das ganze habe ich unter Win10 gemacht. Nun konnte ich mich Verbinden und sehe die Ordner.

      Noch eine andere Frage:
      Ich habe eine 1Tb Hdd. Ich habe nun eine "Nas" Verbindung und eine ownCloud Verbindung unter MeinPC.
      Die Nas Verbindung hat Gesamt 916Gb und frei 911Gb. Die ownClud Verbindung hat Gesamt 58Gb und davon 10,4Gb frei.
      Will nun meine Bilder syncen aber die sind knapp 50Gb? Kann ich das wo einstellen in ownCloud?

      benutze 5mb von 911Gb steht in ownCloud, also passt
    • leider muss ich sagen, das es doch nicht so funktioniert wie ich es will.
      Nach einem Neustart des Laptops wird das Netzlaufwerk "OwnCloud" nicht verbunden, rotes kreuz am Icon. Dann kann ich nur Trennen und die Verbindung wieder per Hand einrichten.
      Die Netzlaufwerkverbindung zu "Nas" ist aber verbunden.

      Auch habe ich dann auf dem PC den OwnCloud Client inst und wollte dann meinen Ordner lokal "Bilder" auf die cloud sichern. Nach 10min waren gerade mal 50mb in der cloud. Wie bekomme ich nun am schnellsten meine ~50GB da rein? Über FTP per Hand runter ziehen und dann OwnCloud starten und indizieren lassen?

      Danke
    • Du hast geschriebn, dass du das omv plugin für owncloud nutzt. Das ist leider nut Version 6.x Momentan ist aktuell die Version 8.2. Das mag erstens ein Grund sein. Des weiteren nutzt das Plugin sqlite als Datenbank, was bei vielen einzelnen Dateien wie z.B. Bildern das ganze ausbremmst. Es ist ein deutlicher unterschied zu mysql. Diese Erfahrung hab ich selbst schon gemacht.
      Ich habe Owncloud mit dem nginx und dem Datenbank (mysql) Plugin eingerichtet. Diese Lösung läuft bei mir gut und flüssig.Owncloud 8 and MySQL: alternative approach
      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • ich hab OwnCloud gerade installiert, aber ich hänge am letzten Schritt fest.
      Da wo man Adminkonto anlegen muss und mySql-Datenabank angeben muss (bei der Anleitung das letzte Bil)
      Als Fehler steht:
      Fehler

      Error while trying to create admin user: Failed to connect to the
      database: An exception occured in driver: SQLSTATE[HY000] [2002] No
      such file or directory

      hab eigentlich alles nach Anleitung gemacht.
      unten bei
      root
      openmediavault als Passwort

      Danke

      Edit: Muss ich mySql starten und auch noch was konfigurieren?

      The post was edited 1 time, last by Schoof ().

    • ja, du musst sql aktivieren und in dem web tool einen Benutzer und eine Datenbank anlegen. Diese Daten trägst du dann in der Seite die du gerade meinntest ein.
      omv 4.0.19 | 64 bit | omvextrasorg 4.1.2 | kernel 4.14
      used plugins: nginx | mysql | docker-gui |rsnapshot | antivirus | apt tool | letsEncrypt |
      used other: netxtcloud | logitechmediaserver | emby
    • sry für die Anfänger frage:
      aber wie kann ich nun die erstellten Ordner auf der HDD wieder löschen?
      also denn www und www_owncloud
      ich will wieder von vorne anfangen weil nun gar nix mehr so richtig geht. Über Win Laptop fehlen mir die berechtigungen. Über FTP gehts auch nicht.
      Putty hab ich mich eingelogt und bei pwd kommt nur /root. Will doch einfach nur über putty auf meine HDD und dort den ordner löschen.
      Am besten jemand schreibt mir die kurz die Befehle:
      Alle Dateien und Ordner anzeigen
      cd verzeichniss ist ins verzeichnis rein
      und der Befehl zum Ordner löschen
      Danke
    • Hey Schoof,

      hast Du im OMV über das GUI einen Benutzer angelegt? Um mit Deinem Windows-Laptop auf die SMB-Freigaben zugreifen zu können, brauchst du einen Benutzer mit Passwort und den entsprechenden Berechtigungen. Der muss im OMV angelegt werden ...

      Wenn die von Dir angelegten Verzeichnisse "www" und "www_owncloud" irgendwo auf Deinem OMV System referenziert sind, kannst Du sie nicht löschen, ohne weiteren Schaden anzurichten.

      Was meinst Du konkret mit "weil nun gar nix mehr so richtig geht"? Gehe bitte einfach nochmal Schritt für Schritt das HowTo durch, Du wirst den Fehler ganz sicher finden.


      pwd ist das aktuelle Verzeichnis anzeigen
      rm -r dir ist Verzeichnis (Directory) löschen
      ls -la Dateien auflisten
      dir -a Verzeichnisse innerhaalb des aktuellen Verzeichnisses anzeigen

      Wenn Du mehr über die Linux-Befehle wissen willst, gibst Du in Putty z.B. ein: man dir das ist das Manual über den Befehl "dir"

      Kannst ja auch mit WinSCP erstmal versuchen, das sieht ähnlich aus wie der Norton-Commander. Hier kannst du die Verzeichnis-struktur sehen und bearbeiten, Rechte vergeben usw.

      Googeln nach "Linux auf einem Blatt" kann auch weiterhelfen ...

      Viele Grüße.

      The post was edited 1 time, last by omavoss ().