NUT settings for UPS Trust OXXTRON 1300VA

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NUT settings for UPS Trust OXXTRON 1300VA

      Hallo.

      I'm running OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586
      Today i got my UPS UPS Trust OXXTRON 1300VA.
      I installed the NUT plugin.
      I tried several driver configurations like the Trust driver form the NUT Hardware compatibility list.

      I tried

      Source Code

      1. ​driver = blazer_ser
      2. port = auto

      and

      Source Code

      1. driver = blazer_usb
      2. port = auto


      i also tried the port usb and several other drivers but nothing. when i go to the system->ups tab i receive the error

      Source Code

      1. ​Failed to execute command 'upsc 'ups' 2>&1': Error: Driver not connected
      2. Errore #4000:
      3. exception 'OMVException' with message 'Failed to execute command 'upsc 'ups' 2>&1': Error: Driver not connected' in /usr/share/openmediavault/engined/rpc/nut.inc:151
      4. Stack trace:
      5. #0 [internal function]: OMVRpcServiceNetworkUPSTools->getStats(NULL, Array)
      6. #1 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #2 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('getStats', NULL, Array)
      8. #3 /usr/sbin/omv-engined(500): OMVRpc::exec('Nut', 'getStats', NULL, Array, 1)
      9. #4 {main}


      my lsusb

      Source Code

      1. ​Bus 002 Device 005: ID 0925:1234 Lakeview Research
      2. Bus 004 Device 002: ID 0781:5567 SanDisk Corp. Cruzer Blade
      3. Bus 004 Device 004: ID 0424:2228 Standard Microsystems Corp. 9-in-2 Card Reader
      4. Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
      5. Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
      6. Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
      7. Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
      8. Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


      My bc is up to date

      i tried also some command found in other threads similar like

      Source Code

      1. ​sudo /lib/nut/blazer_usb -a usb -x vendorid=0925
      2. Network UPS Tools - Megatec/Q1 protocol USB driver 0.08 (2.6.4)
      3. Error: Section usb not found in ups.conf


      Can somebody give me some hints to solve this please

      Thanks
      OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586
    • Maybe this can help more

      Source Code

      1. ​ lsusb -v
      2. Bus 002 Device 005: ID 0925:1234 Lakeview Research
      3. Device Descriptor:
      4. bLength 18
      5. bDescriptorType 1
      6. bcdUSB 1.10
      7. bDeviceClass 0 (Defined at Interface level)
      8. bDeviceSubClass 0
      9. bDeviceProtocol 0
      10. bMaxPacketSize0 8
      11. idVendor 0x0925 Lakeview Research
      12. idProduct 0x1234
      13. bcdDevice 0.01
      14. iManufacturer 1 ?
      15. iProduct 2 UPS USB MON V1.4
      16. iSerial 0
      17. bNumConfigurations 1
      18. Configuration Descriptor:
      19. bLength 9
      20. bDescriptorType 2
      21. wTotalLength 34
      22. bNumInterfaces 1
      23. bConfigurationValue 1
      24. iConfiguration 0
      25. bmAttributes 0x80
      26. (Bus Powered)
      27. MaxPower 100mA
      28. Interface Descriptor:
      29. bLength 9
      30. bDescriptorType 4
      31. bInterfaceNumber 0
      32. bAlternateSetting 0
      33. bNumEndpoints 1
      34. bInterfaceClass 3 Human Interface Device
      35. bInterfaceSubClass 0 No Subclass
      36. bInterfaceProtocol 0 None
      37. iInterface 0
      38. HID Device Descriptor:
      39. bLength 9
      40. bDescriptorType 33
      41. bcdHID 1.00
      42. bCountryCode 0 Not supported
      43. bNumDescriptors 1
      44. bDescriptorType 34 Report
      45. wDescriptorLength 78
      46. Report Descriptors:
      47. ** UNAVAILABLE **
      48. Endpoint Descriptor:
      49. bLength 7
      50. bDescriptorType 5
      51. bEndpointAddress 0x81 EP 1 IN
      52. bmAttributes 3
      53. Transfer Type Interrupt
      54. Synch Type None
      55. Usage Type Data
      56. wMaxPacketSize 0x0006 1x 6 bytes
      57. bInterval 1
      58. Device Status: 0x0000
      59. (Bus Powered)
      Display All

      Source Code

      1. ​[code]​
      [/code]
      OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586
    • i got uone step further.

      i changed my configuration to

      Source Code

      1. ​driver = usbhid-ups
      2. port = auto
      3. vendorid = 0925
      4. productid = 1234


      now when i hit

      Source Code

      1. ​sudo /lib/nut/usbhid-ups -a trust -DD
      2. Network UPS Tools - Generic HID driver 0.37 (2.6.4)
      3. USB communication driver 0.32
      4. 0.000000 debug level is '2'
      5. 0.000934 upsdrv_initups...
      6. 0.144179 Checking device (1D6B/0001) (005/001)
      7. 0.168171 - VendorID: 1d6b
      8. 0.168345 - ProductID: 0001
      9. 0.168506 - Manufacturer: unknown
      10. 0.168697 - Product: unknown
      11. 0.168856 - Serial Number: unknown
      12. 0.169014 - Bus: 005
      13. 0.169213 Trying to match device
      14. 0.169375 Device does not match - skipping
      15. 0.169615 Checking device (0424/2228) (004/004)
      16. 0.169805 - VendorID: 0424
      17. 0.170007 - ProductID: 2228
      18. 0.170166 - Manufacturer: unknown
      19. 0.170363 - Product: unknown
      20. 0.170522 - Serial Number: unknown
      21. 0.170680 - Bus: 004
      22. 0.170886 Trying to match device
      23. 0.171047 Device does not match - skipping
      24. 0.171256 Checking device (0781/5567) (004/002)
      25. 0.171442 - VendorID: 0781
      26. 0.171650 - ProductID: 5567
      27. 0.171809 - Manufacturer: unknown
      28. 0.172008 - Product: unknown
      29. 0.172182 - Serial Number: unknown
      30. 0.172386 - Bus: 004
      31. 0.172544 Trying to match device
      32. 0.172704 Device does not match - skipping
      33. 0.172914 Checking device (1D6B/0002) (004/001)
      34. 0.173099 - VendorID: 1d6b
      35. 0.173259 - ProductID: 0002
      36. 0.173320 - Manufacturer: unknown
      37. 0.173342 - Product: unknown
      38. 0.173403 - Serial Number: unknown
      39. 0.173425 - Bus: 004
      40. 0.173485 Trying to match device
      41. 0.173509 Device does not match - skipping
      42. 0.173535 Checking device (1D6B/0001) (003/001)
      43. 0.196166 - VendorID: 1d6b
      44. 0.196194 - ProductID: 0001
      45. 0.196259 - Manufacturer: unknown
      46. 0.196285 - Product: unknown
      47. 0.196305 - Serial Number: unknown
      48. 0.196367 - Bus: 003
      49. 0.196389 Trying to match device
      50. 0.196450 Device does not match - skipping
      51. 0.196503 Checking device (0925/1234) (002/005)
      52. 0.220249 - VendorID: 0925
      53. 0.220356 - ProductID: 1234
      54. 0.220378 - Manufacturer: ?
      55. 0.220439 - Product: UPS USB MON V1.4
      56. 0.220462 - Serial Number: unknown
      57. 0.220522 - Bus: 002
      58. 0.220543 Trying to match device
      59. 0.220602 Device does not match - skipping
      60. 0.220632 Checking device (1D6B/0001) (002/001)
      61. 0.220742 - VendorID: 1d6b
      62. 0.220811 - ProductID: 0001
      63. 0.220870 - Manufacturer: unknown
      64. 0.220892 - Product: unknown
      65. 0.220952 - Serial Number: unknown
      66. 0.220974 - Bus: 002
      67. 0.220994 Trying to match device
      68. 0.221056 Device does not match - skipping
      69. 0.221083 Checking device (1D6B/0001) (001/001)
      70. 0.244174 - VendorID: 1d6b
      71. 0.244248 - ProductID: 0001
      72. 0.244271 - Manufacturer: unknown
      73. 0.244291 - Product: unknown
      74. 0.244353 - Serial Number: unknown
      75. 0.244375 - Bus: 001
      76. 0.244435 Trying to match device
      77. 0.244458 Device does not match - skipping
      78. 0.244545 No appropriate HID device found
      79. 0.244615 No matching HID UPS found
      Display All


      i get the above output but it says they don't match, althought the vendor and product id appear in the checked devices.

      i tried other drivers like

      Source Code

      1. ​bcmxcp_usb
      2. blazer_usb
      3. richcomm_usb
      4. ecc


      but i get this

      Source Code

      1. ​Network UPS Tools - Generic HID driver 0.37 (2.6.4)
      2. USB communication driver 0.32
      3. Error: UPS [trust] is for driver richcomm_usb, but I'm usbhid-ups!


      So any idea? i looked also in the manpages of usbhid-ups but its not my knowledge.

      Thanks for replies
      OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586
    • Ok i solved by my own with the kind help of the NUT mailing list members.

      My configuration for UPS Trust OXXTRON 1300VA is:

      Source Code

      1. ​driver = richcomm_usb
      2. port = auto

      It seems that the only information given from the UPS the following

      Source Code

      1. ​device.mfr: Richcomm dry-contact to USB solution
      2. device.model: UPS USB MON V1.4
      3. device.serial: unknown
      4. device.type: ups
      5. driver.name: richcomm_usb
      6. driver.parameter.pollinterval: 2
      7. driver.parameter.port: auto
      8. driver.version: 2.6.4
      9. driver.version.internal: 0.04
      10. ups.mfr: Richcomm dry-contact to USB solution
      11. ups.model: UPS USB MON V1.4
      12. ups.productid: 1234
      13. ups.serial: unknown
      14. ups.status: OL
      15. ups.vendorid: 0925
      Display All


      The status:

      Source Code

      1. ​OL / OB / BL
      are shown correct i think when the supply status changes.
      When the ups is attached on the AC it shows

      Source Code

      1. OL (online i think)

      When i take away the power from the ups it shows

      Source Code

      1. ​OB (on battery i think)

      When the battery is low it show

      Source Code

      1. BL (battery low i think)


      it respects also the given shutdown or suspend settings of the plugin.

      If somebody figures out how to squeeze more information out of it i would be interested 8o
      OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586
    • Hallo All.

      I update my system to version 4 and now i'm trying to configure it again but i have a problem giving the ups a name.

      i always get the error on saving the configuration


      Source Code

      1. Errore #0:
      2. OMV\Json\SchemaValidationException: upsname: The value 'UPSTESTNAME' doesn't match the pattern '^[a-z0-9_-]+$'. in /usr/share/php/openmediavault/json/schema.inc:478
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/json/schema.inc(370): OMV\Json\Schema->checkPattern('UPSTESTNAME', Array, 'upsname')
      5. #1 /usr/share/php/openmediavault/json/schema.inc(297): OMV\Json\Schema->validateString('UPSTESTNAME', Array, 'upsname')
      6. #2 /usr/share/php/openmediavault/json/schema.inc(624): OMV\Json\Schema->validateType('UPSTESTNAME', Array, 'upsname')
      7. #3 /usr/share/php/openmediavault/json/schema.inc(395): OMV\Json\Schema->checkProperties(Object(stdClass), Array, '')
      8. #4 /usr/share/php/openmediavault/json/schema.inc(285): OMV\Json\Schema->validateObject(Object(stdClass), Array, '')
      9. #5 /usr/share/php/openmediavault/json/schema.inc(257): OMV\Json\Schema->validateType(Object(stdClass), Array, '')
      10. #6 /usr/share/php/openmediavault/rpc/paramsvalidator.inc(59): OMV\Json\Schema->validate(Object(stdClass))
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(178): OMV\Rpc\ParamsValidator->validate('{"enable":true,...')
      12. #8 /usr/share/openmediavault/engined/rpc/nut.inc(67): OMV\Rpc\ServiceAbstract->validateMethodParams(Array, 'rpc.nut.set')
      13. #9 [internal function]: OMVRpcServiceNetworkUPSTools->set(Array, Array)
      14. #10 /usr/share/php/openmediavault/rpc/serviceabstract.inc(123): call_user_func_array(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('set', Array, Array)
      16. #12 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Nut', 'set', Array, Array, 1)
      17. #13 {main}
      Display All
      Any ideas to help?

      Thanks in adavnce
      OMV 2.1.20 Kernel 3.16.0-0.bpo.4-586