webui email notification for every login - where to configure?

    • OMV 2.x
    • webui email notification for every login - where to configure?

      Hello

      I recently upgraded from 1.19 to OMV 2.x and immediately noticed I got email notifications every time I logged into OMVs webui. I looked around and see no way to configure or turn off this notification. I also noticed it sends to the wrong email address which results in a delivery failure from gmail. It sends to admin@server.localdamin unlike the other system notifications.

      I found one other post on this but, it had no replies with a solution.
      Mail notification each time I log into Web-GUI, how to switch off?

      Any help would be appreciated. Thanks.

      Source Code

      1. Dear admin,
      2. your user account was used to log in to server.local (::ffff:192.168.2.102) via a web browser.
      3. Date and time: Sun, 24 Jan 2016 08:42:59 -0600
      4. Remote address: ::ffff:192.168.2.30
      5. User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
      6. If you recently logged in to the control panel, you can disregard this email. If you have not logged in recently and believe someone may have accessed your account, you should reset your password.
      7. Sincerely,
      8. your openmediavault system
      Display All
    • I have exactly this problem as well with OMV 2.1.25.

      I'd expect a toggle switch on the Notifications page, but there is none.

      There are two things wrong:
      1) the email is sent to the wrong email address (admin@server.localdomain)
      2) you can't turn it off entirely.

      Please let us know how to disable this feature.

      Thanks,
      daflow
    • I see in the bugtracker that feature request 0001453 addressed the first part of the issue in this thread, where the notification is sent to the wrong address. I would like to disable this specific notification. Can this notification be disabled? If so, I haven't found it in the webui. Thank you. Amazing software. 8|
    • I am bringing this up again as i am getting 8(!) email notifications every time i boot OMV. Is it possible to disable this?


      Source Code

      1. Dear admin,
      2. your user account was used to log in to openmediavault.local (::ffff:192.168.1.101) via a web browser.
      3. Date and time: Sun, 22 May 2016 13:20:00 +0300
      4. Remote address: ::ffff:192.168.1.103
      5. User agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:48.0) Gecko/20100101 Firefox/48.0
      6. If you recently logged in to the control panel, you can disregard this email. If you have not logged in recently and believe someone may have accessed your account, you should reset your password.
      7. Sincerely,
      8. your openmediavault system
      Display All
      Thank for your time and help.
    • Apparently the email is supposed to be sent the first time a user logs in as admin from a new browser. The information whether or not a login is "first time" is stored in a cookie in the browser.

      So if the email is sent on every login, there might be something wrong or incorrectly configured regarding storage of cookies for your OMV machine.
      Kind regards,
      Frank
    • I have this problem as well on 3.x

      Set the admin email details under notifications and the test email works.

      I receive UPS, login and other notifications to the defined email, but then occasionally, i am receiving

      Dear admin,
      your user account was used to log in to mynas (192.168.x.x) via a web browser
      .

      the problem is, i get a failed email response with
      Your message wasn't delivered to admin@mynas.localdomain because the domain mynas.localdomain couldn't be found.

      This is very weird given that it works for all other messages, but occasionally produces this for the login message.
    • gwaitsi wrote:

      I have this problem as well on 3.x

      Set the admin email details under notifications and the test email works.

      I receive UPS, login and other notifications to the defined email, but then occasionally, i am receiving

      Dear admin,
      your user account was used to log in to mynas (192.168.x.x) via a web browser.

      the problem is, i get a failed email response with
      Your message wasn't delivered to admin@mynas.localdomain because the domain mynas.localdomain couldn't be found.

      This is very weird given that it works for all other messages, but occasionally produces this for the login message.

      Exactly the same here! No idea how to change this email address.