Announcement Openmediavault 3.x - Important Information!

    • Mr.President wrote:

      but nothing will be overwritten in smb.conf after a reboot.
      I didn´t write something is overwritten after reboot. But if you make samba configuration changes (e.g. add 'vfs objects ='-entries or activate the recycle bin in "add share") in the WebUI, which effects the smb.conf then your manual changes are overwritten.

      Mr.President wrote:

      Standard recycle bin??
      Yes, that´s the recycle bin button in the share settings.
      OMV 3.0.78 (Gray style)
    • cabrio_leo wrote:

      if you make samba configuration changes (e.g. add 'vfs objects ='-entries or activate the recycle bin in "add share") in the WebUI, which effects the smb.conf then your manual changes are overwritten.
      In addition to that, editing the shared folder used in samba and giving another user permissions would overwrite the smb.conf.
      omv 3.0.80 erasmus | 64 bit | 4.9 backport kernel | omvextrasorg 3.4.25
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Mr.President wrote:

      However, let´s stop here.
      It works and that was the main topic.
      Again, ususally you don´t have any WebGUI....
      The comments aren't only for you. They are for people who read this thread and do the same thing. Then wonder why their system keeps changing.
      omv 3.0.80 erasmus | 64 bit | 4.9 backport kernel | omvextrasorg 3.4.25
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Openmediavault 3.x - Important Information!

      Mr.President wrote:

      Again, ususally you don´t have any WebGUI....


      But this is openmediavault. Here we have a WebGUI. ;)

      Have a nice evening! Bye Hoppel
      ---------------------------------------------------------------------------------------------------------------
      frontend software - android tv | libreelec | win10 | kodi krypton | emby for kodi | vnsi
      frontend hardware - nvidia shield tv | odroid c2 | yamaha rx-a1020 | quadral chromium style 5.1 | samsung le40-a789r2 | harmony smart control
      -------------------------------------------
      backend software - proxmox | openmediavault | debian jessie | kernel 4.4 lts | zfs | docker | emby | vdr | vnsi
      backend hardware - supermicro x11ssh-ctf | xeon E3-1240L-v5 | 64gb ecc | 8x4tb wd red | raid-z2 | digital devices max s8
      ---------------------------------------------------------------------------------------------------------------------------------------
    • Sure i didnt see the notes "dont upgrade from 2.x to 3.x via omv-upgrade"
      So i went from 1.9 to latest 3.x via omv-upgrade.... bad things happen :/

      Now ofc i get this error with omv-engined -d -f:

      Source Code

      1. PHP Fatal error: require_once(): Failed opening required 'openmediavault/config.inc' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/openmediavault/engined/rpc/backup.inc on line 19

      Is there any way to get this fixed? It seems that everything is running fine.

      - tvheadend
      - dropbox
      - all shares
      - mysql

      everything seems to work but the weblogin doesnt. i dont want to reinstall everything.. i spent very much time with the installation cause i am not so good at linux...
    • marnix wrote:

      Sure i didnt see the notes "dont upgrade from 2.x to 3.x via omv-upgrade"
      So i went from 1.9 to latest 3.x via omv-upgrade.... bad things happen :/

      everything seems to work but the weblogin doesnt. i dont want to reinstall everything.. i spent very much time with the installation cause i am not so good at linux...
      First let me say that I'm hoping that someone in the forum knows an easy way to fix your problem.
      ______________________________________________________

      With that said; I'm not so good at Linux either, and yes, I spent a good bit of time setting up my system as well.

      Knowing that I'm not good at Linux and wanting to preserve my data forced me to think of ways where I could help myself to be more, shall we say, "independent". So here's the first truly relevant question in this circumstance. Do you have a backup of your boot drive? (About 16GB or less and easy to do.)

      If not, since your data and boot drives are separate, all is not lost. (I'm referring to the data in your shares. It's still there.) However, recovery is not as easy as it would have been, if you had backup. Without backup, unfortunately, a rebuild may be in your future.
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.80 Erasmus
      ThinkServer TS140, 12GB ECC /
      32GB USB3.0 / 4TB

      OMV 3.0.68 Erasmus - Rsync'ed Backup Server
      R-PI 2 $29 / 16GB SD Card $8 / Real Time Clock $1.86
      4TB WD My Passport $119
    • PHP Fatal error: require_once(): Failed opening required 'openmediavault/config.inc' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/share/openmediavault/engined/rpc/backup.inc on line 19

      backup.inc is your issue. remove it and run omv-engined -d -f again.

      (To remove use apt-get purge openmediavault-backup - this did it for me).
      Asrock C70M, 32Gb OCZ SSD, 4Gb RAM runing OMV 3.X
      Acer system 8Gb SSD, 4Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • Hi guys

      Just a couple of questions,

      is v3 now stable ?

      I have some plugins installed will I need to uninstall any of them before I upgrade to v3

      Here's a list of my plugins

      root@Home-NAS:~# dpkg -l | grep openm
      ii openmediavault 2.2.14 all Open network attached storage solution
      ii openmediavault-keyring 0.4 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-minidlna 1.1 all OpenMediaVault miniDLNA (DLNA server) plugin
      ii openmediavault-omvextrasorg 2.13.9 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-plexmediaserver 1.0.15 all OpenMediaVault Plex Media Server plugin
      ii openmediavault-syncthing 1.9.2 all Syncthing plugin for OpenMediaVault.
      ii openmediavault-transmissionbt 1.4 all OpenMediaVault Transmission (BitTorrent client) plugin.
      root@Home-NAS:~#



      Many thanks



      Graeme
    • Emegra wrote:

      Hi guys

      Just a couple of questions,

      is v3 now stable ?

      I have some plugins installed will I need to uninstall any of them before I upgrade to v3

      Here's a list of my plugins

      root@Home-NAS:~# dpkg -l | grep openm
      ii openmediavault 2.2.14 all Open network attached storage solution
      ii openmediavault-keyring 0.4 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-minidlna 1.1 all OpenMediaVault miniDLNA (DLNA server) plugin
      ii openmediavault-omvextrasorg 2.13.9 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-plexmediaserver 1.0.15 all OpenMediaVault Plex Media Server plugin
      ii openmediavault-syncthing 1.9.2 all Syncthing plugin for OpenMediaVault.
      ii openmediavault-transmissionbt 1.4 all OpenMediaVault Transmission (BitTorrent client) plugin.
      root@Home-NAS:~#



      Many thanks



      Graeme
      it is stable. Unfortunately the upgrade process is not error free even if you run a server with no plugins. Clean install is the best option.
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • New

      Hello,

      I'm testing OMV 3 (3.0.79) on a virtual host.

      The first window, in french is not cool as you can see in the attachment, the window is far too small and not resizeable.

      In production I've installed OMV 2.1 with 15 users with no major problems.

      I will wait the 3.1 to change my 2.1.

      Thanks for the hard work you do.
      Images
      • Capture d’écran_2017-06-23_17-46-36.png

        9.46 kB, 597×480, viewed 10 times
    • New

      janfi wrote:

      Hello,

      I'm testing OMV 3 (3.0.79) on a virtual host.

      The first window, in french is not cool as you can see in the attachment, the window is far too small and not resizeable.

      In production I've installed OMV 2.1 with 15 users with no major problems.

      I will wait the 3.1 to change my 2.1.

      Thanks for the hard work you do.
      Probably would be good to post a bug @ bugtracker.openmediavault.org Give as many details as you can.
      If you make it idiot proof, somebody will build a better idiot.
    • New

      janfi wrote:

      Hello,

      I'm testing OMV 3 (3.0.79) on a virtual host.

      The first window, in french is not cool as you can see in the attachment, the window is far too small and not resizeable.

      In production I've installed OMV 2.1 with 15 users with no major problems.

      I will wait the 3.1 to change my 2.1.

      Thanks for the hard work you do.
      I just changed my Web UI for the same reason, just a few minutes ago. (I couldn't see the comments field.):

      ryecoaaron, one of the moderators, put me onto the info needed to change the Web UI to address the problem you demo'ed.

      The post is here -> Change Web UI

      (This will require that you SSH in and edit config files.)
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.80 Erasmus
      ThinkServer TS140, 12GB ECC /
      32GB USB3.0 / 4TB

      OMV 3.0.68 Erasmus - Rsync'ed Backup Server
      R-PI 2 $29 / 16GB SD Card $8 / Real Time Clock $1.86
      4TB WD My Passport $119
    • New

      janfi wrote:

      Hello,

      I'm testing OMV 3 (3.0.79) on a virtual host.

      The first window, in french is not cool as you can see in the attachment, the window is far too small and not resizeable.

      In production I've installed OMV 2.1 with 15 users with no major problems.

      I will wait the 3.1 to change my 2.1.

      Thanks for the hard work you do.
      Oh, I forgot to mention, use the "gray" theme.
      Good backup takes the "drama" out of computing
      ____________________________________
      OMV 3.0.80 Erasmus
      ThinkServer TS140, 12GB ECC /
      32GB USB3.0 / 4TB

      OMV 3.0.68 Erasmus - Rsync'ed Backup Server
      R-PI 2 $29 / 16GB SD Card $8 / Real Time Clock $1.86
      4TB WD My Passport $119