RemoteShares plugin and ACL

    • RemoteShares plugin and ACL

      Hello I am fairly new to OMV
      I am currently using two sources for video files
      1. Network Share on a system called unraid
      2. Local volume/share inside OMV

      I want to run the plugin called 'sonarr' and use both the network share and the local volume.
      I can get the local volume to work without issues but I am having problems getting the network share to work.
      The problem is that I cannot use any sort of UNC path to navigate the directory structure.
      I have tried \\hostname
      I have tried \\IPAddress
      It just doesn't work - no errors
      The Windows Version of sonar is able to use UNC path without issue.

      As a suggestion I tried using the RemoteShares plugin and setup a samba share with it.
      I am now able to browse the folder structure however when I attempt to add a folder to my library I get the following error:

      Request Failed: Root folder path '/media/61a21e9c-74b8-441a-866e-d83e0dfbd710/sharename/tvshows/' is not writable by user 'sonarr'

      I checked the permissions on the folder and we are seeing this:

      drwxr-xr-x 1 root root 0 Jan 30 03:40 sharename

      I believe this is the problem
      Only the root user and the root group have any sort of access to this folder.
      I've added the user 'sonarr' to the root group but it does not resolve the issue as that group only have read and execute permissions.
      If I try to adjust the ACL using the webgui on OMV it does not work. I get an error message:

      Failed to execute command 'export LANG=C; setfacl --remove-all --recursive -M '/tmp/setfaclnC8X96' -- '/media/61a21e9c-74b8-441a-866e-d83e0dfbd710/solarshare/TV' 2>&1': setfacl: /media/61a21e9c-74b8-441a-866e-d83e0dfbd710/solarshare/TV: Operation not supported

      If I try to change the ACL using chown or chmod it simply does nothing.
      My primary goal is to get the network share into Sonarr

      Any suggestions on how to proceed?
    • Where do you set these settings? (add user sonar to group root, set acl etc)? If you try to set it on your Sonar system where you just mounted your share via RemoteShare, then this is the wrong way. You have to configure the share itself on the other system. There you can (re)set the permissions on the folder using OMV-Extras. (Just go to shared folders, reset permission)
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive