NFS and permissions... drive me crazy !

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • NFS and permissions... drive me crazy !

      Hi,
      I just set up my first NAS and have some problems with sharing via NFS.
      I'm pretty used to work with debian/ubuntu/mint OS as my laptop and desktop system.
      However, these are my first steps about NFS sharing... and it really drives me crazy !

      I try to access to my nfs shared folders with my linux mint OS and autofs... sometimes it works and sometimes (after reboot and/or writing on it) won't work anymore !
      I guess it's due to /etc/auto.nfs (client) and /etc/export (server) options, but I didn't get to a working and stable configuration yet.
      Maybe I shoud precise that I'm able to see shared folders (showmount -e), to mount them, but not to access to it (read or write).


      Here are some questions which hopefully may help be to go on :

      OMV NFS config :
      1- Do I have to change the default parameters on OMV (ie insecure, no_subtree_check) ?
      2- Do I have to add some more on the server side (anonuid=, anongid=,root_squash,no_root_squash,all_squash) ?
      3- Should I restart nfs-kernel-server after changes ?

      OMV shared folder config :
      4 - What should be priviledges and ACL for owner/group/others for the shared folder ?
      5 - What about sub-folders ?
      6 - Should I restart nfs-kernel-server or anything else after changes ?

      Client autofs config :
      7 - Should I specify some options in /etc/auto.nfs (uid,gid...) ?
      8 - Should I restart autofs to apply changes ?

      Many thanks for your help !


      Edit : I've tryed to simplify my setup in order to avoid potential sources of problems. And for now it works...
      - I've disabled owncloud and related shared folders
      - I've disabled a shared folder containing the one I wanted to access
      It looks like this permission issue could be very tricky some times...

      The post was edited 2 times, last by Davy39 ().

    • Nfs works by matching the remote/local uid:gid, so in a case with Linux mint I think it should work if the omv share has standard omv permission root:users 775.
      I am pretty sure (but you have to confirm) that mint puts all users in "users" group gid number 100, same as any debian distro. Anonuid certainly help in some cases but in this case it should work, without it, but doesn't hurt.

      Once there if would suggest to perform
      A reset permission on the omv share, next to shared folder there is a tab to that only if you have omvextras.

      For testing leave out auto.nfs, and test with cli or the browser auto mount with the advertised avahi nfs service
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Thanks for reply.
      If I understand your point, since my client user on my lapop (linux mint) is part of users group (gid=100), it should theoretically be able to access the nfs shared folder as long as its ACL is 775, and that without modifying any NFS option.
      Is that right ?
      I'm going to try again on a fresh and cleaner install.
      Will keep in touch
    • Thanks, I got it now !
      It works with default configuration of OMV and the simplest autofs config :
      MyFolder -fstype=nfs,rw 192.168.1.10:/export/MyFolder

      I guess my problems were first coming from imbrication of shared folders and owncloud...
      I'm gonna try reset this in a more proper way
      We always think it is more complicated than it really is...
      I will set this treat as solved in a couple of days if I have no more problem.
      Anyway, thanks !