FTP - No shares seen

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • FTP - No shares seen

      I'm having trouble setting up FTP.

      First of all, in the beginning I could not log in at all - access denied. I figured out that the user name is case sensitive. I don't recall that I ever has needed to supply an FTP user name in the correct case. Is this intended behavior?

      After a successful login, I can not see any shared folders at all. I have added the shares to FTP, and I'm able to see them if I login using root or anonymous. So why can't a regular user see the share?

      The folder is also an SMB share and I can access the share this way without problems.

      I'm running OMV 2.1.27 with all updates installed.
    • Well the privilege button acts over samba and ftp, so if privileges are ok there then they must be at the conf file. Just check the file /etc/proftod/proftpd.conf

      See if your username is there
      There is an option in ftp that says deny login to users with no valid shell . Make sure is not on.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • I turned the mentioned option off, but it made no difference. I did not expect it to either, since I AM able to login. I just don't see any shared folders.

      I don't see my user name in the conf file. Could this be the problem?:

      Include /etc/proftpd/modules.conf
      LoadModule mod_vroot.c
      UseIPv6 on
      ServerName "OMV"
      ServerType standalone
      DeferWelcome on
      MultilineRFC2228 on
      DefaultServer on
      ShowSymlinks on
      DisplayChdir .message true
      ListOptions "-l"
      MaxInstances 30
      DenyFilter \*.*/
      AuthPAMConfig proftpd
      User proftpd
      Group nogroup
      Umask 000 000
      PersistentPasswd off
      TimesGMT off
      AllowOverwrite on
      AuthOrder mod_auth_pam.c* mod_auth_unix.c
      DefaultTransferMode ascii
      #SystemLog /var/log/proftpd/proftpd.log
      <IfModule mod_facl.c>
      FACLEngine on
      <IfModule mod_quotatab.c>
      QuotaEngine off
      <IfModule mod_ratio.c>
      Ratios off
      <IfModule mod_delay.c>
      DelayEngine on
      <IfModule mod_ctrls.c>
      ControlsEngine on
      ControlsMaxClients 2
      ControlsLog /var/log/proftpd/controls.log
      ControlsInterval 5
      ControlsSocket /var/run/proftpd/proftpd.sock
      <IfModule mod_ctrls_admin.c>
      AdminControlsEngine off
      <IfModule mod_vroot.c>
      VRootEngine on
      VRootLog /var/log/proftpd/vroot.log
      Port 21
      TransferLog NONE
      IdentLookups off
      UseReverseDNS off
      TimeoutIdle 1200
      TimeoutNoTransfer 600
      TimeoutStalled 600
      DeleteAbortedStores off
      <Directory />
      HideFiles (welcome.msg)
      <Anonymous ~ftp>
      User ftp
      Group nogroup
      UserAlias anonymous ftp
      DirFakeUser on ftp
      DirFakeGroup on ftp
      RequireValidShell off
      <Directory *>
      HideFiles (welcome.msg)
      HideNoAccess on
      <Limit WRITE>

      <IfModule mod_vroot.c>
      VRootAlias "/media/13a2d70c-eb6b-4e49-b3fe-682f573d5894/Video" "Video"
      <Directory /Video>
      <Limit ALL>
      AllowUser OR root
      AllowGroup OR root
      <Limit READ DIRS>
      AllowUser OR root
      AllowGroup OR root
      <IfModule mod_auth.c>
      DefaultRoot /srv/ftp
      MaxClients 5
      MaxLoginAttempts 98
      RequireValidShell off
      RootLogin on
      # This option is useless because this is handled via the PAM
      # pam_listfile.so module, so set it to 'off' by default.
      UseFtpUsers off

      <IfModule mod_ban.c>
      BanEngine off
      BanControlsACLs all allow user root
      BanLog /var/log/proftpd/ban.log
      BanMessage Host %a has been banned
      BanTable /var/run/proftpd/ban.tab

      DisplayLogin /srv/ftp/welcome.msg
      <IfModule mod_wrap.c>
      TCPAccessFiles /etc/hosts.allow /etc/hosts.deny
      TCPAccessSyslogLevels info warn
      TCPServiceName ftpd
    • Eh. Can't insert an image here, so you get a description.

      I click Access Rights Management -> Shared folders. Select the folder and click Privileges. This brings up a dialog which shows the user and three columns: Read/Write, Read-only and No access. All are off for the user.

      This is stange. When I create the folder I get the option set set the permissions and I choose one where 'users' group has read/write access. Thus, shouldn't all users have read/write access to the folder? It certainly works for SMB share, why not FTP?

      Whats the fix here? Its not very intuitive to set access rights for the user when the group allready has access.
    • Ok. Enabling the switch in privileges solved the problem. Thanks a lot. +1

      Still, I think this was very confusing. I never suspected rights management to be the problem since it was working with SMB. Further, I don't use ACL. I also think there is a lot of steps involved. Why do you need to set rights pr. user when that user is member of a group which has the access ('users' group).

      Is there a better way to manage rights. I know the 'users' group is a system group. Will it be simpler if I create a group of my own and put the users there?