Problems renaming Folders etc.

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Problems renaming Folders etc.

      Hi

      I've got a problem renaming or deleting some folders (I get the message "ungültiges Gerät" probably "invalid device" in English).
      But usually there's no problem with most folders, what can I do to troubleshoot this?

      Somehow one folder had root as owner, don't ask me why.
      I changed the other one with chown, I'm the owner now, but still I can't access the folder "you are not allowed to..." rights are the following: drwxrwsr-x

      Kind regards
      ChacalCH

      The post was edited 1 time, last by ChacalCH ().

    • ChacalCH wrote:

      I've got a problem renaming or deleting some folders (I get the message "ungültiges Gerät" probably "invalid device" in English).
      But usually there's no problem with most folders, what can I do to troubleshoot this?


      Where do you get this error? Command Line? Via Samba?

      ChacalCH wrote:

      Somehow one folder had root as owner, don't ask me why.


      That's correct. All files are owned by root and the group ​users by default.

      ChacalCH wrote:

      I changed the other one with chown, I'm the owner now, but still I can't access the folder "you are not allowed to..." rights are the following: drwxrwsr-x


      Still, how do you access them?

      Greetings
      David
      "Well... lately this forum has become support for everything except omv" [...] "And is like someone is banning Google from their browsers"

      Only two things are infinite, the universe and human stupidity, and I'm not sure about the former.


      Upload Logfile via WebGUI/CLI
      #openmediavault on freenode IRC | German & English | GMT+1
      Absolutely no Support via PM!

      I host parts of the omv-extras.org Repository, the OpenMediaVault Live Demo and the pre-built PXE Images. If you want you can take part and help covering the costs by having a look at my profile page.
    • I had the exact same problem right now. Never happened before. I use aufs on OMV 2.2.13. The folder is downloaded via Transmission, and if I check the permissions they are 777.
      If I create another folder inside this one I can edit it without any problem.

      I just get Invalid device when trying to edit the folder name with Windows. Very weird.