Fehler bei NFS-Freigabe / Error with new NFS share

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Fehler bei NFS-Freigabe / Error with new NFS share

      Hallo,

      nach langer Überlegung habe ich nun endlich meinen alten PC als NAS eingerichtet. Die Software der Wahl wurde openmediavault. Im Prinzip funktionierte alles schon einmal, doch nach einer Neueinrichtung mit Systemplattenwechsel (SSD) funktioniert die NFS-Freigabe nicht mehr. Immer wenn ich eine weitere Freigabe einrichten möchte, kriege ich die folgende Fehlermeldung:

      Source Code

      1. Fehler #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'export LANG=C; monit -t 2>&1': /etc/monit/conf.d/openmediavault-system.conf:1: Error: service name conflict, localhost already defined 'localhost'' in /usr/share/openmediavault/engined/module/monit.inc:56
      3. Stack trace:
      4. #0 /usr/share/openmediavault/engined/rpc/config.inc(180): OMVModuleMonit->applyConfig()
      5. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      6. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      7. #3 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      8. #4 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      9. #5 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      12. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      13. #9 {main}
      Display All

      Die omv-system.conf sieht ok aus. Kann mir jemand helfen?

      Hi,

      my old PC was runnning OMV very well. After a new configuration with a change to new system harddisk (SSD) it's not possible to create new NFS shares. I will receive the error message above.
      Is there anybody able to help?

      The post was edited 1 time, last by elend ().

    • Hey elend,

      scheint so, als ob Du bei einem Share als Client 127.0.0.1 eingetragen hättest, das mag das System nicht.

      Error: service name conflict, localhost already defined 'localhost'


      Prüfe das bitte. Bei mir sieht das so aus wie auf dem Bild:
      Ich habe aber nur den einen NFS-Share ... alle anderen sind SMB/CIFS-Shares. Die freigegebenen Ordner kann ich problemlos SMB/CIFS- oder (und) NFS-Shares zuordnen.

      Viele Grüße.
      Images
      • 2016-02-14 22_22_40-openmediavault web administration interface - FSC.fritz.box.png

        16.34 kB, 415×291, viewed 245 times

      The post was edited 4 times, last by omavoss ().

    • Hey elend,

      es gibt im Forum auch noch die Möglichkeit, admins oder Moderatoren oder andere Teilnehmer über "Konversation" direkt anzusprechen.
      Ich selbst weiß jetzt hier auch nicht mehr weiter, außer vielleicht das System neu aufzusetzen.

      Vielleicht versuchst Du es ja dort einmal.

      Warum eigentlich hast du eine SSD in den alten Rechner eingebaut? Die hat doch einen Haufen Geld gekostet, welches Du über die Stromrechnung für die OMV-Maschine NIEMALS wieder reinkriegen wirst. Für die SSD solltest Du auch noch das Plugin installieren, was die Schreibzugriffe reduziert; irgendwas mit "flash...". Sonst ist die SSD beizeiten hinüber.

      Strom- und damit Geld-sparen hättest Du besser damit gemacht, indem Du die Kiste mit WOL entsprechend aufgeweckt und mit dem autoshutdown-Plugin schlafen geschickt hättest. Nur mal so als Hinweis(e).

      Viele Grüße.

      The post was edited 1 time, last by omavoss ().

    • omavoss wrote:

      admins oder Moderatoren oder andere Teilnehmer über "Konversation" direkt anzusprechen
      Dafür ist das aber nicht gedacht ;) Fragen gehören hier ins Forum. Ich persönlich habe noch -nie- eine Frage via PM beantwortet, da sie früher oder später mal von jemand anderem wieder gebraucht werden könnte. Natürlich hab ich dann darum gebeten das nochmals zu posten ;)

      omavoss wrote:

      eine SSD in den alten Rechner eingebaut? Die hat doch einen Haufen Geld gekostet
      SSD´s sind nicht mehr gar so teuer. Eine kleine SSD fürs System kriegst du schon für 30-40€. Ich muss gestehen ich bin schon so lange auf den SSD-Zug aufgesprungen, dass ich sogar alle meine kleineren Externen Festplatten mit SSDs ausgestattet habe (256GB).

      omavoss wrote:

      Für die SSD solltest Du auch noch das Plugin installieren, was die Schreibzugriffe reduziert; irgendwas mit "flash...".
      openmediavault-flashmemory. Das Plugin kann man auch bei HDDs aktivieren. Bei SSDs ist das nicht ganz so wichtig. Unbedingt notwendig aber bei USB-Sticks. Natürlich nur, wenn die Platte fürs System verwendet wird.

      elend wrote:

      Mir hat das booten über die normale hdd zu lange gedauert
      Die Bootzeit ändert sich drastisch mit OMV 3.x. Positiv natürlich.

      So, nun zu deinem eigentlichen Problem:
      Bitte mal die Section <fstab> bis </fstab> aus der Datei /ect/openmediavault/config.xml posten.
      Zusätlich bitte ein cat /etc/monit/conf.d/openmediavault-system.conf
      OMV stoneburner | HP Microserver | 256GB Samsung 830 SSD for system | 4x 2TB in a RAID5
      OMV erasmus| Odroid XU4 | 5TB Data drive | 500GB Backup drive
    • So, endlich Zeit für die wichtigen Dinge im Leben ;)

      Wegen der SSD - habe eine kleine 60 GB für schmales Geld genommen. Ich bin davon ausgegangen, dass das Speichermanagement der SSD gut genug sein müsste, den Verschleiß der SSD im Zaum zu halten.

      Hier der gewünschte Auszug der config.xml

      Source Code

      1. <fstab>
      2. <!--
      3. <mntent>
      4. <uuid>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx</uuid>
      5. <fsname>xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx|xxxx-xxxx|/dev/xxx</fsname>
      6. <dir>/xxx/yyy/zzz</dir>
      7. <type>none|ext2|ext3|ext4|xfs|jfs|iso9660|udf|...</type>
      8. <opts></opts>
      9. <freq>0</freq>
      10. <passno>0|1|2</passno>
      11. <hidden>0|1</hidden>
      12. </mntent>
      13. -->
      14. <mntent>
      15. <uuid>d1d165e1-6cec-429a-93f5-978c5ac56e88</uuid>
      16. <fsname>ac8a4d8a-01a1-4a81-acc5-3f60853d3e28</fsname>
      17. <dir>/media/ac8a4d8a-01a1-4a81-acc5-3f60853d3e28</dir>
      18. <type>ext4</type>
      19. <opts>defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,discard,acl</opts>
      20. <freq>0</freq>
      21. <passno>2</passno>
      22. <hidden>0</hidden>
      23. </mntent>
      24. <mntent>
      25. <uuid>e34532d3-f7ac-431f-8f3d-301d9a6ee7a4</uuid>
      26. <fsname>edcb0b50-cc11-480b-87b5-f5fac9660d20</fsname>
      27. <dir>/media/edcb0b50-cc11-480b-87b5-f5fac9660d20</dir>
      28. <type>ext4</type>
      29. <opts>defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0,acl</opts>
      30. <freq>0</freq>
      31. <passno>2</passno>
      32. <hidden>0</hidden>
      33. </mntent>
      34. </fstab>
      Display All


      und hier die openmediavault-system.conf

      Source Code

      1. check system localhost
      2. if loadavg (1min) > 4 for 3 cycles then alert
      3. if loadavg (5min) > 2 for 3 cycles then alert
      4. if memory usage > 90% then alert
      5. if cpu usage (user) > 95% then alert
      6. if cpu usage (system) > 95% then alert
      7. if cpu usage (wait) > 95% then alert

    • Looks like a monit issue. Try omv-mkconf monit and then try creating the nfs share.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Reinstall should definitely fix the problem unless the drive that OMV is installed on is bad.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!