[HELP] Can't Log in on the Web-Gui with right credentials

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • subzero79. Good call.

      Yes, you are correct. The drive was filled at 100%. A quick removal of some huge files and web GUI admin work again....got into the system.

      But I had another system a couple days ago, OMV running in a KVM based VM where I had a similar situation. It was a fresh install of OMV, no patches applied....so the disk was practically empty. Could not get into the web GUI. Don't have this VM any longer but I'll monitor the situation and see if it occurs again.

      Thanks much for the help.
    • I'm getting the same login loop, and I've checked the usual suspects:

      - Disk is not full:

      Source Code

      1. root@hippo:/# df -h
      2. Sys. fich. Taille Util. Dispo Uti% Monté sur
      3. rootfs 16G 6,5G 8,0G 45% /
      4. udev 10M 0 10M 0% /dev
      5. tmpfs 788M 1,7M 787M 1% /run
      6. /dev/disk/by-uuid/c40bf765-2c41-4344-b9e8-e4f6e14ef520 16G 6,5G 8,0G 45% /
      7. tmpfs 5,0M 0 5,0M 0% /run/lock
      8. tmpfs 2,2G 1,3M 2,2G 1% /run/shm
      9. tmpfs 3,9G 0 3,9G 0% /tmp
      10. /dev/md127 931G 789G 143G 85% /media/36333d82-b684-420d-84f1-c03d5a3ff870
      11. /dev/sdc1 2,7T 2,2T 535G 81% /media/66b650a2-72ad-4db3-89cf-efa661ac564f
      12. /dev/sdd3 55G 9,5G 43G 19% /media/a62cc2b0-d262-4d58-aa30-0639364a9fa3
      13. /dev/sdb1 1,8T 782G 1,1T 43% /media/e743a233-933d-448c-bbc0-554d783065a4
      Display All


      - Authentication works fine, it just loops back to the login screen.

      Source Code

      1. May 31 18:53:43 hippo openmediavault-webgui[30732]: Authorized login from ::ffff:192.168.1.17 [username=admin, user-agent=Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/50.0.2661.102 Safari/537.36]


      - Tried to reset the password through omv-firstaid, same result. Also tried to reboot.

      nginx and php5-fpm are running fine.

      The post was edited 1 time, last by Nibb31 ().

    • What is the output of:

      dpkg -l | grep nginx

      And maybe try rewriting the config files.
      omv-mkconf nginx
      omv-mkconf php5fpm
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Source Code

      1. ​dpkg -l | grep nginx
      2. ii nginx 1.2.1-2.2+wheezy4 all small, powerful, scalable web/proxy server
      3. ii nginx-common 1.2.1-2.2+wheezy4 all small, powerful, scalable web/proxy server - common files
      4. ii nginx-full 1.2.1-2.2+wheezy4 amd64 nginx web/proxy server (standard version)
      5. ii openmediavault-nginx 2.4 all Nginx plugin for OpenMediaVault.


      Rewriting the configs and restarting php5-fpm and nginx didn't help... :(
    • You have to restart the services after rewriting the configs.

      service nginx restart
      service php5-fpm restart
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • 80GB Intel 310 mSATA with SATA adapter, about a year old running 24/7, no flashmemory plugin... You think it might be corrupted ?

      I just ran a /forcefsck:

      Brainfuck Source Code

      1. root@hippo:/var/log/fsck# tail checkroot
      2. Log of fsck -C -f -a -t ext4 /dev/sdd1
      3. Tue May 31 21:08:58 2016
      4. fsck from util-linux 2.20.1
      5. SYSTEM: 200375/1024000 files (0.3% non-contiguous), 1791499/4096000 blocks
      6. Tue May 31 21:09:00 2016
      7. ----------------
      8. root@hippo:/var/log/fsck# tail checkfs
      9. Tue May 31 21:09:01 2016
      10. fsck from util-linux 2.20.1
      11. /sbin/fsck.xfs: XFS file system.
      12. VM: 244963/3661824 files (0.1% non-contiguous), 2744156/14638080 blocks
      13. DATA1: 253376/122101760 files (1.5% non-contiguous), 212434934/488378385 blocks
      14. DATA2: 462185/183148544 files (1.2% non-contiguous), 592435653/732566385 blocks
      15. Tue May 31 21:12:51 2016
      16. ----------------
      Display All


      Looking good to me. Any other log files you think I could look at?

      The post was edited 1 time, last by Nibb31 ().

    • Maybe this?

      Source Code

      1. ​root@hippo:/var/log/nginx# tail openmediavault-webgui_error.log
      2. 2016/05/31 21:42:07 [error] 19640#0: *3 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_h1ngv2vhbjpfq0g737bb0chdk1, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48
      3. PHP message: PHP Warning: session_commit(): open(/var/lib/php5/sess_fpiupp7vtcrp1ruhhojgscbrp2, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 55
      4. PHP message: PHP Warning: session_commit(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/var/lib/php5) in /usr/share/php/openmediavault/session.inc on line 55" while reading response header from upstream, client: ::ffff:192.168.1.17, server: openmediavault-webgui, request: "POST /rpc.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "hippo:8040", referrer: "http://hippo:8040/"
      5. 2016/05/31 21:42:08 [error] 19640#0: *3 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_fpiupp7vtcrp1ruhhojgscbrp2, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:192.168.1.17, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "hippo:8040", referrer: "http://hippo:8040/"
      6. 2016/05/31 21:42:28 [error] 19640#0: *12 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_i2e4jomm4cvhaibjaf9plk0v12, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "127.0.0.1:8040"
      7. 2016/05/31 21:42:58 [error] 19640#0: *14 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_0s9dcd5fq8lsgmrdsp280hj7p7, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "127.0.0.1:8040"
      8. 2016/05/31 21:43:29 [error] 19640#0: *16 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_od4o62foi9hatcsu6rr8sdl021, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "127.0.0.1:8040"
      9. 2016/05/31 21:43:59 [error] 19640#0: *18 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_irrfq7sml29n78r4566h03qor5, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "127.0.0.1:8040"
      10. 2016/05/31 21:44:29 [error] 19640#0: *20 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_c8tctr4blmviepb1skc39u75k3, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "127.0.0.1:8040"
      11. 2016/05/31 21:44:59 [error] 19640#0: *22 FastCGI sent in stderr: "PHP message: PHP Warning: session_start(): open(/var/lib/php5/sess_dblnqtbkmvdhrooc657hl90pa1, O_RDWR) failed: Permission denied (13) in /usr/share/php/openmediavault/session.inc on line 48" while reading response header from upstream, client: ::ffff:127.0.0.1, server: openmediavault-webgui, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php5-fpm-openmediavault-webgui.sock:", host: "127.0.0.1:8040"
      Display All
    • Not sure but you have missing directories... Try:
      mkdir -p /var/lib/php5/sessions
      mkdir -p /var/lib/php5/modules
      chmod 1733 /var/lib/php5/sessions
      chmod 0755 /var/lib/php5/modules
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • Source Code

      1. ​root@hippo:/var# mkdir -p /var/lib/php5/sessions
      2. root@hippo:/var# mkdir -p /var/lib/php5/modules
      3. root@hippo:/var# chmod 1733 /var/lib/php5/sessions
      4. root@hippo:/var# chmod 0755 /var/lib/php5/modules
      5. root@hippo:/var# ls -al /var/lib/php5/
      6. total 88
      7. drwxr-xr-x 4 root root 73728 mai 31 22:05 .
      8. drwxr-xr-x 45 root root 4096 mai 4 22:00 ..
      9. drwxr-xr-x 2 root root 4096 mai 31 22:05 modules
      10. drwx-wx-wt 2 root root 4096 mai 31 22:05 sessions
      11. root@hippo:/var# omv-mkconf php5fpm
      12. root@hippo:/var# omv-mkconf nginx
      13. root@hippo:/var# service php5-fpm restart
      14. Restarting PHP5 FastCGI Process Manager: php5-fpm.
      15. root@hippo:/var# service nginx restart
      16. Restarting nginx: nginx.
      Display All


      You think I should uninstall and reinstall php5 ?
    • Happend once to me.

      Happend once to me.

      Stoneburner 250GB SSD fresh install with only hard drives mounted, SSH enabled, OMV-Extras installed and no other plugins ... resolved by OMV-firstaid ... only happened once.
      OMV 2 |64 bit|

      Your Test Results are back: You are Granted License to Own a Computer But Your Recent Score Does Not Allow For You To Connect a Mouse and Keyboard to it.
      You may study and retake the Exam ... If your score is sufficiently improved the License may be upgraded to allow for Mouse and Keyboard Connection.